Fix for emacs bug 112144, style_changed_cb (#922519)
This commit is contained in:
parent
9d699accf8
commit
a50699a537
15
emacs-style-change-cb.patch
Normal file
15
emacs-style-change-cb.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff --git a/src/gtkutil.c b/src/gtkutil.c
|
||||||
|
index e76b0a7..b3aa335 100644
|
||||||
|
--- a/src/gtkutil.c
|
||||||
|
+++ b/src/gtkutil.c
|
||||||
|
@@ -1079,7 +1079,9 @@ style_changed_cb (GObject *go,
|
||||||
|
FOR_EACH_FRAME (rest, frame)
|
||||||
|
{
|
||||||
|
FRAME_PTR f = XFRAME (frame);
|
||||||
|
- if (FRAME_X_DISPLAY (f) == dpy)
|
||||||
|
+ if (FRAME_LIVE_P (f)
|
||||||
|
+ && FRAME_X_P (f)
|
||||||
|
+ && FRAME_X_DISPLAY (f) == dpy)
|
||||||
|
{
|
||||||
|
x_set_scroll_bar_default_width (f);
|
||||||
|
xg_frame_set_char_size (f, FRAME_COLS (f), FRAME_LINES (f));
|
10
emacs.spec
10
emacs.spec
@ -3,7 +3,7 @@ Summary: GNU Emacs text editor
|
|||||||
Name: emacs
|
Name: emacs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 24.3
|
Version: 24.3
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/emacs/
|
URL: http://www.gnu.org/software/emacs/
|
||||||
Group: Applications/Editors
|
Group: Applications/Editors
|
||||||
@ -18,6 +18,9 @@ Source6: emacs-terminal.desktop
|
|||||||
Source7: emacs-terminal.sh
|
Source7: emacs-terminal.sh
|
||||||
# rhbz#713600
|
# rhbz#713600
|
||||||
Patch7: emacs-spellchecker.patch
|
Patch7: emacs-spellchecker.patch
|
||||||
|
|
||||||
|
# Fix for emacs bug #922519
|
||||||
|
Patch10: emacs-style-change-cb.patch
|
||||||
# Fix for emacs bug #13460.
|
# Fix for emacs bug #13460.
|
||||||
Patch100: emacs-24.3-hunspell.patch
|
Patch100: emacs-24.3-hunspell.patch
|
||||||
|
|
||||||
@ -154,6 +157,8 @@ packages that add functionality to Emacs.
|
|||||||
|
|
||||||
%patch7 -p1 -b .spellchecker
|
%patch7 -p1 -b .spellchecker
|
||||||
|
|
||||||
|
%patch10 -p1 -b .style-change-cb.patch
|
||||||
|
|
||||||
%patch100 -p1 -b .hunspell
|
%patch100 -p1 -b .hunspell
|
||||||
|
|
||||||
# We prefer our emacs.desktop file
|
# We prefer our emacs.desktop file
|
||||||
@ -434,6 +439,9 @@ update-desktop-database &> /dev/null || :
|
|||||||
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 28 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-3
|
||||||
|
- Fix for emacs bug 112144, style_changed_cb (#922519)
|
||||||
|
|
||||||
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-2
|
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-2
|
||||||
- fix #927996 correcting bug. Info pages were not delivered
|
- fix #927996 correcting bug. Info pages were not delivered
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user