update to 25.1 rc1
This commit is contained in:
parent
47162ef150
commit
7f81767e62
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
|||||||
/emacs-25.0.93.tar.xz
|
/emacs-25.0.93.tar.xz
|
||||||
/emacs-25.0.94.tar.xz
|
/emacs-25.0.94.tar.xz
|
||||||
/emacs-25.0.95.tar.xz
|
/emacs-25.0.95.tar.xz
|
||||||
|
/emacs-25.1-rc1.tar.xz
|
||||||
|
@ -1,62 +0,0 @@
|
|||||||
commit ff3fc21e24edffccce0d42065833e852a6792bd2
|
|
||||||
Author: Paul Eggert <eggert@cs.ucla.edu>
|
|
||||||
Date: Tue Jul 19 15:23:14 2016 +0200
|
|
||||||
|
|
||||||
Port to glibc 2.24 (pre-release) + ppc64
|
|
||||||
|
|
||||||
Backport from master (Bug#24033).
|
|
||||||
Inspired by a suggestion by Florian Weimer in:
|
|
||||||
https://sourceware.org/ml/libc-alpha/2016-07/msg00425.html
|
|
||||||
* src/emacs.c (main) [__PPC64__]:
|
|
||||||
Special case for __PPC64__, which needs ASLR disabled in
|
|
||||||
dumped Emacs too.
|
|
||||||
|
|
||||||
diff --git a/src/emacs.c b/src/emacs.c
|
|
||||||
index 5c187e7..2480dfc 100644
|
|
||||||
--- a/src/emacs.c
|
|
||||||
+++ b/src/emacs.c
|
|
||||||
@@ -674,6 +674,26 @@ main (int argc, char **argv)
|
|
||||||
|
|
||||||
stack_base = &dummy;
|
|
||||||
|
|
||||||
+#if defined HAVE_PERSONALITY_LINUX32 && defined __PPC64__
|
|
||||||
+ /* This code partly duplicates the HAVE_PERSONALITY_LINUX32 code
|
|
||||||
+ below. This duplication is planned to be fixed in a later
|
|
||||||
+ Emacs release. */
|
|
||||||
+# define ADD_NO_RANDOMIZE 0x0040000
|
|
||||||
+ int pers = personality (0xffffffff);
|
|
||||||
+ if (! (pers & ADD_NO_RANDOMIZE)
|
|
||||||
+ && 0 <= personality (pers | ADD_NO_RANDOMIZE))
|
|
||||||
+ {
|
|
||||||
+ /* Address randomization was enabled, but is now disabled.
|
|
||||||
+ Re-execute Emacs to get a clean slate. */
|
|
||||||
+ execvp (argv[0], argv);
|
|
||||||
+
|
|
||||||
+ /* If the exec fails, warn the user and then try without a
|
|
||||||
+ clean slate. */
|
|
||||||
+ perror (argv[0]);
|
|
||||||
+ }
|
|
||||||
+# undef ADD_NO_RANDOMIZE
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
#ifndef CANNOT_DUMP
|
|
||||||
might_dump = !initialized;
|
|
||||||
#endif
|
|
||||||
@@ -784,7 +804,7 @@ main (int argc, char **argv)
|
|
||||||
dumping = !initialized && (strcmp (argv[argc - 1], "dump") == 0
|
|
||||||
|| strcmp (argv[argc - 1], "bootstrap") == 0);
|
|
||||||
|
|
||||||
-#ifdef HAVE_PERSONALITY_LINUX32
|
|
||||||
+#if defined HAVE_PERSONALITY_LINUX32 && !defined __PPC64__
|
|
||||||
if (dumping && ! getenv ("EMACS_HEAP_EXEC"))
|
|
||||||
{
|
|
||||||
/* Set this so we only do this once. */
|
|
||||||
@@ -801,7 +821,7 @@ main (int argc, char **argv)
|
|
||||||
/* If the exec fails, try to dump anyway. */
|
|
||||||
emacs_perror (argv[0]);
|
|
||||||
}
|
|
||||||
-#endif /* HAVE_PERSONALITY_LINUX32 */
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#if defined (HAVE_SETRLIMIT) && defined (RLIMIT_STACK) && !defined (CYGWIN)
|
|
||||||
/* Extend the stack space available. Don't do that if dumping,
|
|
12
emacs.spec
12
emacs.spec
@ -4,12 +4,13 @@
|
|||||||
Summary: GNU Emacs text editor
|
Summary: GNU Emacs text editor
|
||||||
Name: emacs
|
Name: emacs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 25.0.95
|
Version: 25.1
|
||||||
Release: 4%{?dist}
|
Release: 0.1.rc1%{?dist}
|
||||||
License: GPLv3+ and CC0-1.0
|
License: GPLv3+ and CC0-1.0
|
||||||
URL: http://www.gnu.org/software/emacs/
|
URL: http://www.gnu.org/software/emacs/
|
||||||
Group: Applications/Editors
|
Group: Applications/Editors
|
||||||
Source0: ftp://ftp.gnu.org/gnu/emacs/emacs-%{version}.tar.xz
|
#Source0: ftp://ftp.gnu.org/gnu/emacs/emacs-%{version}.tar.xz
|
||||||
|
Source0: ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{version}-rc1.tar.xz
|
||||||
Source1: emacs.desktop
|
Source1: emacs.desktop
|
||||||
Source3: dotemacs.el
|
Source3: dotemacs.el
|
||||||
Source4: site-start.el
|
Source4: site-start.el
|
||||||
@ -25,7 +26,6 @@ Patch1: emacs-spellchecker.patch
|
|||||||
# Fix for default PDF viewer bug #971162
|
# Fix for default PDF viewer bug #971162
|
||||||
Patch2: emacs-pdf-default.patch
|
Patch2: emacs-pdf-default.patch
|
||||||
Patch3: emacs-system-crypto-policies.patch
|
Patch3: emacs-system-crypto-policies.patch
|
||||||
Patch4: emacs-ppc64.patch
|
|
||||||
|
|
||||||
BuildRequires: atk-devel
|
BuildRequires: atk-devel
|
||||||
BuildRequires: cairo-devel
|
BuildRequires: cairo-devel
|
||||||
@ -168,7 +168,6 @@ packages that add functionality to Emacs.
|
|||||||
%patch1 -p1 -b .spellchecker
|
%patch1 -p1 -b .spellchecker
|
||||||
%patch2 -p1 -b .pdf-default.patch
|
%patch2 -p1 -b .pdf-default.patch
|
||||||
%patch3 -p1 -b .system-crypto-policies
|
%patch3 -p1 -b .system-crypto-policies
|
||||||
%patch4 -p1 -b .ppc64
|
|
||||||
autoconf
|
autoconf
|
||||||
|
|
||||||
# We prefer our emacs.desktop file
|
# We prefer our emacs.desktop file
|
||||||
@ -448,6 +447,9 @@ update-desktop-database &> /dev/null || :
|
|||||||
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 25 2016 Jan Synáček <jsynacek@redhat.com> - 1:25.1-0.1.rc1
|
||||||
|
- update to 25.1 rc1
|
||||||
|
|
||||||
* Fri Jul 22 2016 Jan Synáček <jsynacek@redhat.com> - 1:25.0.95-4
|
* Fri Jul 22 2016 Jan Synáček <jsynacek@redhat.com> - 1:25.0.95-4
|
||||||
- fix: emacs build failure due to high memory consumption on ppc64 (#1356919)
|
- fix: emacs build failure due to high memory consumption on ppc64 (#1356919)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user