import emacs-27.2-6.el9

This commit is contained in:
CentOS Sources 2022-05-17 04:42:37 -04:00 committed by Stepan Oksanichenko
commit 7da7725375
15 changed files with 2489 additions and 0 deletions

2
.emacs.metadata Normal file
View File

@ -0,0 +1,2 @@
8d18e2bfb6e28cf060ce7587290954e9c582aa25 SOURCES/emacs-27.2.tar.xz
4898b4750740a0b711bb140a2fad512d80a991b0 SOURCES/gpgkey-E6C9029C363AD41D787A8EBB91C1262F01EB8D39.gpg

2
.gitignore vendored Normal file
View File

@ -0,0 +1,2 @@
SOURCES/emacs-27.2.tar.xz
SOURCES/gpgkey-E6C9029C363AD41D787A8EBB91C1262F01EB8D39.gpg

7
SOURCES/default.el Normal file
View File

@ -0,0 +1,7 @@
;;; default.el - loaded after ".emacs" on startup
;;;
;;; Setting `inhibit-default-init' non-nil in "~/.emacs"
;;; prevents loading of this file. Also the "-q" option to emacs
;;; prevents both "~/.emacs" and this file from being loaded at startup.
(setq-default smime-CA-directory "/etc/ssl/certs")

12
SOURCES/dotemacs.el Normal file
View File

@ -0,0 +1,12 @@
;; .emacs
(custom-set-variables
;; uncomment to always end a file with a newline
;'(require-final-newline t)
;; uncomment to disable loading of "default.el" at startup
;'(inhibit-default-init t)
;; default to unified diffs
'(diff-switches "-u"))
;;; uncomment for CJK utf-8 support for non-Asian users
;; (require 'un-define)

View File

@ -0,0 +1,11 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
iQEcBAABAgAGBQJgXHmkAAoJEJHBJi8B6405d2EIAIPafSj+sV3Hemu9CSPL+F38
KutOo7nUF1AO0tgdijPGZ4BTBsWnsum0dLQ/JLtor7/NQuqrZTMJQbrorLluwCR7
p1aVtwQ+enWn3G0Aq/4uWo0xaMCvJlEPOQuYE8Dtt12PFZzmfAE1r4KZa4cL073h
suugT/tz7awq7QS6GbjI88mkJXVMuEwVYPPS2tzBUTkA2152dikFSyqBhUnIo3Ni
eDN6NvSYBpL1I9HgNYuiBJp9xv8CzGtwm/7Nidntzl9SPVQlZkZIHNj8tRbE67Ge
R0EXBgnDsSKlRUM51R7PejnSG6134VcLCaItMF6dIiVBu6BwQXw1t+zdqnzG6v8=
=L6J6
-----END PGP SIGNATURE-----

View File

@ -0,0 +1,40 @@
From f97e07ea807cc6d38774a3888a15091b20645ac6 Mon Sep 17 00:00:00 2001
From: Paul Eggert <eggert@cs.ucla.edu>
Date: Tue, 9 Mar 2021 11:22:59 -0800
Subject: [PATCH] Port alternate signal stack to upcoming glibc 2.34
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
* src/sysdep.c (sigsegv_stack): Increase size to 64 KiB and align
it to max_align_t. This copies from Gnulibs c-stack.c, and works
around a portability bug in draft glibc 2.34, which no longer
defines SIGSTKSZ when _GNU_SOURCE is defined.
---
src/sysdep.c | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/sysdep.c b/src/sysdep.c
index 941b4e2fa2..24d8832b2f 100644
--- a/src/sysdep.c
+++ b/src/sysdep.c
@@ -1785,7 +1785,15 @@ handle_arith_signal (int sig)
/* Alternate stack used by SIGSEGV handler below. */
-static unsigned char sigsegv_stack[SIGSTKSZ];
+/* Storage for the alternate signal stack.
+ 64 KiB is not too large for Emacs, and is large enough
+ for all known platforms. Smaller sizes may run into trouble.
+ For example, libsigsegv 2.6 through 2.8 have a bug where some
+ architectures use more than the Linux default of an 8 KiB alternate
+ stack when deciding if a fault was caused by stack overflow. */
+static max_align_t sigsegv_stack[(64 * 1024
+ + sizeof (max_align_t) - 1)
+ / sizeof (max_align_t)];
/* Return true if SIGINFO indicates a stack overflow. */
--
2.29.2

View File

@ -0,0 +1,16 @@
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
index 1d28de7..1daec44 100644
--- a/lisp/textmodes/ispell.el
+++ b/lisp/textmodes/ispell.el
@@ -200,9 +200,9 @@
;; cause an error; and one of the other spelling engines below is
;; almost certainly installed in any case, for enchant to use.
(defcustom ispell-program-name
- (or (executable-find "aspell")
+ (or (executable-find "hunspell")
+ (executable-find "aspell")
(executable-find "ispell")
- (executable-find "hunspell")
"ispell")
"Program invoked by \\[ispell-word] and \\[ispell-region] commands."
:type 'string

View File

@ -0,0 +1,11 @@
--- a/src/gnutls.c 2016-01-24 10:29:58.000000000 +0100
+++ b/src/gnutls.c 2016-02-02 09:32:28.477274274 +0100
@@ -1557,7 +1557,7 @@
gnutls_certificate_credentials_t x509_cred = NULL;
gnutls_anon_client_credentials_t anon_cred = NULL;
Lisp_Object global_init;
- char const *priority_string_ptr = "NORMAL"; /* default priority string. */
+ char const *priority_string_ptr = "@SYSTEM"; /* default priority string. */
char *c_hostname;
/* Placeholders for the property list elements. */

View File

@ -0,0 +1,11 @@
[Desktop Entry]
Name=Emacs Terminal
GenericName=Emacs Terminal
Comment=Emacs Terminal Mode
Exec=emacs-terminal
Icon=utilities-terminal
Type=Application
Terminal=false
Categories=Application;Utility;X-Red-Hat-Base;GTK;TerminalEmulator;
Encoding=UTF-8
StartupWMClass=Emacs

View File

@ -0,0 +1,3 @@
#!/bin/sh
exec /usr/bin/emacs -Q --eval '(term "/bin/bash")'

64
SOURCES/emacs.appdata.xml Normal file
View File

@ -0,0 +1,64 @@
<?xml version="1.0" encoding="UTF-8"?>
<!-- Copyright 2014 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> -->
<component type="desktop">
<id>emacs.desktop</id>
<metadata_license>CC0-1.0</metadata_license>
<project_license>GPL-3.0+</project_license>
<name>GNU Emacs</name>
<summary>Edit text files, view pictures and binary files</summary>
<description>
<p>
Emacs is a powerful, customizable, self-documenting, modeless
editor. It is used primarely to edit text, including text
documents, source code of programs, web pages and XML documents,
but can also be used to display and edit binary files.
</p>
<p>
Emacs allows efficient editing of text with shortcuts which
allow operating on letters, words, sentences, and paragraphs as
single units. This includes both moving around and operations
like copying, deleting, transposing, and pasting. Macros can be
conveniently defined to repeat sequences of commands. In
addition, Emacs is (partially) built in a scripting language
(elisp) which can also be used to define further functions
extending existing capabilities.
</p>
<p>
Emacs has extensive support for editing source code, including
programmable syntax highlighting, automatic indentation, source
code indexing, overview modes, and navigation based on language
specific units like functions and blocks. It is also possible to
invoke the compiler from within Emacs and easily move between
compiler output and corresponding positions in the source.
</p>
<p>
Emacs has multiple modules which provide further functionality.
This provides the capability to read mail, news, browse
pictures, read man and info pages, browse the web, execute
arbitrary programs, and more, without leaving the editor.
</p>
</description>
<screenshots>
<screenshot type="default" height="888" width="1595">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-two-buffers.png</image>
</screenshot>
<screenshot height="667" width="1199">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-editing-xml.png</image>
</screenshot>
<screenshot height="572" width="1019">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-hexl-mode.png</image>
</screenshot>
<screenshot height="667" width="1199">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-showing-svg.png</image>
</screenshot>
<screenshot height="439" width="794">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-with-python-source.png</image>
</screenshot>
</screenshots>
<url type="homepage">http://www.gnu.org/software/emacs/</url>
<url type="bugtracker">https://www.gnu.org/software/emacs/manual/html_node/emacs/Bugs.html</url>
<url type="donation">https://my.fsf.org/donate/</url>
<url type="help">https://www.gnu.org/software/emacs/manual/</url>
<update_contact>zbyszek@in.waw.pl</update_contact>
<translation/>
</component>

12
SOURCES/emacs.desktop Normal file
View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Emacs
GenericName=Text Editor
Comment=Edit text
Comment[zh_TW]=
MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
Exec=emacs %f
Icon=emacs
Type=Application
Terminal=false
Categories=Utility;TextEditor;X-Red-Hat-Base;
StartupWMClass=Emacs

11
SOURCES/emacs.service Normal file
View File

@ -0,0 +1,11 @@
[Unit]
Description=Emacs: the extensible, self-documenting text editor
[Service]
Type=forking
ExecStart=/usr/bin/emacs --daemon
ExecStop=/usr/bin/emacsclient --eval "(kill-emacs)"
Restart=always
[Install]
WantedBy=default.target

9
SOURCES/site-start.el Normal file
View File

@ -0,0 +1,9 @@
;;; loaded before user's ".emacs" file and default.el
;; load *.el and *.elc in /usr/share/emacs/site-lisp/site-start.d on startup
(mapc
'load
(delete-dups
(mapcar 'file-name-sans-extension
(directory-files
"/usr/share/emacs/site-lisp/site-start.d" t "\\.elc?\\'"))))

2278
SPECS/emacs.spec Normal file

File diff suppressed because it is too large Load Diff