Removed focus-init.el which used to set focus-follows-mouse to nil.
This commit is contained in:
parent
6f7b9b056b
commit
68a9eb0779
@ -1,33 +0,0 @@
|
||||
*** emacs-24.1/lisp/files.el~ 2012-08-13 10:54:50.256181658 +0800
|
||||
--- emacs-24.1/lisp/files.el 2012-08-13 10:54:58.076181990 +0800
|
||||
***************
|
||||
*** 3107,3117 ****
|
||||
;; Obey `enable-local-eval'.
|
||||
((eq var 'eval)
|
||||
(when enable-local-eval
|
||||
! (push elt all-vars)
|
||||
! (or (eq enable-local-eval t)
|
||||
! (hack-one-local-variable-eval-safep (eval (quote val)))
|
||||
! (safe-local-variable-p var val)
|
||||
! (push elt unsafe-vars))))
|
||||
;; Ignore duplicates (except `mode') in the present list.
|
||||
((and (assq var all-vars) (not (eq var 'mode))) nil)
|
||||
;; Accept known-safe variables.
|
||||
--- 3107,3122 ----
|
||||
;; Obey `enable-local-eval'.
|
||||
((eq var 'eval)
|
||||
(when enable-local-eval
|
||||
! (let ((safe (or (hack-one-local-variable-eval-safep
|
||||
! (eval (quote val)))
|
||||
! ;; In case previously marked safe (bug#5636).
|
||||
! (safe-local-variable-p var val))))
|
||||
! ;; If not safe and e-l-v = :safe, ignore totally.
|
||||
! (when (or safe (not (eq enable-local-variables :safe)))
|
||||
! (push elt all-vars)
|
||||
! (or (eq enable-local-eval t)
|
||||
! safe
|
||||
! (push elt unsafe-vars))))))
|
||||
;; Ignore duplicates (except `mode') in the present list.
|
||||
((and (assq var all-vars) (not (eq var 'mode))) nil)
|
||||
;; Accept known-safe variables.
|
||||
|
@ -1,49 +0,0 @@
|
||||
diff -up emacs-24.1/lib/stdio.in.h.nogets emacs-24.1/lib/stdio.in.h
|
||||
--- emacs-24.1/lib/stdio.in.h.nogets 2012-04-08 05:03:02.000000000 +0200
|
||||
+++ emacs-24.1/lib/stdio.in.h 2012-07-11 18:25:11.120972062 +0200
|
||||
@@ -699,22 +699,11 @@ _GL_WARN_ON_USE (getline, "getline is un
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#if @GNULIB_GETS@
|
||||
-# if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
|
||||
-# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
|
||||
-# undef gets
|
||||
-# define gets rpl_gets
|
||||
-# endif
|
||||
-_GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
|
||||
-_GL_CXXALIAS_RPL (gets, char *, (char *s));
|
||||
-# else
|
||||
-_GL_CXXALIAS_SYS (gets, char *, (char *s));
|
||||
-# undef gets
|
||||
-# endif
|
||||
-_GL_CXXALIASWARN (gets);
|
||||
/* It is very rare that the developer ever has full control of stdin,
|
||||
- so any use of gets warrants an unconditional warning. Assume it is
|
||||
- always declared, since it is required by C89. */
|
||||
+ so any use of gets warrants an unconditional warning; besides, C11
|
||||
+ removed it. */
|
||||
+#undef gets
|
||||
+#if HAVE_RAW_DECL_GETS
|
||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
#endif
|
||||
|
||||
diff -up emacs-24.1/m4/stdio_h.m4.nogets emacs-24.1/m4/stdio_h.m4
|
||||
--- emacs-24.1/m4/stdio_h.m4.nogets 2012-04-08 05:03:02.000000000 +0200
|
||||
+++ emacs-24.1/m4/stdio_h.m4 2012-07-11 18:25:48.112449063 +0200
|
||||
@@ -18,7 +18,6 @@ AC_DEFUN([gl_STDIO_H],
|
||||
GNULIB_GETC=1
|
||||
GNULIB_GETCHAR=1
|
||||
GNULIB_FGETS=1
|
||||
- GNULIB_GETS=1
|
||||
GNULIB_FREAD=1
|
||||
dnl This ifdef is necessary to avoid an error "missing file lib/stdio-read.c"
|
||||
dnl "expected source file, required through AC_LIBSOURCES, not found". It is
|
||||
@@ -113,7 +112,6 @@ AC_DEFUN([gl_STDIO_H_DEFAULTS],
|
||||
GNULIB_GETCHAR=0; AC_SUBST([GNULIB_GETCHAR])
|
||||
GNULIB_GETDELIM=0; AC_SUBST([GNULIB_GETDELIM])
|
||||
GNULIB_GETLINE=0; AC_SUBST([GNULIB_GETLINE])
|
||||
- GNULIB_GETS=0; AC_SUBST([GNULIB_GETS])
|
||||
GNULIB_OBSTACK_PRINTF=0; AC_SUBST([GNULIB_OBSTACK_PRINTF])
|
||||
GNULIB_OBSTACK_PRINTF_POSIX=0; AC_SUBST([GNULIB_OBSTACK_PRINTF_POSIX])
|
||||
GNULIB_PCLOSE=0; AC_SUBST([GNULIB_PCLOSE])
|
12
emacs.spec
12
emacs.spec
@ -3,7 +3,7 @@ Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 24.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
@ -13,9 +13,8 @@ Source2: emacsclient.desktop
|
||||
Source3: dotemacs.el
|
||||
Source4: site-start.el
|
||||
# rpm-spec-mode from XEmacs
|
||||
Source10: rpm-spec-mode.el
|
||||
Source10: https://bitbucket.org/xemacs/prog-modes/raw/eacc4cb30d0c/rpm-spec-mode.el
|
||||
Source11: rpm-spec-mode-init.el
|
||||
Source13: focus-init.el
|
||||
Source18: default.el
|
||||
# Emacs Terminal Mode, #551949, #617355
|
||||
Source19: emacs-terminal.desktop
|
||||
@ -136,7 +135,6 @@ Requires: emacs = %{epoch}:%{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description terminal
|
||||
|
||||
Contains a desktop menu item running GNU Emacs terminal. Install
|
||||
emacs-terminal if you need a terminal with Malayalam support.
|
||||
|
||||
@ -293,7 +291,7 @@ mv %{buildroot}%{_bindir}/{ctags,gctags}
|
||||
install -p -m 0644 site-lisp/*.el{,c} %{buildroot}%{site_lisp}
|
||||
|
||||
mkdir -p %{buildroot}%{site_lisp}/site-start.d
|
||||
install -p -m 0644 %SOURCE11 %SOURCE13 %{buildroot}%{site_lisp}/site-start.d
|
||||
install -p -m 0644 %SOURCE11 %{buildroot}%{site_lisp}/site-start.d
|
||||
|
||||
# Default initialization file
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/skel
|
||||
@ -447,6 +445,10 @@ update-desktop-database &> /dev/null || :
|
||||
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
||||
|
||||
%changelog
|
||||
* Thu Sep 13 2012 Karel Klíč <kklic@redhat.com> - 1:24.2-2
|
||||
- Removed focus-init.el which used to set focus-follows-mouse to nil.
|
||||
It is set to nil by default in Emacs 24.2.
|
||||
|
||||
* Thu Sep 13 2012 Karel Klíč <kklic@redhat.com> - 1:24.2-1
|
||||
- Updated to the newest upstream release
|
||||
- Switched from bz2 upstream package to xz
|
||||
|
@ -1,3 +0,0 @@
|
||||
(when window-system
|
||||
;; make switching frames works properly under the default click-to-focus
|
||||
(setq focus-follows-mouse nil))
|
Loading…
Reference in New Issue
Block a user