Moved RPM spec mode to a separate package (rhbz#857865)
This commit is contained in:
parent
ad2b01fd98
commit
4e102e7897
31
emacs.spec
31
emacs.spec
@ -3,7 +3,7 @@ Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 24.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
@ -12,16 +12,10 @@ Source1: emacs.desktop
|
||||
Source2: emacsclient.desktop
|
||||
Source3: dotemacs.el
|
||||
Source4: site-start.el
|
||||
# rpm-spec-mode from XEmacs
|
||||
Source10: https://bitbucket.org/xemacs/prog-modes/raw/eacc4cb30d0c/rpm-spec-mode.el
|
||||
Source11: rpm-spec-mode-init.el
|
||||
Source18: default.el
|
||||
Source5: default.el
|
||||
# Emacs Terminal Mode, #551949, #617355
|
||||
Source19: emacs-terminal.desktop
|
||||
Source20: emacs-terminal.sh
|
||||
Patch1: rpm-spec-mode.patch
|
||||
Patch2: rpm-spec-mode-utc.patch
|
||||
Patch3: rpm-spec-mode-changelog.patch
|
||||
Source6: emacs-terminal.desktop
|
||||
Source7: emacs-terminal.sh
|
||||
# rhbz#713600
|
||||
Patch7: emacs-spellchecker.patch
|
||||
# rhbz#830162, fixed in org-mode upstream
|
||||
@ -156,14 +150,6 @@ packages that add functionality to Emacs.
|
||||
%patch7 -p1 -b .spellchecker
|
||||
%patch8 -p1 -b .locate-library
|
||||
|
||||
# Install site-lisp files
|
||||
cp %SOURCE10 site-lisp
|
||||
pushd site-lisp
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
%patch3 -p0
|
||||
popd
|
||||
|
||||
# We prefer our emacs.desktop file
|
||||
cp %SOURCE1 etc/emacs.desktop
|
||||
|
||||
@ -274,7 +260,7 @@ chmod 755 %{buildroot}%{emacs_libexecdir}/movemail
|
||||
|
||||
mkdir -p %{buildroot}%{site_lisp}
|
||||
install -p -m 0644 %SOURCE4 %{buildroot}%{site_lisp}/site-start.el
|
||||
install -p -m 0644 %SOURCE18 %{buildroot}%{site_lisp}
|
||||
install -p -m 0644 %SOURCE5 %{buildroot}%{site_lisp}
|
||||
|
||||
# This solves bz#474958, "update-directory-autoloads" now finally
|
||||
# works the path is different each version, so we'll generate it here
|
||||
@ -308,7 +294,7 @@ mkdir -p %{buildroot}%{_sysconfdir}/rpm
|
||||
install -p -m 0644 macros.emacs %{buildroot}%{_sysconfdir}/rpm/
|
||||
|
||||
# Installing emacs-terminal binary
|
||||
install -p -m 755 %SOURCE20 %{buildroot}%{_bindir}/emacs-terminal
|
||||
install -p -m 755 %SOURCE7 %{buildroot}%{_bindir}/emacs-terminal
|
||||
|
||||
# After everything is installed, remove info dir
|
||||
rm -f %{buildroot}%{_infodir}/dir
|
||||
@ -319,7 +305,7 @@ mkdir -p %{buildroot}%{_datadir}/applications
|
||||
desktop-file-install --dir=%{buildroot}%{_datadir}/applications \
|
||||
%SOURCE1
|
||||
desktop-file-install --dir=%{buildroot}%{_datadir}/applications \
|
||||
%SOURCE19
|
||||
%SOURCE6
|
||||
|
||||
# Byte compile emacs*.py with correct python interpreters
|
||||
%if 0%{!?el6:1}
|
||||
@ -444,6 +430,9 @@ update-desktop-database &> /dev/null || :
|
||||
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
||||
|
||||
%changelog
|
||||
* Fri Sep 14 2012 Karel Klíč <kklic@redhat.com> - 1:24.2-4
|
||||
- Moved RPM spec mode to a separate package (rhbz#857865)
|
||||
|
||||
* Fri Sep 14 2012 Karel Klíč <kklic@redhat.com> - 1:24.2-3
|
||||
- Removed patch glibc-open-macro, which seems to be no longer necessary
|
||||
|
||||
|
@ -1,48 +0,0 @@
|
||||
diff -up rpm-spec-mode.el.orig site-lisp/rpm-spec-mode.el
|
||||
--- rpm-spec-mode.el.orig 2011-11-10 17:22:20.000000000 +0100
|
||||
+++ rpm-spec-mode.el 2011-11-23 15:59:13.959987280 +0100
|
||||
@@ -491,6 +491,7 @@ value returned by function `user-mail-ad
|
||||
(set-keymap-name rpm-spec-mode-map 'rpm-spec-mode-map))
|
||||
(define-key rpm-spec-mode-map "\C-c\C-c" 'rpm-change-tag)
|
||||
(define-key rpm-spec-mode-map "\C-c\C-e" 'rpm-add-change-log-entry)
|
||||
+ (define-key rpm-spec-mode-map "\C-c\C-w" 'rpm-goto-add-change-log-entry)
|
||||
(define-key rpm-spec-mode-map "\C-c\C-i" 'rpm-insert-tag)
|
||||
(define-key rpm-spec-mode-map "\C-c\C-n" 'rpm-forward-section)
|
||||
(define-key rpm-spec-mode-map "\C-c\C-o" 'rpm-goto-section)
|
||||
@@ -719,10 +720,8 @@ This variable is global by default, but
|
||||
If `rpm-change-log-uses-utc' is nil, \"today\" means the local time zone."
|
||||
(format-time-string "%a %b %e %Y" nil rpm-change-log-uses-utc))
|
||||
|
||||
-(defun rpm-add-change-log-entry (&optional change-log-entry)
|
||||
- "Find change log and add an entry for today."
|
||||
- (interactive "sChange log entry: ")
|
||||
- (save-excursion
|
||||
+(defun rpm-goto-add-change-log-header ()
|
||||
+ "Find change log and add header (if needed) for today"
|
||||
(rpm-goto-section "changelog")
|
||||
(let* ((address (rpm-spec-user-mail-address))
|
||||
(fullname (or rpm-spec-user-full-name (user-full-name)))
|
||||
@@ -733,8 +732,21 @@ If `rpm-change-log-uses-utc' is nil, \"t
|
||||
(concat " - " (rpm-find-spec-version t))))))
|
||||
(if (not (search-forward string nil t))
|
||||
(insert "\n" string "\n")
|
||||
- (forward-line 2))
|
||||
- (insert "- " change-log-entry "\n"))))
|
||||
+ (forward-line 2))))
|
||||
+
|
||||
+(defun rpm-add-change-log-entry (&optional change-log-entry)
|
||||
+ "Find change log and add an entry for today."
|
||||
+ (interactive "sChange log entry: ")
|
||||
+ (save-excursion
|
||||
+ (rpm-goto-add-change-log-header)
|
||||
+ (insert "- " change-log-entry "\n")))
|
||||
+
|
||||
+(defun rpm-goto-add-change-log-entry ()
|
||||
+ "Goto change log and add an header for today (if needed)."
|
||||
+ (interactive)
|
||||
+ (rpm-goto-add-change-log-header)
|
||||
+ (insert "- \n")
|
||||
+ (end-of-line '0))
|
||||
|
||||
;;------------------------------------------------------------
|
||||
|
@ -1,5 +0,0 @@
|
||||
;; rpm-spec-mode for spec files
|
||||
|
||||
(autoload 'rpm-spec-mode "rpm-spec-mode" "RPM spec mode." t)
|
||||
(add-to-list 'auto-mode-alist '("\\.spec\\(\\.in\\)?$" . rpm-spec-mode))
|
||||
(setq-default rpm-change-log-uses-utc t)
|
@ -1,31 +0,0 @@
|
||||
--- rpm-spec-mode.el~ 2009-06-11 11:01:53.000000000 +0200
|
||||
+++ rpm-spec-mode.el 2009-06-11 11:05:24.000000000 +0200
|
||||
@@ -708,6 +708,17 @@
|
||||
|
||||
;;------------------------------------------------------------
|
||||
|
||||
+(defvar rpm-change-log-uses-utc nil
|
||||
+ "*If non-nil, \\[rpm-add-change-log-entry] will use Universal time (UTC).
|
||||
+If this is nil, it uses local time as returned by `current-time'.
|
||||
+
|
||||
+This variable is global by default, but you can make it buffer-local.")
|
||||
+
|
||||
+(defsubst rpm-change-log-date-string ()
|
||||
+ "Return the date string for today, inserted by \\[rpm-add-change-log-entry].
|
||||
+If `rpm-change-log-uses-utc' is nil, \"today\" means the local time zone."
|
||||
+ (format-time-string "%a %b %e %Y" nil rpm-change-log-uses-utc))
|
||||
+
|
||||
(defun rpm-add-change-log-entry (&optional change-log-entry)
|
||||
"Find change log and add an entry for today."
|
||||
(interactive "sChange log entry: ")
|
||||
@@ -715,8 +726,8 @@
|
||||
(rpm-goto-section "changelog")
|
||||
(let* ((address (rpm-spec-user-mail-address))
|
||||
(fullname (or rpm-spec-user-full-name (user-full-name)))
|
||||
- (string (concat "* " (substring (current-time-string) 0 11)
|
||||
- (substring (current-time-string) -4) " "
|
||||
+ (system-time-locale "C")
|
||||
+ (string (concat "* " (rpm-change-log-date-string) " "
|
||||
fullname " <" address ">"
|
||||
(and rpm-spec-insert-changelog-version
|
||||
(concat " - " (rpm-find-spec-version t))))))
|
1413
rpm-spec-mode.el
1413
rpm-spec-mode.el
File diff suppressed because it is too large
Load Diff
@ -1,91 +0,0 @@
|
||||
--- rpm-spec-mode.el~ 2008-04-22 15:14:40.000000000 -0400
|
||||
+++ rpm-spec-mode.el 2008-04-22 16:19:09.000000000 -0400
|
||||
@@ -63,7 +63,9 @@
|
||||
|
||||
;;; Code:
|
||||
|
||||
-(defconst rpm-spec-mode-version "0.12.3x" "Version of `rpm-spec-mode'.")
|
||||
+(require 'compile)
|
||||
+
|
||||
+(defconst rpm-spec-mode-version "0.12.3x.rh1" "Version of `rpm-spec-mode'.")
|
||||
|
||||
(defgroup rpm-spec nil
|
||||
"RPM spec mode with Emacs/XEmacs enhancements."
|
||||
@@ -189,11 +191,6 @@
|
||||
:type 'boolean
|
||||
:group 'rpm-spec)
|
||||
|
||||
-(defcustom rpm-spec-use-compilation-mode t
|
||||
- "*If non-nil, build in `compilation-mode' if it's available."
|
||||
- :type 'boolean
|
||||
- :group 'rpm-spec)
|
||||
-
|
||||
(defcustom rpm-spec-default-release "1"
|
||||
"*Default value for the Release tag in new spec files."
|
||||
:type 'string
|
||||
@@ -225,6 +222,11 @@
|
||||
:type 'string
|
||||
:group 'rpm-spec)
|
||||
|
||||
+(defcustom rpm-spec-auto-topdir nil
|
||||
+ "*Automatically detect an rpm build directory tree and define _topdir."
|
||||
+ :type 'boolean
|
||||
+ :group 'rpm-spec)
|
||||
+
|
||||
(defgroup rpm-spec-faces nil
|
||||
"Font lock faces for `rpm-spec-mode'."
|
||||
:prefix "rpm-spec-"
|
||||
@@ -1025,20 +1027,30 @@
|
||||
(setq buildoptions (cons "--nodeps" buildoptions)))
|
||||
(if (and rpm-spec-sign-gpg (not rpm-no-gpg))
|
||||
(setq buildoptions (cons "--sign" buildoptions)))
|
||||
- (save-excursion
|
||||
- (set-buffer (get-buffer rpm-buffer-name))
|
||||
- (and rpm-spec-use-compilation-mode
|
||||
- (fboundp 'compilation-mode)
|
||||
- (compilation-mode))
|
||||
- (goto-char (point-max)))
|
||||
- (let* ((process-environment (cons "EMACS=t" process-environment))
|
||||
- (process
|
||||
- (apply 'start-process rpm-spec-build-command rpm-buffer-name
|
||||
- rpm-spec-build-command buildoptions)))
|
||||
- (if (and rpm-spec-sign-gpg (not rpm-no-gpg))
|
||||
- (let ((rpm-passwd-cache (read-passwd "GPG passphrase: ")))
|
||||
- (process-send-string process (concat rpm-passwd-cache "\n"))))
|
||||
- (set-process-filter process 'rpm-command-filter)))
|
||||
+
|
||||
+ (if rpm-spec-auto-topdir
|
||||
+ (if (string-match ".*/SPECS/$" default-directory)
|
||||
+ (let ((topdir (expand-file-name default-directory)))
|
||||
+ (setq buildoptions
|
||||
+ (cons
|
||||
+ (concat "--define \"_topdir "
|
||||
+ (replace-regexp-in-string "/SPECS/$" "" topdir)
|
||||
+ "\"")
|
||||
+ buildoptions)))))
|
||||
+
|
||||
+ (progn
|
||||
+ (defun list->string (lst)
|
||||
+ (if (cdr lst)
|
||||
+ (concat (car lst) " " (list->string (cdr lst)))
|
||||
+ (car lst)))
|
||||
+ (compilation-start (list->string (cons rpm-spec-build-command buildoptions)) 'rpmbuild-mode))
|
||||
+
|
||||
+ (if (and rpm-spec-sign-gpg (not rpm-no-gpg))
|
||||
+ (let ((build-proc (get-buffer-process
|
||||
+ (get-buffer
|
||||
+ (compilation-buffer-name "rpmbuild" nil nil))))
|
||||
+ (rpm-passwd-cache (read-passwd "GPG passphrase: ")))
|
||||
+ (process-send-string build-proc (concat rpm-passwd-cache "\n")))))
|
||||
|
||||
(defun rpm-build-prepare (&optional arg)
|
||||
"Run a `rpmbuild -bp'."
|
||||
@@ -1409,5 +1421,8 @@
|
||||
;;;###autoload(add-to-list 'auto-mode-alist '("\\.spec\\(\\.in\\)?$" . rpm-spec-mode))
|
||||
|
||||
(provide 'rpm-spec-mode)
|
||||
+;;;###autoload
|
||||
+(define-compilation-mode rpmbuild-mode "RPM build" ""
|
||||
+ (set (make-local-variable 'compilation-disable-input) t))
|
||||
|
||||
;;; rpm-spec-mode.el ends here
|
Loading…
Reference in New Issue
Block a user