Auto sync2gitlab import of emacs-26.1-9.el8.src.rpm
This commit is contained in:
parent
7cdcdd77e0
commit
437373138f
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
||||
/emacs-26.1.tar.xz
|
||||
/package-keyring.gpg
|
7
default.el
Normal file
7
default.el
Normal file
@ -0,0 +1,7 @@
|
||||
;;; default.el - loaded after ".emacs" on startup
|
||||
;;;
|
||||
;;; Setting `inhibit-default-init' non-nil in "~/.emacs"
|
||||
;;; prevents loading of this file. Also the "-q" option to emacs
|
||||
;;; prevents both "~/.emacs" and this file from being loaded at startup.
|
||||
|
||||
(setq-default smime-CA-directory "/etc/ssl/certs")
|
12
dotemacs.el
Normal file
12
dotemacs.el
Normal file
@ -0,0 +1,12 @@
|
||||
;; .emacs
|
||||
|
||||
(custom-set-variables
|
||||
;; uncomment to always end a file with a newline
|
||||
;'(require-final-newline t)
|
||||
;; uncomment to disable loading of "default.el" at startup
|
||||
;'(inhibit-default-init t)
|
||||
;; default to unified diffs
|
||||
'(diff-switches "-u"))
|
||||
|
||||
;;; uncomment for CJK utf-8 support for non-Asian users
|
||||
;; (require 'un-define)
|
223
emacs-ctags-local-command-execute-vulnerability.patch
Normal file
223
emacs-ctags-local-command-execute-vulnerability.patch
Normal file
@ -0,0 +1,223 @@
|
||||
diff --git a/lib-src/etags.c b/lib-src/etags.c
|
||||
index 588921bc70..a156444281 100644
|
||||
--- a/lib-src/etags.c
|
||||
+++ b/lib-src/etags.c
|
||||
@@ -371,7 +371,7 @@ static void just_read_file (FILE *);
|
||||
|
||||
static language *get_language_from_langname (const char *);
|
||||
static void readline (linebuffer *, FILE *);
|
||||
-static long readline_internal (linebuffer *, FILE *, char const *);
|
||||
+static long readline_internal (linebuffer *, FILE *, char const *, const bool);
|
||||
static bool nocase_tail (const char *);
|
||||
static void get_tag (char *, char **);
|
||||
static void get_lispy_tag (char *);
|
||||
@@ -394,7 +394,9 @@ static void free_fdesc (fdesc *);
|
||||
static void pfnote (char *, bool, char *, int, int, long);
|
||||
static void invalidate_nodes (fdesc *, node **);
|
||||
static void put_entries (node *);
|
||||
+static void clean_matched_file_tag (char const * const, char const * const);
|
||||
|
||||
+static void do_move_file (const char *, const char *);
|
||||
static char *concat (const char *, const char *, const char *);
|
||||
static char *skip_spaces (char *);
|
||||
static char *skip_non_spaces (char *);
|
||||
@@ -1307,7 +1309,7 @@ main (int argc, char **argv)
|
||||
if (parsing_stdin)
|
||||
fatal ("cannot parse standard input "
|
||||
"AND read file names from it");
|
||||
- while (readline_internal (&filename_lb, stdin, "-") > 0)
|
||||
+ while (readline_internal (&filename_lb, stdin, "-", false) > 0)
|
||||
process_file_name (filename_lb.buffer, lang);
|
||||
}
|
||||
else
|
||||
@@ -1355,9 +1357,6 @@ main (int argc, char **argv)
|
||||
/* From here on, we are in (CTAGS && !cxref_style) */
|
||||
if (update)
|
||||
{
|
||||
- char *cmd =
|
||||
- xmalloc (strlen (tagfile) + whatlen_max +
|
||||
- sizeof "mv..OTAGS;grep -Fv '\t\t' OTAGS >;rm OTAGS");
|
||||
for (i = 0; i < current_arg; ++i)
|
||||
{
|
||||
switch (argbuffer[i].arg_type)
|
||||
@@ -1368,17 +1367,8 @@ main (int argc, char **argv)
|
||||
default:
|
||||
continue; /* the for loop */
|
||||
}
|
||||
- char *z = stpcpy (cmd, "mv ");
|
||||
- z = stpcpy (z, tagfile);
|
||||
- z = stpcpy (z, " OTAGS;grep -Fv '\t");
|
||||
- z = stpcpy (z, argbuffer[i].what);
|
||||
- z = stpcpy (z, "\t' OTAGS >");
|
||||
- z = stpcpy (z, tagfile);
|
||||
- strcpy (z, ";rm OTAGS");
|
||||
- if (system (cmd) != EXIT_SUCCESS)
|
||||
- fatal ("failed to execute shell command");
|
||||
+ clean_matched_file_tag (tagfile, argbuffer[i].what);
|
||||
}
|
||||
- free (cmd);
|
||||
append_to_tagfile = true;
|
||||
}
|
||||
|
||||
@@ -1407,6 +1397,51 @@ main (int argc, char **argv)
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
|
||||
+/*
|
||||
+ * Equivalent to: mv tags OTAGS;grep -Fv ' filename ' OTAGS >tags;rm OTAGS
|
||||
+ */
|
||||
+static void
|
||||
+clean_matched_file_tag (const char* tagfile, const char* match_file_name)
|
||||
+{
|
||||
+ FILE *otags_f = fopen ("OTAGS", "wb");
|
||||
+ FILE *tag_f = fopen (tagfile, "rb");
|
||||
+
|
||||
+ if (otags_f == NULL)
|
||||
+ pfatal ("OTAGS");
|
||||
+
|
||||
+ if (tag_f == NULL)
|
||||
+ pfatal (tagfile);
|
||||
+
|
||||
+ int buf_len = strlen (match_file_name) + sizeof ("\t\t ") + 1;
|
||||
+ char *buf = xmalloc (buf_len);
|
||||
+ snprintf (buf, buf_len, "\t%s\t", match_file_name);
|
||||
+
|
||||
+ linebuffer line;
|
||||
+ linebuffer_init (&line);
|
||||
+ while (readline_internal (&line, tag_f, tagfile, true) > 0)
|
||||
+ {
|
||||
+ if (ferror (tag_f))
|
||||
+ pfatal (tagfile);
|
||||
+
|
||||
+ if (strstr (line.buffer, buf) == NULL)
|
||||
+ {
|
||||
+ fprintf (otags_f, "%s\n", line.buffer);
|
||||
+ if (ferror (tag_f))
|
||||
+ pfatal (tagfile);
|
||||
+ }
|
||||
+ }
|
||||
+ free (buf);
|
||||
+ free (line.buffer);
|
||||
+
|
||||
+ if (fclose (otags_f) == EOF)
|
||||
+ pfatal ("OTAGS");
|
||||
+
|
||||
+ if (fclose (tag_f) == EOF)
|
||||
+ pfatal (tagfile);
|
||||
+
|
||||
+ do_move_file ("OTAGS", tagfile);
|
||||
+ return;
|
||||
+}
|
||||
|
||||
/*
|
||||
* Return a compressor given the file name. If EXTPTR is non-zero,
|
||||
@@ -1794,7 +1829,7 @@ find_entries (FILE *inf)
|
||||
|
||||
/* Else look for sharp-bang as the first two characters. */
|
||||
if (parser == NULL
|
||||
- && readline_internal (&lb, inf, infilename) > 0
|
||||
+ && readline_internal (&lb, inf, infilename, false) > 0
|
||||
&& lb.len >= 2
|
||||
&& lb.buffer[0] == '#'
|
||||
&& lb.buffer[1] == '!')
|
||||
@@ -6293,7 +6328,7 @@ analyze_regex (char *regex_arg)
|
||||
if (regexfp == NULL)
|
||||
pfatal (regexfile);
|
||||
linebuffer_init (®exbuf);
|
||||
- while (readline_internal (®exbuf, regexfp, regexfile) > 0)
|
||||
+ while (readline_internal (®exbuf, regexfp, regexfile, false) > 0)
|
||||
analyze_regex (regexbuf.buffer);
|
||||
free (regexbuf.buffer);
|
||||
if (fclose (regexfp) != 0)
|
||||
@@ -6648,11 +6683,13 @@ get_lispy_tag (register char *bp)
|
||||
|
||||
/*
|
||||
* Read a line of text from `stream' into `lbp', excluding the
|
||||
- * newline or CR-NL, if any. Return the number of characters read from
|
||||
- * `stream', which is the length of the line including the newline.
|
||||
+ * newline or CR-NL (if `leave_cr` is false), if any. Return the
|
||||
+ * number of characters read from `stream', which is the length
|
||||
+ * of the line including the newline.
|
||||
*
|
||||
- * On DOS or Windows we do not count the CR character, if any before the
|
||||
- * NL, in the returned length; this mirrors the behavior of Emacs on those
|
||||
+ * On DOS or Windows, if `leave_cr` is false, we do not count the
|
||||
+ * CR character, if any before the NL, in the returned length;
|
||||
+ * this mirrors the behavior of Emacs on those
|
||||
* platforms (for text files, it translates CR-NL to NL as it reads in the
|
||||
* file).
|
||||
*
|
||||
@@ -6660,7 +6697,7 @@ get_lispy_tag (register char *bp)
|
||||
* appended to `filebuf'.
|
||||
*/
|
||||
static long
|
||||
-readline_internal (linebuffer *lbp, FILE *stream, char const *filename)
|
||||
+readline_internal (linebuffer *lbp, FILE *stream, char const *filename, const bool leave_cr)
|
||||
{
|
||||
char *buffer = lbp->buffer;
|
||||
char *p = lbp->buffer;
|
||||
@@ -6691,7 +6728,7 @@ readline_internal (linebuffer *lbp, FILE *stream, char const *filename)
|
||||
}
|
||||
if (c == '\n')
|
||||
{
|
||||
- if (p > buffer && p[-1] == '\r')
|
||||
+ if (!leave_cr && p > buffer && p[-1] == '\r')
|
||||
{
|
||||
p -= 1;
|
||||
chars_deleted = 2;
|
||||
@@ -6736,7 +6773,7 @@ readline (linebuffer *lbp, FILE *stream)
|
||||
long result;
|
||||
|
||||
linecharno = charno; /* update global char number of line start */
|
||||
- result = readline_internal (lbp, stream, infilename); /* read line */
|
||||
+ result = readline_internal (lbp, stream, infilename, false); /* read line */
|
||||
lineno += 1; /* increment global line number */
|
||||
charno += result; /* increment global char number */
|
||||
|
||||
@@ -7104,6 +7141,46 @@ etags_mktmp (void)
|
||||
return templt;
|
||||
}
|
||||
|
||||
+static void
|
||||
+do_move_file(const char *src_file, const char *dst_file)
|
||||
+{
|
||||
+ if (rename (src_file, dst_file) == 0)
|
||||
+ return;
|
||||
+
|
||||
+ FILE *src_f = fopen (src_file, "rb");
|
||||
+ FILE *dst_f = fopen (dst_file, "wb");
|
||||
+
|
||||
+ if (src_f == NULL)
|
||||
+ pfatal (src_file);
|
||||
+
|
||||
+ if (dst_f == NULL)
|
||||
+ pfatal (dst_file);
|
||||
+
|
||||
+ int c;
|
||||
+ while ((c = fgetc (src_f)) != EOF)
|
||||
+ {
|
||||
+ if (ferror (src_f))
|
||||
+ pfatal (src_file);
|
||||
+
|
||||
+ if (ferror (dst_f))
|
||||
+ pfatal (dst_file);
|
||||
+
|
||||
+ if (fputc (c, dst_f) == EOF)
|
||||
+ pfatal ("cannot write");
|
||||
+ }
|
||||
+
|
||||
+ if (fclose (src_f) == EOF)
|
||||
+ pfatal (src_file);
|
||||
+
|
||||
+ if (fclose (dst_f) == EOF)
|
||||
+ pfatal (dst_file);
|
||||
+
|
||||
+ if (unlink (src_file) == -1)
|
||||
+ pfatal ("unlink error");
|
||||
+
|
||||
+ return;
|
||||
+}
|
||||
+
|
||||
/* Return a newly allocated string containing the file name of FILE
|
||||
relative to the absolute directory DIR (which should end with a slash). */
|
||||
static char *
|
31
emacs-mh-rmail-nonempty-dir.patch
Normal file
31
emacs-mh-rmail-nonempty-dir.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From b73cde5e2815c531df7f5fd13e214a7d92f78239 Mon Sep 17 00:00:00 2001
|
||||
From: Mike Kupfer <mkupfer@alum.berkeley.edu>
|
||||
Date: Wed, 4 Jul 2018 15:43:04 -0700
|
||||
Subject: [PATCH] Fix MH-E mail composition with GNU Mailutils (SF#485)
|
||||
|
||||
* lisp/mh-e/mh-comp.el (mh-bare-components): Recursively delete
|
||||
the temporary folder.
|
||||
---
|
||||
lisp/mh-e/mh-comp.el | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lisp/mh-e/mh-comp.el b/lisp/mh-e/mh-comp.el
|
||||
index a9f809cfa1..aa22df8b18 100644
|
||||
--- a/lisp/mh-e/mh-comp.el
|
||||
+++ b/lisp/mh-e/mh-comp.el
|
||||
@@ -925,8 +925,10 @@ mh-bare-components
|
||||
(list "-form" mh-comp-formfile)))
|
||||
(setq new (make-temp-file "comp."))
|
||||
(rename-file (concat temp-folder "/" "1") new t)
|
||||
- (delete-file (concat temp-folder "/" ".mh_sequences"))
|
||||
- (delete-directory temp-folder)
|
||||
+ ;; The temp folder could contain various metadata files. Rather
|
||||
+ ;; than trying to enumerate all the known files, just do a
|
||||
+ ;; recursive delete on the directory.
|
||||
+ (delete-directory temp-folder t)
|
||||
new))
|
||||
|
||||
(defun mh-read-draft (use initial-contents delete-contents-file)
|
||||
--
|
||||
2.36.1
|
||||
|
16
emacs-spellchecker.patch
Normal file
16
emacs-spellchecker.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
|
||||
index 1d28de7..1daec44 100644
|
||||
--- a/lisp/textmodes/ispell.el
|
||||
+++ b/lisp/textmodes/ispell.el
|
||||
@@ -200,9 +200,9 @@
|
||||
;; cause an error; and one of the other spelling engines below is
|
||||
;; almost certainly installed in any case, for enchant to use.
|
||||
(defcustom ispell-program-name
|
||||
- (or (executable-find "aspell")
|
||||
+ (or (executable-find "hunspell")
|
||||
+ (executable-find "aspell")
|
||||
(executable-find "ispell")
|
||||
- (executable-find "hunspell")
|
||||
"ispell")
|
||||
"Program invoked by \\[ispell-word] and \\[ispell-region] commands."
|
||||
:type 'string
|
11
emacs-system-crypto-policies.patch
Normal file
11
emacs-system-crypto-policies.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/gnutls.c 2016-01-24 10:29:58.000000000 +0100
|
||||
+++ b/src/gnutls.c 2016-02-02 09:32:28.477274274 +0100
|
||||
@@ -1557,7 +1557,7 @@
|
||||
gnutls_certificate_credentials_t x509_cred = NULL;
|
||||
gnutls_anon_client_credentials_t anon_cred = NULL;
|
||||
Lisp_Object global_init;
|
||||
- char const *priority_string_ptr = "NORMAL"; /* default priority string. */
|
||||
+ char const *priority_string_ptr = "@SYSTEM"; /* default priority string. */
|
||||
char *c_hostname;
|
||||
|
||||
/* Placeholders for the property list elements. */
|
11
emacs-terminal.desktop
Normal file
11
emacs-terminal.desktop
Normal file
@ -0,0 +1,11 @@
|
||||
[Desktop Entry]
|
||||
Name=Emacs Terminal
|
||||
GenericName=Emacs Terminal
|
||||
Comment=Emacs Terminal Mode
|
||||
Exec=emacs-terminal
|
||||
Icon=utilities-terminal
|
||||
Type=Application
|
||||
Terminal=false
|
||||
Categories=Application;Utility;X-Red-Hat-Base;GTK;TerminalEmulator;
|
||||
Encoding=UTF-8
|
||||
StartupWMClass=Emacs
|
3
emacs-terminal.sh
Normal file
3
emacs-terminal.sh
Normal file
@ -0,0 +1,3 @@
|
||||
#!/bin/sh
|
||||
|
||||
exec /usr/bin/emacs -Q --eval '(term "/bin/bash")'
|
64
emacs.appdata.xml
Normal file
64
emacs.appdata.xml
Normal file
@ -0,0 +1,64 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!-- Copyright 2014 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> -->
|
||||
<component type="desktop">
|
||||
<id>emacs.desktop</id>
|
||||
<metadata_license>CC0-1.0</metadata_license>
|
||||
<project_license>GPL-3.0+</project_license>
|
||||
<name>GNU Emacs</name>
|
||||
<summary>Edit text files, view pictures and binary files</summary>
|
||||
<description>
|
||||
<p>
|
||||
Emacs is a powerful, customizable, self-documenting, modeless
|
||||
editor. It is used primarely to edit text, including text
|
||||
documents, source code of programs, web pages and XML documents,
|
||||
but can also be used to display and edit binary files.
|
||||
</p>
|
||||
<p>
|
||||
Emacs allows efficient editing of text with shortcuts which
|
||||
allow operating on letters, words, sentences, and paragraphs as
|
||||
single units. This includes both moving around and operations
|
||||
like copying, deleting, transposing, and pasting. Macros can be
|
||||
conveniently defined to repeat sequences of commands. In
|
||||
addition, Emacs is (partially) built in a scripting language
|
||||
(elisp) which can also be used to define further functions
|
||||
extending existing capabilities.
|
||||
</p>
|
||||
<p>
|
||||
Emacs has extensive support for editing source code, including
|
||||
programmable syntax highlighting, automatic indentation, source
|
||||
code indexing, overview modes, and navigation based on language
|
||||
specific units like functions and blocks. It is also possible to
|
||||
invoke the compiler from within Emacs and easily move between
|
||||
compiler output and corresponding positions in the source.
|
||||
</p>
|
||||
<p>
|
||||
Emacs has multiple modules which provide further functionality.
|
||||
This provides the capability to read mail, news, browse
|
||||
pictures, read man and info pages, browse the web, execute
|
||||
arbitrary programs, and more, without leaving the editor.
|
||||
</p>
|
||||
</description>
|
||||
<screenshots>
|
||||
<screenshot type="default" height="888" width="1595">
|
||||
<image>http://in.waw.pl/~zbyszek/fedora/emacs-two-buffers.png</image>
|
||||
</screenshot>
|
||||
<screenshot height="667" width="1199">
|
||||
<image>http://in.waw.pl/~zbyszek/fedora/emacs-editing-xml.png</image>
|
||||
</screenshot>
|
||||
<screenshot height="572" width="1019">
|
||||
<image>http://in.waw.pl/~zbyszek/fedora/emacs-hexl-mode.png</image>
|
||||
</screenshot>
|
||||
<screenshot height="667" width="1199">
|
||||
<image>http://in.waw.pl/~zbyszek/fedora/emacs-showing-svg.png</image>
|
||||
</screenshot>
|
||||
<screenshot height="439" width="794">
|
||||
<image>http://in.waw.pl/~zbyszek/fedora/emacs-with-python-source.png</image>
|
||||
</screenshot>
|
||||
</screenshots>
|
||||
<url type="homepage">http://www.gnu.org/software/emacs/</url>
|
||||
<url type="bugtracker">https://www.gnu.org/software/emacs/manual/html_node/emacs/Bugs.html</url>
|
||||
<url type="donation">https://my.fsf.org/donate/</url>
|
||||
<url type="help">https://www.gnu.org/software/emacs/manual/</url>
|
||||
<update_contact>zbyszek@in.waw.pl</update_contact>
|
||||
<translation/>
|
||||
</component>
|
12
emacs.desktop
Normal file
12
emacs.desktop
Normal file
@ -0,0 +1,12 @@
|
||||
[Desktop Entry]
|
||||
Name=Emacs
|
||||
GenericName=Text Editor
|
||||
Comment=Edit text
|
||||
Comment[zh_TW]=編輯文字
|
||||
MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
|
||||
Exec=emacs %f
|
||||
Icon=emacs
|
||||
Type=Application
|
||||
Terminal=false
|
||||
Categories=Utility;TextEditor;X-Red-Hat-Base;
|
||||
StartupWMClass=Emacs
|
11
emacs.service
Normal file
11
emacs.service
Normal file
@ -0,0 +1,11 @@
|
||||
[Unit]
|
||||
Description=Emacs: the extensible, self-documenting text editor
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/emacs --daemon
|
||||
ExecStop=/usr/bin/emacsclient --eval "(kill-emacs)"
|
||||
Restart=always
|
||||
|
||||
[Install]
|
||||
WantedBy=default.target
|
2218
emacs.spec
Normal file
2218
emacs.spec
Normal file
File diff suppressed because it is too large
Load Diff
9
site-start.el
Normal file
9
site-start.el
Normal file
@ -0,0 +1,9 @@
|
||||
;;; loaded before user's ".emacs" file and default.el
|
||||
|
||||
;; load *.el and *.elc in /usr/share/emacs/site-lisp/site-start.d on startup
|
||||
(mapc
|
||||
'load
|
||||
(delete-dups
|
||||
(mapcar 'file-name-sans-extension
|
||||
(directory-files
|
||||
"/usr/share/emacs/site-lisp/site-start.d" t "\\.elc?\\'"))))
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (emacs-26.1.tar.xz) = 537c2cfdd281151b360002419dde6280c313e07a937ed96405c67f754b3401ec5541091a3c0aa6690929bc33dd79e8e0d8844e7a6b014b7798c63cb15de210c2
|
||||
SHA512 (package-keyring.gpg) = ca0dfa2edda9a6de5837dd6d754d574b13e007561e8dcc99c178d24f6a5dbb6880edc95db9d6afbea8bdf0b409671657fe22a778003ea0ccf351dce5e4fd429f
|
Loading…
Reference in New Issue
Block a user