- Add patch to fix rhbz#547566 (from Juanma Barranquero)
This commit is contained in:
parent
4d93d3cd76
commit
3f1c4afc20
12
emacs-23.1-hexl-mode.patch
Normal file
12
emacs-23.1-hexl-mode.patch
Normal file
@ -0,0 +1,12 @@
|
||||
=== modified file 'lisp/hexl.el'
|
||||
--- lisp/hexl.el 2010-01-13 08:35:10 +0000
|
||||
+++ lisp/hexl.el 2010-01-14 00:38:04 +0000
|
||||
@@ -779,7 +779,7 @@
|
||||
|
||||
(defun hexl-printable-character (ch)
|
||||
"Return a displayable string for character CH."
|
||||
- (format "%c" (if hexl-iso
|
||||
+ (format "%c" (if (not (equal hexl-iso ""))
|
||||
(if (or (< ch 32) (and (>= ch 127) (< ch 160)))
|
||||
46
|
||||
ch)
|
10
emacs.spec
10
emacs.spec
@ -4,7 +4,7 @@ Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 23.1
|
||||
Release: 22%{?dist}
|
||||
Release: 23%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
@ -39,6 +39,10 @@ Patch9: emacs-23.1-memmove.patch
|
||||
# rhbz#517272
|
||||
Patch10: emacs-23.1-fontdpi.patch
|
||||
|
||||
# Fix https://bugzilla.redhat.com/show_bug.cgi?id=547566
|
||||
# Reported upstream: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=5313
|
||||
Patch11: emacs-23.1-hexl-mode.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: atk-devel, cairo-devel, desktop-file-utils, freetype-devel, fontconfig-devel, dbus-devel, giflib-devel, glibc-devel, gtk2-devel, libpng-devel
|
||||
BuildRequires: libjpeg-devel, libtiff-devel, libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel, libXt-devel
|
||||
@ -139,6 +143,7 @@ Emacs packages or see some elisp examples.
|
||||
%patch8 -p1
|
||||
%patch9 -p1 -b .memmove
|
||||
%patch10 -p1 -b .fontdpi
|
||||
%patch11 -p0
|
||||
|
||||
# install rest of site-lisp files
|
||||
( cd site-lisp
|
||||
@ -410,6 +415,9 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%dir %{_datadir}/emacs/%{version}
|
||||
|
||||
%changelog
|
||||
* Thu Jan 14 2010 Jonathan G. Underwood <jonathan.underwood@gmail.com> 1:23.1-23
|
||||
- Add patch to fix rhbz#547566 (from Juanma Barranquero)
|
||||
|
||||
* Tue Jan 12 2010 Karel Klic <kklic@redhat.com> 1:23.1-22
|
||||
- Removed invalid URL for rpm-spec-mode.el. This mode is no longer
|
||||
found on Internet in this version.
|
||||
|
Loading…
Reference in New Issue
Block a user