Add patch to fix rhbz#595546
This commit is contained in:
parent
0134b8d40f
commit
12b3cf530e
17
emacs-23.2-hideshow-comment.patch
Normal file
17
emacs-23.2-hideshow-comment.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- lisp/progmodes/hideshow.el.orig 2010-05-12 18:28:06.543936429 +0200
|
||||
+++ lisp/progmodes/hideshow.el 2010-05-12 18:27:40.212936751 +0200
|
||||
@@ -691,9 +691,11 @@ Return point, or nil if original point w
|
||||
;; look backward for the start of a block that contains the cursor
|
||||
(while (and (re-search-backward hs-block-start-regexp nil t)
|
||||
(not (setq done
|
||||
- (< here (save-excursion
|
||||
- (hs-forward-sexp (match-data t) 1)
|
||||
- (point)))))))
|
||||
+ (and (< here
|
||||
+ (save-excursion
|
||||
+ (hs-forward-sexp (match-data t) 1)
|
||||
+ (point)))
|
||||
+ (eq (hs-inside-comment-p) nil))))))
|
||||
(if done
|
||||
(point)
|
||||
(goto-char here)
|
15
emacs.spec
15
emacs.spec
@ -4,7 +4,7 @@ Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 23.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
@ -30,6 +30,10 @@ Patch3: rpm-spec-mode-utc.patch
|
||||
Patch4: emacs-23.1-xdg.patch
|
||||
# Accepted by upstream.
|
||||
Patch5: emacs-23.2-m17ncheck.patch
|
||||
# Fix rhbz#595546
|
||||
# Upstream: http://emacsbugs.donarmstrong.com/cgi/bugreport.cgi?bug=6158
|
||||
Patch6: emacs-23.2-hideshow-comment.patch
|
||||
|
||||
|
||||
BuildRequires: atk-devel, cairo-devel, desktop-file-utils, freetype-devel, fontconfig-devel, dbus-devel, giflib-devel, glibc-devel, gtk2-devel, libpng-devel
|
||||
BuildRequires: libjpeg-devel, libtiff-devel, libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel, libXt-devel
|
||||
@ -136,6 +140,7 @@ Emacs packages or see some elisp examples.
|
||||
%patch0 -p1 -b .glibc-open-macro
|
||||
%patch4 -p1 -b .xdg
|
||||
%patch5 -p1 -b .m17ncheck
|
||||
%patch6 -p0 -b .hideshow-comment
|
||||
|
||||
# Install site-lisp files
|
||||
cp %SOURCE7 %SOURCE9 %SOURCE10 site-lisp
|
||||
@ -310,9 +315,6 @@ sed -i -e "s|\.%{_prefix}|%{_prefix}|" *-files
|
||||
cat common-*-files > common-filelist
|
||||
cat el-*-files common-lisp-dir-files > el-filelist
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%post
|
||||
update-desktop-database &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
@ -402,6 +404,11 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%dir %{_datadir}/emacs/%{version}
|
||||
|
||||
%changelog
|
||||
* Thu May 27 2010 Karel Klíč <karel@agata> - 1:23.2-4
|
||||
- Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
|
||||
under certain circumstances
|
||||
- Removed %%clean section
|
||||
|
||||
* Wed May 19 2010 Naveen Kumar <nkumar@redhat.com> - 1:23.2-3
|
||||
- Added a desktop file for adding terminal mode to menu (RHBZ #551949)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user