new upstream bugfix prerelease, defuzz patches
This commit is contained in:
parent
0d33a19817
commit
ede5edb124
@ -1 +1 @@
|
||||
elinks-0.12pre3.tar.bz2
|
||||
elinks-0.12pre4.tar.bz2
|
||||
|
@ -1,22 +1,22 @@
|
||||
--- elinks-0.10.1/configure.in.pkgconfig 2005-01-04 14:51:02.000000000 +0100
|
||||
+++ elinks-0.10.1/configure.in 2005-01-28 18:00:55.964204016 +0100
|
||||
@@ -655,6 +655,11 @@
|
||||
if test "$disable_openssl" = yes; then
|
||||
cf_result="not used"
|
||||
--- elinks-0.12pre4/configure.in.pkgconfig
|
||||
+++ elinks-0.12pre4/configure.in
|
||||
@@ -1034,6 +1034,11 @@
|
||||
|
||||
else
|
||||
cf_result=no
|
||||
+ if pkg-config openssl ; then
|
||||
+ CFLAGS="$CFLAGS_X `pkg-config --cflags openssl`"
|
||||
+ LIBS="$LIBS_X `pkg-config --libs openssl`"
|
||||
+ cf_result=yes
|
||||
+ else
|
||||
for ssldir in "$openssl_withval" "" /usr /usr/local/openssl \
|
||||
for ssldir in "$with_openssl" "" /usr /usr/local/openssl \
|
||||
/usr/lib/openssl /usr/local/ssl \
|
||||
/usr/local/www /usr/lib/ssl /usr/local \
|
||||
@@ -682,6 +687,7 @@
|
||||
@@ -1058,6 +1063,7 @@
|
||||
fi
|
||||
fi
|
||||
done
|
||||
+ fi
|
||||
|
||||
if test "$cf_result" != yes; then
|
||||
if test -n "$openssl_withval" && test "x$openssl_withval" != xno; then
|
||||
if test "${with_openssl-no}" != "no"; then
|
||||
|
@ -2,12 +2,12 @@
|
||||
+++ elinks-0.10.1/src/config/options.c 2005-01-28 18:32:34.523579120 +0100
|
||||
@@ -643,8 +643,9 @@
|
||||
get_opt_bool("terminal.linux.m11_hack") = 1;
|
||||
get_opt_int("terminal.vt100.type") = 1;
|
||||
get_opt_int("terminal.vt110.type") = 1;
|
||||
- get_opt_int("terminal.xterm.type") = 1;
|
||||
get_opt_int("terminal.vt100.type") = TERM_VT100;
|
||||
get_opt_int("terminal.vt110.type") = TERM_VT100;
|
||||
- get_opt_int("terminal.xterm.type") = TERM_VT100;
|
||||
+ get_opt_int("terminal.xterm.type") = 2;
|
||||
get_opt_bool("terminal.xterm.underline") = 1;
|
||||
+ get_opt_int("terminal.xterm.colors") = 1;
|
||||
get_opt_int("terminal.xterm-color.type") = 1;
|
||||
get_opt_int("terminal.xterm-color.type") = TERM_VT100;
|
||||
get_opt_int("terminal.xterm-color.colors") = COLOR_MODE_16;
|
||||
get_opt_bool("terminal.xterm-color.underline") = 1;
|
||||
|
@ -1,17 +1,9 @@
|
||||
diff -ruNp elinks-0.12pre3.orig/configure.in elinks-0.12pre3/configure.in
|
||||
--- elinks-0.12pre3.orig/configure.in 2009-04-28 12:19:38.816628000 +0200
|
||||
+++ elinks-0.12pre3/configure.in 2009-04-28 12:56:07.343999815 +0200
|
||||
@@ -1014,6 +1014,7 @@ gnutls_withval="$withval"
|
||||
|
||||
if test "$enable_gnutls" = yes; then
|
||||
disable_openssl=yes;
|
||||
+ with_nss_compat_ossl=no;
|
||||
fi
|
||||
|
||||
AC_ARG_WITH(openssl, [ --without-openssl disable OpenSSL support],
|
||||
@@ -1021,6 +1022,37 @@ AC_ARG_WITH(openssl, [ --without-openss
|
||||
AC_ARG_WITH(openssl, [[ --with-openssl[=DIR] enable OpenSSL support (default)]])
|
||||
openssl_withval="$withval"
|
||||
*) chosen_ssl_library="OpenSSL" ;;
|
||||
esac])
|
||||
|
||||
+AC_ARG_WITH(nss_compat_ossl, [[ --with-nss_compat_ossl[=DIR]
|
||||
+ NSS compatibility SSL libraries/include files]])
|
||||
|
10
elinks.spec
10
elinks.spec
@ -1,11 +1,11 @@
|
||||
Name: elinks
|
||||
Summary: A text-mode Web browser
|
||||
Version: 0.12
|
||||
Release: 0.15.pre3%{?dist}
|
||||
Release: 0.16.pre4%{?dist}
|
||||
License: GPLv2
|
||||
URL: http://elinks.or.cz
|
||||
Group: Applications/Internet
|
||||
Source: http://elinks.or.cz/download/elinks-%{version}pre3.tar.bz2
|
||||
Source: http://elinks.or.cz/download/elinks-%{version}pre4.tar.bz2
|
||||
Source2: elinks.conf
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -45,7 +45,7 @@ advantage over graphical browsers is its speed--Elinks starts and exits
|
||||
quickly and swiftly displays Web pages.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}pre3
|
||||
%setup -q -n %{name}-%{version}pre4
|
||||
|
||||
# Prevent crash when HOME is unset (bug #90663).
|
||||
%patch0 -p1
|
||||
@ -126,6 +126,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 01 2009 Ondrej Vasik <ovasik@redhat.com> 0.12-0.16.pre4
|
||||
- new upstream bugfix prerelease
|
||||
- defuzz patches
|
||||
|
||||
* Wed Apr 29 2009 Kamil Dudka <kdudka@redhat.com> 0.12-0.15.pre3
|
||||
- try to load default NSS root certificates if the configuration option
|
||||
connection.ssl.trusted_ca_file is set to an empty string (#497788)
|
||||
|
Loading…
Reference in New Issue
Block a user