Updated to latest stable upstream version
This commit is contained in:
parent
f0c0e69879
commit
e87f417db4
@ -1 +1 @@
|
||||
elinks-0.11.2.tar.bz2
|
||||
elinks-0.11.3.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- elinks-0.11.1/src/session/task.c.kzak 2006-10-11 09:26:28.000000000 +0200
|
||||
+++ elinks-0.11.1/src/session/task.c 2006-10-11 09:27:29.000000000 +0200
|
||||
@@ -538,7 +538,8 @@
|
||||
}
|
||||
|
||||
if (is_in_result_state(download->state) && download->state != S_OK) {
|
||||
- print_error_dialog(ses, download->state, download->conn->uri,
|
||||
+ print_error_dialog(ses, download->state,
|
||||
+ download->conn ? download->conn->uri : NULL,
|
||||
download->pri);
|
||||
if (d == DO_MOVE_ABORT) reload(ses, CACHE_MODE_NORMAL);
|
||||
}
|
@ -352,28 +352,18 @@
|
||||
|
||||
struct http_version {
|
||||
int major;
|
||||
@@ -551,7 +554,7 @@
|
||||
int trace = get_opt_bool("protocol.http.trace");
|
||||
struct string header;
|
||||
unsigned char *post_data = NULL;
|
||||
- struct auth_entry *entry;
|
||||
+ struct auth_entry *entry = NULL;
|
||||
struct uri *uri = conn->proxied_uri; /* Set to the real uri */
|
||||
unsigned char *optstr;
|
||||
int use_connect, talking_to_proxy;
|
||||
@@ -808,7 +811,11 @@
|
||||
add_crlf_to_string(&header);
|
||||
@@ -846,7 +849,11 @@
|
||||
}
|
||||
|
||||
- entry = find_auth(uri);
|
||||
/* CONNECT: The Authorization header is for the origin server only. */
|
||||
+#ifdef CONFIG_GSSAPI
|
||||
+ if (http_negotiate_output(uri, &header) != 0)
|
||||
+ if (http_negotiate_output(uri, &header) != 0) {
|
||||
+#else
|
||||
if (!use_connect) {
|
||||
+#endif
|
||||
+ entry = find_auth(uri);
|
||||
+
|
||||
entry = find_auth(uri);
|
||||
}
|
||||
if (entry) {
|
||||
if (entry->digest) {
|
||||
unsigned char *response;
|
||||
@@ -1327,12 +1334,13 @@
|
||||
return 0;
|
||||
}
|
||||
|
10
elinks.spec
10
elinks.spec
@ -1,6 +1,6 @@
|
||||
Name: elinks
|
||||
Summary: A text-mode Web browser
|
||||
Version: 0.11.2
|
||||
Version: 0.11.3
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
URL: http://elinks.or.cz
|
||||
@ -29,7 +29,6 @@ Patch4: elinks-0.11.0-sysname.patch
|
||||
Patch5: elinks-0.10.1-xterm.patch
|
||||
Patch6: elinks-0.11.0-union.patch
|
||||
Patch7: elinks-0.11.1-negotiate.patch
|
||||
Patch8: elinks-0.11.1-badproxy.patch
|
||||
|
||||
%description
|
||||
Links is a text-based Web browser. Links does not display any images,
|
||||
@ -55,8 +54,6 @@ quickly and swiftly displays Web pages.
|
||||
%patch6 -p1
|
||||
# Fix #194096 – elinks should support negotiate-auth
|
||||
%patch7 -p1
|
||||
# Fix #210103 - elinks crashes when given bad HTTP_PROXY
|
||||
%patch8 -p1
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -86,6 +83,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Tue Jun 5 2007 Ondrej Vasik <ovasik@redhat.com> 0.11.3-1
|
||||
- update to new upstream version
|
||||
- removed patch for #210103 , included in upstream release
|
||||
- updated patch elinks-0.11.1-negotiate.patch to pass build
|
||||
|
||||
* Mon Mar 26 2007 Karel Zak <kzak@redhat.com> 0.11.2-1
|
||||
- update to new upstream version
|
||||
- cleanup spec file
|
||||
|
Loading…
Reference in New Issue
Block a user