new upstream release
Resolves: rhbz#2192272
This commit is contained in:
parent
64336b6eff
commit
c6e6799231
@ -1,24 +0,0 @@
|
|||||||
PR submitted upstream: https://github.com/rkd77/elinks/pull/212
|
|
||||||
|
|
||||||
Author: Arjun Shankar <arjun@redhat.com>
|
|
||||||
Date: Fri Mar 24 14:10:43 2023 +0100
|
|
||||||
|
|
||||||
configure: Fix an "implicit int" warning
|
|
||||||
|
|
||||||
configure defines a main function without a return type, leading to a
|
|
||||||
-Wimplicit-int warning (enabled by default in C99 and later dialects).
|
|
||||||
This commit fixes that.
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index d3bf724aa997173e..ef23337b34e2617f 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -390,7 +390,7 @@ void foo(const char *format, ...) {
|
|
||||||
|
|
||||||
exit(0);
|
|
||||||
}
|
|
||||||
-main() { foo("hello\n"); }
|
|
||||||
+int main() { foo("hello\n"); }
|
|
||||||
]])],[el_cv_HAVE_C99_VSNPRINTF=yes],[el_cv_HAVE_C99_VSNPRINTF=no],[el_cv_HAVE_C99_VSNPRINTF=cross])])
|
|
||||||
if test x"$el_cv_HAVE_C99_VSNPRINTF" = x"yes"; then
|
|
||||||
EL_DEFINE(HAVE_C99_VSNPRINTF, [C99 compliant vsnprintf()])
|
|
@ -1,7 +1,7 @@
|
|||||||
Name: elinks
|
Name: elinks
|
||||||
Summary: A text-mode Web browser
|
Summary: A text-mode Web browser
|
||||||
Version: 0.16.0
|
Version: 0.16.1.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPL-2.0-only
|
License: GPL-2.0-only
|
||||||
URL: https://github.com/rkd77/elinks
|
URL: https://github.com/rkd77/elinks
|
||||||
Source: https://github.com/rkd77/elinks/releases/download/v%{version}/elinks-%{version}.tar.xz
|
Source: https://github.com/rkd77/elinks/releases/download/v%{version}/elinks-%{version}.tar.xz
|
||||||
@ -49,7 +49,6 @@ Patch6: 0006-elinks-0.16.0-libidn2.patch
|
|||||||
|
|
||||||
# let list_is_singleton() return false for an empty list (#1075415)
|
# let list_is_singleton() return false for an empty list (#1075415)
|
||||||
Patch15: elinks-0.12pre6-list_is_singleton.patch
|
Patch15: elinks-0.12pre6-list_is_singleton.patch
|
||||||
Patch16: elinks-configure-c99.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Elinks is a text-based Web browser. Elinks does not display any images,
|
Elinks is a text-based Web browser. Elinks does not display any images,
|
||||||
@ -130,6 +129,9 @@ exit 0
|
|||||||
%{_mandir}/man5/*
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 02 2023 Lukáš Zaoral <lzaoral@redhat.com> - 0.16.1.1-1
|
||||||
|
- new upstream release (rhbz#2192272)
|
||||||
|
|
||||||
* Tue Apr 11 2023 Lukáš Zaoral <lzaoral@redhat.com> - 0.16.0-5
|
* Tue Apr 11 2023 Lukáš Zaoral <lzaoral@redhat.com> - 0.16.0-5
|
||||||
- migrate to SPDX license format
|
- migrate to SPDX license format
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (elinks-0.16.0.tar.xz) = b1d6040b691610d596e0d1eae26bfe52d702272c71a2e5100ab7d6b05b24a0b88524d4fc7be3f6371e0bada1e6f0992da7505a72419ca642dec778424629a522
|
SHA512 (elinks-0.16.1.1.tar.xz) = 49e03ff4766e29b6fd4324d226e415ca1329a84d4a44fac40ecd72186dd104de88c3e541810a008dc6f1d1ed889a45edbef159cbc6ac3860756ca21261ffec8a
|
||||||
|
Loading…
Reference in New Issue
Block a user