Arjun Shankar 2023-03-24 14:37:44 +01:00
parent bcfa84f8a8
commit 79fd552452
2 changed files with 29 additions and 1 deletions

View File

@ -0,0 +1,24 @@
PR submitted upstream: https://github.com/rkd77/elinks/pull/212
Author: Arjun Shankar <arjun@redhat.com>
Date: Fri Mar 24 14:10:43 2023 +0100
configure: Fix an "implicit int" warning
configure defines a main function without a return type, leading to a
-Wimplicit-int warning (enabled by default in C99 and later dialects).
This commit fixes that.
diff --git a/configure.ac b/configure.ac
index d3bf724aa997173e..ef23337b34e2617f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,7 +390,7 @@ void foo(const char *format, ...) {
exit(0);
}
-main() { foo("hello\n"); }
+int main() { foo("hello\n"); }
]])],[el_cv_HAVE_C99_VSNPRINTF=yes],[el_cv_HAVE_C99_VSNPRINTF=no],[el_cv_HAVE_C99_VSNPRINTF=cross])])
if test x"$el_cv_HAVE_C99_VSNPRINTF" = x"yes"; then
EL_DEFINE(HAVE_C99_VSNPRINTF, [C99 compliant vsnprintf()])

View File

@ -1,7 +1,7 @@
Name: elinks
Summary: A text-mode Web browser
Version: 0.16.0
Release: 3%{?dist}
Release: 4%{?dist}
License: GPLv2
URL: https://github.com/rkd77/elinks
Source: https://github.com/rkd77/elinks/releases/download/v%{version}/elinks-%{version}.tar.xz
@ -49,6 +49,7 @@ Patch6: 0006-elinks-0.16.0-libidn2.patch
# let list_is_singleton() return false for an empty list (#1075415)
Patch15: elinks-0.12pre6-list_is_singleton.patch
Patch16: elinks-configure-c99.patch
%description
Elinks is a text-based Web browser. Elinks does not display any images,
@ -129,6 +130,9 @@ exit 0
%{_mandir}/man5/*
%changelog
* Fri Mar 24 2023 Arjun Shankar <arjun@redhat.com> - 0.16.0-4
- Port configure script to C99
* Mon Feb 20 2023 Jan Rybar <jrybar@redhat.com> - 0.16.0-3
- parallel builds cause FTBFS
- Resolves: bz#2171476