rebase to latest upstream release
Resolves: rhbz#2255830
This commit is contained in:
parent
b8b72ba839
commit
756faf7bf7
@ -1,10 +1,10 @@
|
|||||||
From b2f38ad669e99a650850a36576a4d54c57bf9ac0 Mon Sep 17 00:00:00 2001
|
From b2f38ad669e99a650850a36576a4d54c57bf9ac0 Mon Sep 17 00:00:00 2001
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
Date: Mon, 11 Apr 2022 09:27:22 +0200
|
Date: Tue, 2 Jan 2023 11:48:22 +0100
|
||||||
Subject: [PATCH] Resolves: #128105 - use "Linux" xterm terminal driver instead
|
Subject: [PATCH] Resolves: #128105 - use "Linux" xterm terminal driver instead
|
||||||
of "VT100"
|
of "VT100"
|
||||||
|
|
||||||
elinks-0.10.1-xterm.patch rebased on 0.15.0
|
0005-elinks-0.15.0-xterm.patch rebased on 0.17.0
|
||||||
---
|
---
|
||||||
src/config/options.c | 2 +-
|
src/config/options.c | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
@ -20,8 +20,8 @@ index a43fbe0..a363b36 100644
|
|||||||
- get_opt_int("terminal.xterm.type", NULL) = TERM_VT100;
|
- get_opt_int("terminal.xterm.type", NULL) = TERM_VT100;
|
||||||
+ get_opt_int("terminal.xterm.type", NULL) = TERM_LINUX;
|
+ get_opt_int("terminal.xterm.type", NULL) = TERM_LINUX;
|
||||||
get_opt_bool("terminal.xterm.underline", NULL) = 1;
|
get_opt_bool("terminal.xterm.underline", NULL) = 1;
|
||||||
|
get_opt_bool("terminal.xterm.strike", NULL) = 1;
|
||||||
get_opt_int("terminal.xterm-color.type", NULL) = TERM_VT100;
|
get_opt_int("terminal.xterm-color.type", NULL) = TERM_VT100;
|
||||||
get_opt_int("terminal.xterm-color.colors", NULL) = COLOR_MODE_16;
|
|
||||||
--
|
--
|
||||||
2.34.1
|
2.34.1
|
||||||
|
|
||||||
|
@ -1,98 +0,0 @@
|
|||||||
From 41461147907ed9a93792309f074072e981b33f42 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
Date: Mon, 11 Apr 2022 09:39:48 +0200
|
|
||||||
Subject: [PATCH] Resolves: #1098789 - add support for GNU Libidn2
|
|
||||||
|
|
||||||
patch by Robert Scheck
|
|
||||||
---
|
|
||||||
Makefile.config.in | 2 +-
|
|
||||||
configure.ac | 4 ++--
|
|
||||||
src/osdep/win32/win32.c | 2 +-
|
|
||||||
src/protocol/uri.c | 12 ++++++------
|
|
||||||
4 files changed, 10 insertions(+), 10 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile.config.in b/Makefile.config.in
|
|
||||||
index bf01d78..73d9762 100644
|
|
||||||
--- a/Makefile.config.in
|
|
||||||
+++ b/Makefile.config.in
|
|
||||||
@@ -139,7 +139,7 @@ CONFIG_GOPHER = @CONFIG_GOPHER@
|
|
||||||
CONFIG_GPM = @CONFIG_GPM@
|
|
||||||
CONFIG_GZIP = @CONFIG_GZIP@
|
|
||||||
CONFIG_HTML_HIGHLIGHT = @CONFIG_HTML_HIGHLIGHT@
|
|
||||||
-CONFIG_IDN = @CONFIG_IDN@
|
|
||||||
+CONFIG_IDN2 = @CONFIG_IDN2@
|
|
||||||
CONFIG_INTERLINK = @CONFIG_INTERLINK@
|
|
||||||
CONFIG_IPV6 = @CONFIG_IPV6@
|
|
||||||
CONFIG_DBLATEX = @CONFIG_DBLATEX@
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index d4537ab..d3bf724 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -556,8 +556,8 @@ EL_LOG_CONFIG([CONFIG_BROTLI], [[brotli]], [[$enable_brotli]])
|
|
||||||
EL_CONFIG_OPTIONAL_LIBRARY(CONFIG_LZMA, lzma, lzma.h, lzma, lzma_code,
|
|
||||||
[ --with-lzma enable lzma encoding support])
|
|
||||||
|
|
||||||
-EL_CONFIG_OPTIONAL_LIBRARY(CONFIG_IDN, idn, idna.h, idn, stringprep_check_version,
|
|
||||||
- [ --without-idn disable international domain names support])
|
|
||||||
+EL_CONFIG_OPTIONAL_LIBRARY(CONFIG_IDN2, idn2, idn2.h, idn2, idn2_lookup_ul,
|
|
||||||
+ [ --without-idn2 disable international domain names support])
|
|
||||||
|
|
||||||
# ===================================================================
|
|
||||||
# Check for GSSAPI, optional even if installed.
|
|
||||||
diff --git a/src/osdep/win32/win32.c b/src/osdep/win32/win32.c
|
|
||||||
index 02b1834..f4c148d 100644
|
|
||||||
--- a/src/osdep/win32/win32.c
|
|
||||||
+++ b/src/osdep/win32/win32.c
|
|
||||||
@@ -44,7 +44,7 @@ init_osdep(void)
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
setlocale(LC_ALL, "");
|
|
||||||
-#ifdef CONFIG_IDN
|
|
||||||
+#ifdef CONFIG_IDN2
|
|
||||||
{
|
|
||||||
char buf[60];
|
|
||||||
UINT cp = GetACP();
|
|
||||||
diff --git a/src/protocol/uri.c b/src/protocol/uri.c
|
|
||||||
index a8f15d1..218d1af 100644
|
|
||||||
--- a/src/protocol/uri.c
|
|
||||||
+++ b/src/protocol/uri.c
|
|
||||||
@@ -9,8 +9,8 @@
|
|
||||||
#ifdef HAVE_ICONV
|
|
||||||
#include <iconv.h>
|
|
||||||
#endif
|
|
||||||
-#ifdef HAVE_IDNA_H
|
|
||||||
-#include <idna.h>
|
|
||||||
+#ifdef HAVE_IDN2_H
|
|
||||||
+#include <idn2.h>
|
|
||||||
#endif
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
@@ -535,10 +535,10 @@ add_uri_to_string(struct string *string, const struct uri *uri,
|
|
||||||
* --pasky */
|
|
||||||
if (uri->ipv6 && wants(URI_PORT)) add_char_to_string(string, '[');
|
|
||||||
#endif
|
|
||||||
-#ifdef CONFIG_IDN
|
|
||||||
+#ifdef CONFIG_IDN2
|
|
||||||
/* Support for the GNU International Domain Name library.
|
|
||||||
*
|
|
||||||
- * http://www.gnu.org/software/libidn/manual/html_node/IDNA-Functions.html
|
|
||||||
+ * http://www.gnu.org/software/libidn/libidn2/manual/libidn2.html
|
|
||||||
*/
|
|
||||||
if (wants(URI_IDN)) {
|
|
||||||
char *host = NULL;
|
|
||||||
@@ -556,10 +556,10 @@ add_uri_to_string(struct string *string, const struct uri *uri,
|
|
||||||
|
|
||||||
if (host) {
|
|
||||||
char *idname;
|
|
||||||
- int code = idna_to_ascii_8z(host, &idname, 0);
|
|
||||||
+ int code = idn2_lookup_ul(host, &idname, 0);
|
|
||||||
|
|
||||||
/* FIXME: Return NULL if it coughed? --jonas */
|
|
||||||
- if (code == IDNA_SUCCESS) {
|
|
||||||
+ if (code == IDN2_OK) {
|
|
||||||
add_to_string(string, idname);
|
|
||||||
free(idname);
|
|
||||||
add_host = 0;
|
|
||||||
--
|
|
||||||
2.38.1
|
|
||||||
|
|
14
elinks.spec
14
elinks.spec
@ -1,7 +1,7 @@
|
|||||||
Name: elinks
|
Name: elinks
|
||||||
Summary: A text-mode Web browser
|
Summary: A text-mode Web browser
|
||||||
Version: 0.16.1.1
|
Version: 0.17.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPL-2.0-only
|
License: GPL-2.0-only
|
||||||
URL: https://github.com/rkd77/elinks
|
URL: https://github.com/rkd77/elinks
|
||||||
Source: https://github.com/rkd77/elinks/releases/download/v%{version}/elinks-%{version}.tar.xz
|
Source: https://github.com/rkd77/elinks/releases/download/v%{version}/elinks-%{version}.tar.xz
|
||||||
@ -44,11 +44,8 @@ Patch4: 0004-elinks-0.15.0-sysname.patch
|
|||||||
# Fix xterm terminal: "Linux" driver seems better than "VT100" (#128105)
|
# Fix xterm terminal: "Linux" driver seems better than "VT100" (#128105)
|
||||||
Patch5: 0005-elinks-0.15.0-xterm.patch
|
Patch5: 0005-elinks-0.15.0-xterm.patch
|
||||||
|
|
||||||
# add support for GNU Libidn2, patch by Robert Scheck (#1098789)
|
|
||||||
Patch6: 0006-elinks-0.16.0-libidn2.patch
|
|
||||||
|
|
||||||
# let list_is_singleton() return false for an empty list (#1075415)
|
# let list_is_singleton() return false for an empty list (#1075415)
|
||||||
Patch15: elinks-0.12pre6-list_is_singleton.patch
|
Patch6: elinks-0.12pre6-list_is_singleton.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Elinks is a text-based Web browser. Elinks does not display any images,
|
Elinks is a text-based Web browser. Elinks does not display any images,
|
||||||
@ -120,7 +117,7 @@ exit 0
|
|||||||
|
|
||||||
%files -f elinks.lang
|
%files -f elinks.lang
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%doc README
|
%doc README.md
|
||||||
%ghost %verify(not md5 size mtime) %{_bindir}/links
|
%ghost %verify(not md5 size mtime) %{_bindir}/links
|
||||||
%{_bindir}/elinks
|
%{_bindir}/elinks
|
||||||
%ghost %verify(not md5 size mtime) %{_mandir}/man1/links.1.gz
|
%ghost %verify(not md5 size mtime) %{_mandir}/man1/links.1.gz
|
||||||
@ -129,6 +126,9 @@ exit 0
|
|||||||
%{_mandir}/man5/*
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 02 2024 Lukáš Zaoral <lzaoral@redhat.com> - 0.17.0-1
|
||||||
|
- rebase to latest upstream release (rhbz#2255830)
|
||||||
|
|
||||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.1.1-2
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.1.1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (elinks-0.16.1.1.tar.xz) = 49e03ff4766e29b6fd4324d226e415ca1329a84d4a44fac40ecd72186dd104de88c3e541810a008dc6f1d1ed889a45edbef159cbc6ac3860756ca21261ffec8a
|
SHA512 (elinks-0.17.0.tar.xz) = 276c648174d067cdd92cbbf25e8a353a3a482a65a4f1080ff42f932cdc0239e5110a51653f5136188a0b9135be2928f2bd1a92f37fa83ce14d8fc1267b87cf56
|
||||||
|
Loading…
Reference in New Issue
Block a user