replace BuildRequire openssl-devel with krb5-devel NSS related description
for connection.ssl.cert_verify configuration option
This commit is contained in:
parent
e714c2f5dd
commit
3b7730f302
@ -1,6 +1,6 @@
|
|||||||
diff -ruNp elinks-0.12pre3.orig/configure.in elinks-0.12pre3/configure.in
|
diff -ruNp elinks-0.12pre3.orig/configure.in elinks-0.12pre3/configure.in
|
||||||
--- elinks-0.12pre3.orig/configure.in 2009-03-30 15:31:31.000000000 +0200
|
--- elinks-0.12pre3.orig/configure.in 2009-04-14 13:46:26.749379000 +0200
|
||||||
+++ elinks-0.12pre3/configure.in 2009-03-30 15:31:31.000000000 +0200
|
+++ elinks-0.12pre3/configure.in 2009-04-14 13:47:13.702846713 +0200
|
||||||
@@ -1014,6 +1014,7 @@ gnutls_withval="$withval"
|
@@ -1014,6 +1014,7 @@ gnutls_withval="$withval"
|
||||||
|
|
||||||
if test "$enable_gnutls" = yes; then
|
if test "$enable_gnutls" = yes; then
|
||||||
@ -60,9 +60,9 @@ diff -ruNp elinks-0.12pre3.orig/configure.in elinks-0.12pre3/configure.in
|
|||||||
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
diff -ruNp elinks-0.12pre2.orig/src/network/ssl/socket.c elinks-0.12pre2/src/network/ssl/socket.c
|
diff -ruNp elinks-0.12pre3.orig/src/network/ssl/socket.c elinks-0.12pre3/src/network/ssl/socket.c
|
||||||
--- elinks-0.12pre2.orig/src/network/ssl/socket.c 2008-09-21 10:45:22.000000000 +0200
|
--- elinks-0.12pre3.orig/src/network/ssl/socket.c 2009-03-29 00:14:03.000000000 +0100
|
||||||
+++ elinks-0.12pre2/src/network/ssl/socket.c 2008-10-01 10:41:01.000000000 +0200
|
+++ elinks-0.12pre3/src/network/ssl/socket.c 2009-04-14 13:47:13.704846733 +0200
|
||||||
@@ -6,6 +6,10 @@
|
@@ -6,6 +6,10 @@
|
||||||
|
|
||||||
#ifdef CONFIG_OPENSSL
|
#ifdef CONFIG_OPENSSL
|
||||||
@ -152,9 +152,9 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/socket.c elinks-0.12pre2/src/net
|
|||||||
int err = SSL_get_error(socket->ssl, rd);
|
int err = SSL_get_error(socket->ssl, rd);
|
||||||
#elif defined(CONFIG_GNUTLS)
|
#elif defined(CONFIG_GNUTLS)
|
||||||
int err = rd;
|
int err = rd;
|
||||||
diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/network/ssl/ssl.c
|
diff -ruNp elinks-0.12pre3.orig/src/network/ssl/ssl.c elinks-0.12pre3/src/network/ssl/ssl.c
|
||||||
--- elinks-0.12pre2.orig/src/network/ssl/ssl.c 2008-10-01 10:38:34.000000000 +0200
|
--- elinks-0.12pre3.orig/src/network/ssl/ssl.c 2009-04-14 13:46:26.739379000 +0200
|
||||||
+++ elinks-0.12pre2/src/network/ssl/ssl.c 2008-10-01 10:39:43.000000000 +0200
|
+++ elinks-0.12pre3/src/network/ssl/ssl.c 2009-04-14 13:52:15.813854125 +0200
|
||||||
@@ -7,6 +7,10 @@
|
@@ -7,6 +7,10 @@
|
||||||
#ifdef CONFIG_OPENSSL
|
#ifdef CONFIG_OPENSSL
|
||||||
#include <openssl/ssl.h>
|
#include <openssl/ssl.h>
|
||||||
@ -175,7 +175,26 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
|
|
||||||
#ifndef PATH_MAX
|
#ifndef PATH_MAX
|
||||||
#define PATH_MAX 256 /* according to my /usr/include/bits/posix1_lim.h */
|
#define PATH_MAX 256 /* according to my /usr/include/bits/posix1_lim.h */
|
||||||
@@ -71,12 +75,27 @@ static struct option_info openssl_option
|
@@ -57,10 +61,18 @@ done_openssl(struct module *module)
|
||||||
|
}
|
||||||
|
|
||||||
|
static struct option_info openssl_options[] = {
|
||||||
|
+#ifdef CONFIG_NSS_COMPAT_OSSL
|
||||||
|
+ INIT_OPT_BOOL("connection.ssl", N_("Verify certificates"),
|
||||||
|
+ "cert_verify", 0, 0,
|
||||||
|
+ N_("Verify the peer's SSL certificate. The NSS database "
|
||||||
|
+ "location can be changed by SSL_DIR environment variable. "
|
||||||
|
+ "The database can be also shared with Mozilla browsers.")),
|
||||||
|
+#else
|
||||||
|
INIT_OPT_BOOL("connection.ssl", N_("Verify certificates"),
|
||||||
|
"cert_verify", 0, 0,
|
||||||
|
N_("Verify the peer's SSL certificate. Note that this "
|
||||||
|
"needs extensive configuration of OpenSSL by the user.")),
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
INIT_OPT_TREE("connection.ssl", N_("Client Certificates"),
|
||||||
|
"client_cert", OPT_SORT,
|
||||||
|
@@ -71,12 +83,27 @@ static struct option_info openssl_option
|
||||||
N_("Enable or not the sending of X509 client certificates "
|
N_("Enable or not the sending of X509 client certificates "
|
||||||
"to servers which request them.")),
|
"to servers which request them.")),
|
||||||
|
|
||||||
@ -203,7 +222,7 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
|
|
||||||
NULL_OPTION_INFO,
|
NULL_OPTION_INFO,
|
||||||
};
|
};
|
||||||
@@ -181,7 +199,7 @@ static struct module gnutls_module = str
|
@@ -182,7 +209,7 @@ static struct module gnutls_module = str
|
||||||
/* done: */ done_gnutls
|
/* done: */ done_gnutls
|
||||||
);
|
);
|
||||||
|
|
||||||
@ -212,7 +231,7 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
|
|
||||||
static struct option_info ssl_options[] = {
|
static struct option_info ssl_options[] = {
|
||||||
INIT_OPT_TREE("connection", N_("SSL"),
|
INIT_OPT_TREE("connection", N_("SSL"),
|
||||||
@@ -192,7 +210,7 @@ static struct option_info ssl_options[]
|
@@ -193,7 +220,7 @@ static struct option_info ssl_options[]
|
||||||
};
|
};
|
||||||
|
|
||||||
static struct module *ssl_modules[] = {
|
static struct module *ssl_modules[] = {
|
||||||
@ -221,7 +240,7 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
&openssl_module,
|
&openssl_module,
|
||||||
#elif defined(CONFIG_GNUTLS)
|
#elif defined(CONFIG_GNUTLS)
|
||||||
&gnutls_module,
|
&gnutls_module,
|
||||||
@@ -213,7 +231,7 @@ struct module ssl_module = struct_module
|
@@ -214,7 +241,7 @@ struct module ssl_module = struct_module
|
||||||
int
|
int
|
||||||
init_ssl_connection(struct socket *socket)
|
init_ssl_connection(struct socket *socket)
|
||||||
{
|
{
|
||||||
@ -230,7 +249,7 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
socket->ssl = SSL_new(context);
|
socket->ssl = SSL_new(context);
|
||||||
if (!socket->ssl) return S_SSL_ERROR;
|
if (!socket->ssl) return S_SSL_ERROR;
|
||||||
#elif defined(CONFIG_GNUTLS)
|
#elif defined(CONFIG_GNUTLS)
|
||||||
@@ -262,7 +280,7 @@ done_ssl_connection(struct socket *socke
|
@@ -263,7 +290,7 @@ done_ssl_connection(struct socket *socke
|
||||||
ssl_t *ssl = socket->ssl;
|
ssl_t *ssl = socket->ssl;
|
||||||
|
|
||||||
if (!ssl) return;
|
if (!ssl) return;
|
||||||
@ -239,7 +258,7 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
SSL_free(ssl);
|
SSL_free(ssl);
|
||||||
#elif defined(CONFIG_GNUTLS)
|
#elif defined(CONFIG_GNUTLS)
|
||||||
gnutls_deinit(*ssl);
|
gnutls_deinit(*ssl);
|
||||||
@@ -279,7 +297,7 @@ get_ssl_connection_cipher(struct socket
|
@@ -280,7 +307,7 @@ get_ssl_connection_cipher(struct socket
|
||||||
|
|
||||||
if (!init_string(&str)) return NULL;
|
if (!init_string(&str)) return NULL;
|
||||||
|
|
||||||
@ -248,9 +267,9 @@ diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.c elinks-0.12pre2/src/networ
|
|||||||
add_format_to_string(&str, "%ld-bit %s %s",
|
add_format_to_string(&str, "%ld-bit %s %s",
|
||||||
SSL_get_cipher_bits(ssl, NULL),
|
SSL_get_cipher_bits(ssl, NULL),
|
||||||
SSL_get_cipher_version(ssl),
|
SSL_get_cipher_version(ssl),
|
||||||
diff -ruNp elinks-0.12pre2.orig/src/network/ssl/ssl.h elinks-0.12pre2/src/network/ssl/ssl.h
|
diff -ruNp elinks-0.12pre3.orig/src/network/ssl/ssl.h elinks-0.12pre3/src/network/ssl/ssl.h
|
||||||
--- elinks-0.12pre2.orig/src/network/ssl/ssl.h 2008-09-21 10:45:22.000000000 +0200
|
--- elinks-0.12pre3.orig/src/network/ssl/ssl.h 2009-03-29 00:14:03.000000000 +0100
|
||||||
+++ elinks-0.12pre2/src/network/ssl/ssl.h 2008-10-01 10:39:43.000000000 +0200
|
+++ elinks-0.12pre3/src/network/ssl/ssl.h 2009-04-14 13:47:13.706846753 +0200
|
||||||
@@ -22,7 +22,7 @@ unsigned char *get_ssl_connection_cipher
|
@@ -22,7 +22,7 @@ unsigned char *get_ssl_connection_cipher
|
||||||
|
|
||||||
/* Internal type used in ssl module. */
|
/* Internal type used in ssl module. */
|
||||||
|
@ -9,10 +9,10 @@ Source: http://elinks.or.cz/download/elinks-%{version}pre3.tar.bz2
|
|||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: openssl-devel
|
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
BuildRequires: libidn-devel
|
BuildRequires: libidn-devel
|
||||||
|
BuildRequires: krb5-devel
|
||||||
BuildRequires: nss_compat_ossl-devel >= 0.9.3
|
BuildRequires: nss_compat_ossl-devel >= 0.9.3
|
||||||
Requires: zlib >= 1.2.0.2
|
Requires: zlib >= 1.2.0.2
|
||||||
Requires(preun): %{_sbindir}/alternatives
|
Requires(preun): %{_sbindir}/alternatives
|
||||||
|
Loading…
Reference in New Issue
Block a user