fix patches such that they apply with zero offset

This commit is contained in:
Kamil Dudka 2011-04-21 15:53:27 +02:00
parent 9ba3c541e7
commit 3086ecbf56
7 changed files with 551 additions and 580 deletions

View File

@ -1,6 +1,6 @@
--- elinks-0.10.1/src/config/options.c.xterm 2005-01-04 01:50:29.000000000 +0100
+++ elinks-0.10.1/src/config/options.c 2005-01-28 18:32:34.523579120 +0100
@@ -643,8 +643,9 @@
@@ -689,8 +689,9 @@ register_autocreated_options(void)
get_opt_bool("terminal.linux.m11_hack") = 1;
get_opt_int("terminal.vt100.type") = TERM_VT100;
get_opt_int("terminal.vt110.type") = TERM_VT100;

View File

@ -1,6 +1,6 @@
--- elinks-0.11.0/src/network/dns.c.getaddrinfo 2006-01-01 17:39:36.000000000 +0100
+++ elinks-0.11.0/src/network/dns.c 2006-01-10 09:30:56.000000000 +0100
@@ -156,9 +156,21 @@
@@ -157,9 +157,21 @@ do_real_lookup(unsigned char *name, struct sockaddr_storage **addrs, int *addrno
* But we duplicate the code terribly here :|. */
/* hostent = getipnodebyname(name, AF_INET6, AI_ALL | AI_ADDRCONFIG, NULL); */
memset(&hint, 0, sizeof(hint));

View File

@ -1,6 +1,6 @@
--- elinks-0.11.0/src/network/ssl/ssl.c.noegd 2006-01-10 09:24:50.000000000 +0100
+++ elinks-0.11.0/src/network/ssl/ssl.c 2006-01-10 09:25:01.000000000 +0100
@@ -43,18 +43,6 @@
@@ -44,18 +44,6 @@ SSL_CTX *context = NULL;
static void
init_openssl(struct module *module)
{

View File

@ -1,6 +1,6 @@
--- elinks-0.11.0/src/config/options.h.union 2006-01-10 09:40:54.000000000 +0100
+++ elinks-0.11.0/src/config/options.h 2006-01-10 09:48:16.000000000 +0100
@@ -131,7 +131,7 @@
@@ -160,7 +160,7 @@ struct option {
};
#define INIT_OPTION(name, flags, type, min, max, value, desc, capt) \
@ -9,7 +9,7 @@
extern struct option *config_options;
extern struct option *cmdline_options;
@@ -292,40 +292,42 @@
@@ -323,40 +323,42 @@ extern void register_options(struct option_info info[], struct option *tree);
extern void unregister_options(struct option_info info[], struct option *tree);
#define NULL_OPTION_INFO \

View File

@ -1,11 +1,16 @@
--- elinks-0.11.3/src/encoding/encoding.c.macropen
+++ elinks-0.11.3/src/encoding/encoding.c
@@ -117,7 +117,7 @@
if (!stream) return NULL;
src/encoding/encoding.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
stream->encoding = encoding;
diff --git a/src/encoding/encoding.c b/src/encoding/encoding.c
index d019dab..9648da3 100644
--- a/src/encoding/encoding.c
+++ b/src/encoding/encoding.c
@@ -111,7 +111,7 @@ open_encoded(int fd, enum stream_encoding encoding)
if (!stream) return NULL;
stream->encoding = encoding;
- if (decoding_backends[stream->encoding]->open(stream, fd) >= 0)
+ if ((decoding_backends[stream->encoding]->open)(stream, fd) >= 0)
return stream;
mem_free(stream);
return stream;
mem_free(stream);

View File

@ -1,7 +1,7 @@
diff -ruNp elinks-0.12pre3.orig/configure.in elinks-0.12pre3/configure.in
--- elinks-0.12pre3.orig/configure.in 2009-04-28 12:19:38.816628000 +0200
+++ elinks-0.12pre3/configure.in 2009-04-28 12:56:07.343999815 +0200
@@ -1021,6 +1022,37 @@ AC_ARG_WITH(openssl, [ --without-openss
@@ -1020,6 +1020,37 @@ AC_ARG_WITH(openssl, [[ --with-openssl[=DIR] enable OpenSSL support (default
*) chosen_ssl_library="OpenSSL" ;;
esac])
@ -39,7 +39,7 @@ diff -ruNp elinks-0.12pre3.orig/configure.in elinks-0.12pre3/configure.in
# ---- OpenSSL
AC_MSG_CHECKING([for OpenSSL])
@@ -1143,10 +1175,11 @@ AC_MSG_RESULT($cf_result)
@@ -1142,10 +1173,11 @@ fi
# Final SSL setup
@ -223,7 +223,7 @@ diff -ruNp elinks-0.12pre3.orig/src/network/ssl/ssl.c elinks-0.12pre3/src/networ
socket->ssl = SSL_new(context);
if (!socket->ssl) return S_SSL_ERROR;
#elif defined(CONFIG_GNUTLS)
@@ -263,7 +283,7 @@ done_ssl_connection(struct socket *socke
@@ -271,7 +291,7 @@ done_ssl_connection(struct socket *socket)
ssl_t *ssl = socket->ssl;
if (!ssl) return;
@ -232,7 +232,7 @@ diff -ruNp elinks-0.12pre3.orig/src/network/ssl/ssl.c elinks-0.12pre3/src/networ
SSL_free(ssl);
#elif defined(CONFIG_GNUTLS)
gnutls_deinit(*ssl);
@@ -280,7 +300,7 @@ get_ssl_connection_cipher(struct socket
@@ -288,7 +308,7 @@ get_ssl_connection_cipher(struct socket *socket)
if (!init_string(&str)) return NULL;

File diff suppressed because it is too large Load Diff