- port patches to new upstream

This commit is contained in:
kzak 2005-01-28 18:11:50 +00:00
parent 3793b69f3b
commit 131b12757f
4 changed files with 59 additions and 18 deletions

View File

@ -0,0 +1,22 @@
--- elinks-0.10.1/configure.in.pkgconfig 2005-01-04 14:51:02.000000000 +0100
+++ elinks-0.10.1/configure.in 2005-01-28 18:00:55.964204016 +0100
@@ -655,6 +655,11 @@
if test "$disable_openssl" = yes; then
cf_result="not used"
else
+ if pkg-config openssl ; then
+ CFLAGS="$CFLAGS_X `pkg-config --cflags openssl`"
+ LIBS="$LIBS_X `pkg-config --libs openssl`"
+ cf_result=yes
+ else
for ssldir in "$openssl_withval" "" /usr /usr/local/openssl \
/usr/lib/openssl /usr/local/ssl \
/usr/local/www /usr/lib/ssl /usr/local \
@@ -682,6 +687,7 @@
fi
fi
done
+ fi
if test "$cf_result" != yes; then
if test "$withval" = yes; then

View File

@ -0,0 +1,11 @@
--- elinks-0.10.1/src/config/options.inc.utf_8_io-default 2005-01-04 01:42:56.000000000 +0100
+++ elinks-0.10.1/src/config/options.inc 2005-01-28 17:54:42.568968720 +0100
@@ -747,7 +747,7 @@
"terminal.")),
INIT_OPT_BOOL("terminal._template_", N_("UTF-8 I/O"),
- "utf_8_io", 0, 0,
+ "utf_8_io", 0, 1,
N_("Enable I/O in UTF8 for Unicode terminals. Note that currently,\n"
"only the subset of UTF8 according to terminal codepage is used.")),

13
elinks-0.10.1-xterm.patch Normal file
View File

@ -0,0 +1,13 @@
--- elinks-0.10.1/src/config/options.c.xterm 2005-01-04 01:50:29.000000000 +0100
+++ elinks-0.10.1/src/config/options.c 2005-01-28 18:32:34.523579120 +0100
@@ -643,8 +643,9 @@
get_opt_bool("terminal.linux.m11_hack") = 1;
get_opt_int("terminal.vt100.type") = 1;
get_opt_int("terminal.vt110.type") = 1;
- get_opt_int("terminal.xterm.type") = 1;
+ get_opt_int("terminal.xterm.type") = 2;
get_opt_bool("terminal.xterm.underline") = 1;
+ get_opt_int("terminal.xterm.colors") = 1;
get_opt_int("terminal.xterm-color.type") = 1;
get_opt_int("terminal.xterm-color.colors") = COLOR_MODE_16;
get_opt_bool("terminal.xterm-color.underline") = 1;

View File

@ -1,18 +1,16 @@
%define rescue %{nil}
Name: elinks
Summary: A text-mode Web browser.
Version: 0.9.2
Release: 2
Version: 0.10.1
Release: 1
Source: http://elinks.or.cz/download/elinks-%{version}.tar.bz2
Source1: http://links.sourceforge.net/download/docs/manual-0.82-en.tar.bz2
Patch0: elinks-noegd.patch
Patch1: elinks-0.9.1-utf_8_io-default.patch
Patch2: elinks-pkgconfig.patch
Patch3: elinks-convert_string.patch
Patch4: elinks-0.4.2-getaddrinfo.patch
Patch5: elinks-sysname.patch
Patch6: elinks-stdin.patch
Patch7: elinks-0.9.2-xterm.patch
Patch1: elinks-0.10.1-utf_8_io-default.patch
Patch2: elinks-0.10.1-pkgconfig.patch
Patch3: elinks-0.4.2-getaddrinfo.patch
Patch4: elinks-sysname.patch
Patch5: elinks-0.10.1-xterm.patch
Group: Applications/Internet
URL: http://elinks.or.cz/
BuildRoot: %{_tmppath}/%{name}-buildroot
@ -39,20 +37,14 @@ quickly and swiftly displays Web pages.
%patch2 -p1 -b .pkgconfig
# Avoid symbol clash (bug #131170).
%patch3 -p1 -b .convert_string
# Make getaddrinfo call use AI_ADDRCONFIG.
%patch4 -p1 -b .getaddrinfo
%patch3 -p1 -b .getaddrinfo
# Don't put so much information in the user-agent header string (bug #97273).
%patch5 -p1 -b .sysname
# Fix elinks -dump -stdin (bug #127624).
%patch6 -p1 -b .stdin
%patch4 -p1 -b .sysname
# Fix xterm terminal: "Linux" driver seems better than "VT100" (#128105)
%patch7 -p1 -b .xterm
%patch5 -p1 -b .xterm
aclocal
automake -a
@ -87,6 +79,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man5/*
%changelog
* Fri Jan 28 2005 Karel Zak <kzak@redhat.com> 0.10.1-1
- sync with upstream; stable 0.10.1
* Thu Oct 14 2004 Karel Zak <kzak@redhat.com> 0.9.2-2
- the "Linux" driver seems better than "VT100" for xterm (#128105)