New upstream version 0.109
This commit is contained in:
parent
83906fb9c6
commit
f995fa824f
@ -1,35 +1,26 @@
|
||||
--- elfutils/ChangeLog
|
||||
+++ elfutils/ChangeLog
|
||||
@@ -1,3 +1,16 @@
|
||||
+2005-02-07 Roland McGrath <roland@frob.com>
|
||||
@@ -7,6 +7,17 @@
|
||||
* Makefile.am (all_SUBDIRS): Add libdwfl.
|
||||
* configure.ac: Write libdwfl/Makefile.
|
||||
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * configure.ac (WEXTRA): Check for -Wextra and set this substitution.
|
||||
+
|
||||
+2003-08-12 Roland McGrath <roland@redhat.com>
|
||||
+ * configure.ac: Check for struct stat st_?tim members.
|
||||
+ * src/strip.c (process_file): Use st_?time if st_?tim are not there.
|
||||
+
|
||||
+ * configure.ac: Check for struct stat st_?tim members.
|
||||
+ * src/strip.c (process_file): Use st_?time if st_?tim are not there.
|
||||
+ * configure.ac: Check for futimes function.
|
||||
+ * src/strip.c (handle_elf) [! HAVE_FUTIMES]: Use utimes instead.
|
||||
+ (handle_ar) [! HAVE_FUTIMES]: Likewise.
|
||||
+
|
||||
+ * configure.ac: Check for futimes function.
|
||||
+ * src/strip.c (handle_elf) [! HAVE_FUTIMES]: Use utimes instead.
|
||||
+ (handle_ar) [! HAVE_FUTIMES]: Likewise.
|
||||
+
|
||||
2005-02-22 Ulrich Drepper <drepper@redhat.com>
|
||||
2005-05-19 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* Makefile.am (all_SUBDIRS): Don't add doc subdir for now.
|
||||
--- elfutils/Makefile.in
|
||||
+++ elfutils/Makefile.in
|
||||
@@ -127,6 +127,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
+WEXTRA = @WEXTRA@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
* configure.ac [AH_BOTTOM] (INTDECL, _INTDECL): New macros.
|
||||
--- elfutils/config/Makefile.in
|
||||
+++ elfutils/config/Makefile.in
|
||||
@@ -105,6 +105,7 @@ SHELL = @SHELL@
|
||||
@@ -107,6 +107,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -39,16 +30,23 @@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/configure
|
||||
+++ elfutils/configure
|
||||
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.108'
|
||||
@@ -1,5 +1,5 @@
|
||||
#! /bin/sh
|
||||
-# From configure.ac Revision: 1.49 .
|
||||
+# From configure.ac Revision: 1.47.2.4 .
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
# Generated by GNU Autoconf 2.59 for Red Hat elfutils 0.109.
|
||||
#
|
||||
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.109'
|
||||
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
||||
|
||||
ac_unique_file="libelf/libelf.h"
|
||||
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
|
||||
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT WEXTRA LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
|
||||
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar MODVERSION build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE LIBEBL_SUBDIR USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
|
||||
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar MODVERSION build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT WEXTRA LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE LIBEBL_SUBDIR USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
|
||||
ac_subst_files=''
|
||||
|
||||
# Initialize some variables set by options.
|
||||
@@ -3373,6 +3373,58 @@ echo "$as_me: error: gcc with C99 suppor
|
||||
@@ -3384,6 +3384,58 @@ echo "$as_me: error: gcc with C99 suppor
|
||||
fi
|
||||
|
||||
|
||||
@ -97,7 +95,7 @@
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_cc_wextra" >&5
|
||||
+echo "${ECHO_T}$ac_cv_cc_wextra" >&6
|
||||
+
|
||||
+if test "x$ac_cv_cc_wextra" = yes; then
|
||||
+if test "x$ac_cv_cc_wextra" = xyes; then
|
||||
+ WEXTRA=-Wextra
|
||||
+else
|
||||
+ WEXTRA=-W
|
||||
@ -107,7 +105,7 @@
|
||||
LOCALEDIR=$datadir
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
@@ -4818,6 +4870,7 @@ s,@YACC@,$YACC,;t t
|
||||
@@ -4847,6 +4899,7 @@ s,@YACC@,$YACC,;t t
|
||||
s,@LEX@,$LEX,;t t
|
||||
s,@LEXLIB@,$LEXLIB,;t t
|
||||
s,@LEX_OUTPUT_ROOT@,$LEX_OUTPUT_ROOT,;t t
|
||||
@ -117,7 +115,16 @@
|
||||
s,@NATIVE_LD_TRUE@,$NATIVE_LD_TRUE,;t t
|
||||
--- elfutils/configure.ac
|
||||
+++ elfutils/configure.ac
|
||||
@@ -64,6 +64,15 @@ CFLAGS="$old_CFLAGS"])
|
||||
@@ -23,7 +23,7 @@ AC_CONFIG_AUX_DIR([config])
|
||||
AC_CONFIG_FILES([config/Makefile])
|
||||
|
||||
AC_COPYRIGHT([Copyright (C) 1996-2003, 2004, 2005 Red Hat, Inc.])
|
||||
-AC_REVISION($Revision: 1.8 $)
|
||||
+AC_REVISION($Revision: 1.8 $)
|
||||
AC_PREREQ(2.59) dnl Minimum Autoconf version required.
|
||||
|
||||
AM_INIT_AUTOMAKE([gnits 1.7])
|
||||
@@ -70,6 +70,15 @@ CFLAGS="$old_CFLAGS"])
|
||||
AS_IF([test "x$ac_cv_c99" != xyes],
|
||||
AC_MSG_ERROR([gcc with C99 support required]))
|
||||
|
||||
@ -128,7 +135,7 @@
|
||||
+ ac_cv_cc_wextra=yes, ac_cv_cc_wextra=no)
|
||||
+CFLAGS="$old_CFLAGS"])
|
||||
+AC_SUBST(WEXTRA)
|
||||
+AS_IF([test "x$ac_cv_cc_wextra" = yes], [WEXTRA=-Wextra], [WEXTRA=-W])
|
||||
+AS_IF([test "x$ac_cv_cc_wextra" = xyes], [WEXTRA=-Wextra], [WEXTRA=-W])
|
||||
+
|
||||
LOCALEDIR=$datadir
|
||||
AC_SUBST(LOCALEDIR)
|
||||
@ -166,7 +173,7 @@
|
||||
noinst_LIBRARIES = libeu.a
|
||||
--- elfutils/lib/Makefile.in
|
||||
+++ elfutils/lib/Makefile.in
|
||||
@@ -127,6 +127,7 @@ SHELL = @SHELL@
|
||||
@@ -129,6 +129,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -174,7 +181,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -169,9 +170,9 @@ sharedstatedir = @sharedstatedir@
|
||||
@@ -171,9 +172,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -186,6 +193,17 @@
|
||||
INCLUDES = -I$(srcdir)/../libelf -I..
|
||||
noinst_LIBRARIES = libeu.a
|
||||
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
|
||||
--- elfutils/libasm/ChangeLog
|
||||
+++ elfutils/libasm/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
2005-02-15 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* Makefile (AM_CFLAGS): Add -Wunused -Wextra -Wformat=2.
|
||||
--- elfutils/libasm/Makefile.am
|
||||
+++ elfutils/libasm/Makefile.am
|
||||
@@ -13,12 +13,13 @@
|
||||
@ -205,7 +223,7 @@
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
--- elfutils/libasm/Makefile.in
|
||||
+++ elfutils/libasm/Makefile.in
|
||||
@@ -159,6 +159,7 @@ SHELL = @SHELL@
|
||||
@@ -161,6 +161,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -213,7 +231,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -200,10 +201,10 @@ sbindir = @sbindir@
|
||||
@@ -202,10 +203,10 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@ -251,7 +269,7 @@
|
||||
noinst_LIBRARIES = libcpu_i386.a
|
||||
--- elfutils/libcpu/Makefile.in
|
||||
+++ elfutils/libcpu/Makefile.in
|
||||
@@ -122,6 +122,7 @@ SHELL = @SHELL@
|
||||
@@ -124,6 +124,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -259,7 +277,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -163,7 +164,7 @@ sbindir = @sbindir@
|
||||
@@ -165,7 +166,7 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@ -268,12 +286,26 @@
|
||||
INCLUDES = -I$(srcdir)
|
||||
noinst_LIBRARIES = libcpu_i386.a
|
||||
libcpu_i386_a_SOURCES = i386_dis.c
|
||||
--- elfutils/libdw/ChangeLog
|
||||
+++ elfutils/libdw/ChangeLog
|
||||
@@ -35,6 +35,11 @@
|
||||
|
||||
2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
* dwarf_formref_die.c (dwarf_formref_die): Add CU header offset to
|
||||
formref offset.
|
||||
|
||||
--- elfutils/libdw/Makefile.am
|
||||
+++ elfutils/libdw/Makefile.am
|
||||
@@ -13,12 +13,13 @@
|
||||
## 3001 King Ranch Road, Ukiah, CA 95482.
|
||||
##
|
||||
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
|
||||
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -DIS_LIBDW
|
||||
+WEXTRA = @WEXTRA@
|
||||
if MUDFLAP
|
||||
AM_CFLAGS = -fmudflap
|
||||
@ -287,7 +319,7 @@
|
||||
|
||||
--- elfutils/libdw/Makefile.in
|
||||
+++ elfutils/libdw/Makefile.in
|
||||
@@ -190,6 +190,7 @@ SHELL = @SHELL@
|
||||
@@ -196,6 +196,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -295,7 +327,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -232,9 +233,9 @@ sharedstatedir = @sharedstatedir@
|
||||
@@ -238,9 +239,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
||||
@ -307,6 +339,72 @@
|
||||
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
|
||||
lib_LIBRARIES = libdw.a
|
||||
@MUDFLAP_FALSE@noinst_LIBRARIES = libdw_pic.a
|
||||
--- elfutils/libdwfl/ChangeLog
|
||||
+++ elfutils/libdwfl/ChangeLog
|
||||
@@ -1,5 +1,10 @@
|
||||
2005-07-21 Roland McGrath <roland@redhat.com>
|
||||
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
+2005-07-21 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
* Makefile.am (noinst_HEADERS): Add loc2c.c.
|
||||
|
||||
* test2.c (main): Check sscanf result to quiet warning.
|
||||
--- elfutils/libdwfl/Makefile.am
|
||||
+++ elfutils/libdwfl/Makefile.am
|
||||
@@ -15,12 +15,13 @@
|
||||
## 3001 King Ranch Road, Ukiah, CA 95482.
|
||||
##
|
||||
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
|
||||
+WEXTRA = @WEXTRA@
|
||||
if MUDFLAP
|
||||
AM_CFLAGS = -fmudflap
|
||||
else
|
||||
AM_CFLAGS =
|
||||
endif
|
||||
-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
|
||||
+AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 $(WEXTRA) -std=gnu99
|
||||
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw -I.. -I$(srcdir)/../lib
|
||||
VERSION = 1
|
||||
--- elfutils/libdwfl/Makefile.in
|
||||
+++ elfutils/libdwfl/Makefile.in
|
||||
@@ -179,6 +179,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
+WEXTRA = @WEXTRA@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -221,9 +222,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
||||
-@MUDFLAP_FALSE@ -Wextra -std=gnu99
|
||||
+@MUDFLAP_FALSE@ $(WEXTRA) -std=gnu99
|
||||
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -Wall -Werror -Wshadow -Wunused \
|
||||
-@MUDFLAP_TRUE@ -Wformat=2 -Wextra -std=gnu99
|
||||
+@MUDFLAP_TRUE@ -Wformat=2 $(WEXTRA) -std=gnu99
|
||||
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw -I.. -I$(srcdir)/../lib
|
||||
|
||||
--- elfutils/libebl/ChangeLog
|
||||
+++ elfutils/libebl/ChangeLog
|
||||
@@ -46,6 +46,11 @@
|
||||
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
|
||||
tracking works right.
|
||||
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
2005-05-21 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* libebl_x86_64.map: Add x86_64_core_note.
|
||||
--- elfutils/libebl/Makefile.am
|
||||
+++ elfutils/libebl/Makefile.am
|
||||
@@ -13,12 +13,13 @@
|
||||
@ -326,7 +424,7 @@
|
||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
|
||||
--- elfutils/libebl/Makefile.in
|
||||
+++ elfutils/libebl/Makefile.in
|
||||
@@ -236,6 +236,7 @@ SHELL = @SHELL@
|
||||
@@ -249,6 +249,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -334,7 +432,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -278,9 +279,9 @@ sharedstatedir = @sharedstatedir@
|
||||
@@ -291,9 +292,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -345,7 +443,38 @@
|
||||
+@MUDFLAP_TRUE@ -Wunused $(WEXTRA) -Wformat=2 -std=gnu99
|
||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
|
||||
lib_LIBRARIES = libebl.a
|
||||
modules = i386 sh mips x86_64 ia64 alpha arm sparc ppc ppc64
|
||||
modules = i386 sh x86_64 ia64 alpha arm sparc ppc ppc64
|
||||
--- elfutils/libelf/ChangeLog
|
||||
+++ elfutils/libelf/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
2005-05-11 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* elf.h: Update again.
|
||||
--- elfutils/libelf/common.h
|
||||
+++ elfutils/libelf/common.h
|
||||
@@ -122,7 +122,7 @@ libelf_release_all (Elf *elf)
|
||||
(Var) = (sizeof (Var) == 1 \
|
||||
? (unsigned char) (Var) \
|
||||
: (sizeof (Var) == 2 \
|
||||
- ? bswap_16 (Var) \
|
||||
+ ? (unsigned short int) bswap_16 (Var) \
|
||||
: (sizeof (Var) == 4 \
|
||||
? bswap_32 (Var) \
|
||||
: bswap_64 (Var))))
|
||||
@@ -131,7 +131,7 @@ libelf_release_all (Elf *elf)
|
||||
(Dst) = (sizeof (Var) == 1 \
|
||||
? (unsigned char) (Var) \
|
||||
: (sizeof (Var) == 2 \
|
||||
- ? bswap_16 (Var) \
|
||||
+ ? (unsigned short int) bswap_16 (Var) \
|
||||
: (sizeof (Var) == 4 \
|
||||
? bswap_32 (Var) \
|
||||
: bswap_64 (Var))))
|
||||
--- elfutils/libelf/Makefile.am
|
||||
+++ elfutils/libelf/Makefile.am
|
||||
@@ -16,12 +16,13 @@
|
||||
@ -365,7 +494,7 @@
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
--- elfutils/libelf/Makefile.in
|
||||
+++ elfutils/libelf/Makefile.in
|
||||
@@ -199,6 +199,7 @@ SHELL = @SHELL@
|
||||
@@ -201,6 +201,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -373,7 +502,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -240,10 +241,10 @@ sbindir = @sbindir@
|
||||
@@ -242,10 +243,10 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@ -388,7 +517,7 @@
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
--- elfutils/m4/Makefile.in
|
||||
+++ elfutils/m4/Makefile.in
|
||||
@@ -103,6 +103,7 @@ SHELL = @SHELL@
|
||||
@@ -105,6 +105,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -396,6 +525,45 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/Makefile.in
|
||||
+++ elfutils/Makefile.in
|
||||
@@ -129,6 +129,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
+WEXTRA = @WEXTRA@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/src/ChangeLog
|
||||
+++ elfutils/src/ChangeLog
|
||||
@@ -20,6 +20,11 @@
|
||||
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
||||
address size.
|
||||
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
2005-05-30 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* readelf.c (print_debug_line_section): Print section offset of each
|
||||
--- elfutils/src/findtextrel.c
|
||||
+++ elfutils/src/findtextrel.c
|
||||
@@ -476,7 +476,11 @@ ptrcompare (const void *p1, const void *
|
||||
|
||||
|
||||
static void
|
||||
-check_rel (size_t nsegments, struct segments segments[nsegments],
|
||||
+check_rel (size_t nsegments, struct segments segments[
|
||||
+#if __GNUC__ >= 4
|
||||
+ nsegments
|
||||
+#endif
|
||||
+ ],
|
||||
GElf_Addr addr, Elf *elf, Elf_Scn *symscn, Dwarf *dw,
|
||||
const char *fname, bool more_than_one, void **knownsrcs)
|
||||
{
|
||||
--- elfutils/src/Makefile.am
|
||||
+++ elfutils/src/Makefile.am
|
||||
@@ -14,14 +14,15 @@
|
||||
@ -418,7 +586,7 @@
|
||||
if MUDFLAP
|
||||
--- elfutils/src/Makefile.in
|
||||
+++ elfutils/src/Makefile.in
|
||||
@@ -194,6 +194,7 @@ SHELL = @SHELL@
|
||||
@@ -200,6 +200,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -426,7 +594,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@ -d
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -237,10 +238,10 @@ sysconfdir = @sysconfdir@
|
||||
@@ -243,10 +244,10 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
|
||||
@MUDFLAP_FALSE@ $(if $($(*F)_no_Werror),,-Werror) \
|
||||
@ -439,21 +607,6 @@
|
||||
@MUDFLAP_TRUE@ $(native_ld_cflags) $(if $($(*F)_no_Wunused),,-Wunused) \
|
||||
@MUDFLAP_TRUE@ $(if $($(*F)_no_Wformat),,-Wformat=2)
|
||||
|
||||
--- elfutils/src/findtextrel.c
|
||||
+++ elfutils/src/findtextrel.c
|
||||
@@ -476,7 +476,11 @@ ptrcompare (const void *p1, const void *
|
||||
|
||||
|
||||
static void
|
||||
-check_rel (size_t nsegments, struct segments segments[nsegments],
|
||||
+check_rel (size_t nsegments, struct segments segments[
|
||||
+#if __GNUC__ >= 4
|
||||
+ nsegments
|
||||
+#endif
|
||||
+ ],
|
||||
GElf_Addr addr, Elf *elf, Elf_Scn *symscn, Dwarf *dw,
|
||||
const char *fname, bool more_than_one, void **knownsrcs)
|
||||
{
|
||||
--- elfutils/src/strip.c
|
||||
+++ elfutils/src/strip.c
|
||||
@@ -40,6 +40,12 @@
|
||||
@ -506,9 +659,40 @@
|
||||
{
|
||||
error (0, errno, gettext ("\
|
||||
cannot set access and modification date of '%s'"), fname);
|
||||
--- elfutils/tests/ChangeLog
|
||||
+++ elfutils/tests/ChangeLog
|
||||
@@ -5,6 +5,11 @@
|
||||
* Makefile.am (TESTS): Add run-elflint-test.sh.
|
||||
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
|
||||
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
+ (AM_CFLAGS): Use it in place of -Wextra.
|
||||
+
|
||||
2005-05-24 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* get-files.c (main): Use correct format specifier.
|
||||
--- elfutils/tests/Makefile.am
|
||||
+++ elfutils/tests/Makefile.am
|
||||
@@ -13,11 +13,12 @@
|
||||
## 3001 King Ranch Road, Ukiah, CA 95482.
|
||||
##
|
||||
DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
|
||||
+WEXTRA = @WEXTRA@
|
||||
if MUDFLAP
|
||||
-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
|
||||
+AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 -fmudflap\
|
||||
$(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
|
||||
else
|
||||
-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
|
||||
+AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 \
|
||||
$(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
|
||||
AM_LDFLAGS = -Wl,-rpath,\$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../libebl:\$$ORIGIN/../libelf
|
||||
endif
|
||||
--- elfutils/tests/Makefile.in
|
||||
+++ elfutils/tests/Makefile.in
|
||||
@@ -266,6 +266,7 @@ SHELL = @SHELL@
|
||||
@@ -268,6 +268,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -516,3 +700,16 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -309,10 +310,10 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
|
||||
+@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 \
|
||||
@MUDFLAP_FALSE@ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
|
||||
|
||||
-@MUDFLAP_TRUE@AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
|
||||
+@MUDFLAP_TRUE@AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 -fmudflap\
|
||||
@MUDFLAP_TRUE@ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
|
||||
|
||||
@MUDFLAP_FALSE@AM_LDFLAGS = -Wl,-rpath,\$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../libebl:\$$ORIGIN/../libelf
|
||||
|
@ -1,5 +1,5 @@
|
||||
%define version 0.108
|
||||
%define release 5
|
||||
%define version 0.109
|
||||
%define release 1
|
||||
|
||||
%define gpl 0
|
||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||
@ -25,8 +25,7 @@ Group: Development/Tools
|
||||
#URL: file://home/devel/drepper/
|
||||
Source: elfutils-%{version}.tar.gz
|
||||
Patch1: elfutils-portability.patch
|
||||
Patch2: elfutils-bswap.patch
|
||||
Patch3: elfutils-0.108-robustify.patch
|
||||
Patch2: elfutils-0.108-robustify.patch
|
||||
Obsoletes: libelf libelf-devel
|
||||
Requires: elfutils-libelf = %{version}-%{release}
|
||||
%if %{gpl}
|
||||
@ -110,14 +109,13 @@ different sections of an ELF file.
|
||||
|
||||
%if %{compat}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
sleep 1
|
||||
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
|
||||
sleep 1
|
||||
find . \( -name configure -o -name config.h.in \) -print | xargs touch
|
||||
%endif
|
||||
|
||||
%patch3 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
mkdir build-%{_target_platform}
|
||||
@ -178,6 +176,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%doc fake-src/FULL
|
||||
%endif
|
||||
%{_bindir}/eu-addr2line
|
||||
%{_bindir}/eu-elfcmp
|
||||
%{_bindir}/eu-elflint
|
||||
%{_bindir}/eu-findtextrel
|
||||
%{_bindir}/eu-nm
|
||||
@ -186,10 +185,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_bindir}/eu-strip
|
||||
%if !%{gpl}
|
||||
#%{_bindir}/eu-ld
|
||||
#%{_libdir}/libasm-%{version}.so
|
||||
%{_libdir}/libdw-%{version}.so
|
||||
#%{_libdir}/libasm*.so.*
|
||||
%{_libdir}/libdw*.so.*
|
||||
%{_libdir}/libdwfl-%{version}.so
|
||||
#%{_libdir}/libasm.so.*
|
||||
%{_libdir}/libdw.so.*
|
||||
%{_libdir}/libdwfl.so.*
|
||||
%dir %{_libdir}/elfutils
|
||||
%{_libdir}/elfutils/lib*.so
|
||||
%endif
|
||||
@ -202,9 +202,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%if !%{gpl}
|
||||
%{_includedir}/elfutils/libebl.h
|
||||
%{_includedir}/elfutils/libdw.h
|
||||
%{_includedir}/elfutils/libdwfl.h
|
||||
#%{_libdir}/libasm.a
|
||||
%{_libdir}/libebl.a
|
||||
%{_libdir}/libdw.a
|
||||
%{_libdir}/libdwfl.a
|
||||
#%{_libdir}/libasm.so
|
||||
%{_libdir}/libdw.so
|
||||
%endif
|
||||
@ -212,7 +214,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%files libelf
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libelf-%{version}.so
|
||||
%{_libdir}/libelf*.so.*
|
||||
%{_libdir}/libelf.so.*
|
||||
|
||||
%files libelf-devel
|
||||
%defattr(-,root,root)
|
||||
@ -223,6 +225,13 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libelf.so
|
||||
|
||||
%changelog
|
||||
* Thu Jul 21 2005 Roland McGrath <roland@redhat.com> - 0.109-1
|
||||
- update to 0.109
|
||||
- verify that libebl modules are from the same build
|
||||
- new eu-elflint checks on copy relocations
|
||||
- new program eu-elfcmp
|
||||
- new experimental libdwfl library
|
||||
|
||||
* Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
|
||||
- robustification of eu-strip and eu-readelf
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user