New upstream version 0.123
This commit is contained in:
parent
fe99d81476
commit
a01d88f46a
@ -1,6 +1,6 @@
|
||||
--- elfutils/backends/ChangeLog
|
||||
+++ elfutils/backends/ChangeLog
|
||||
@@ -67,6 +67,11 @@
|
||||
@@ -96,6 +96,11 @@
|
||||
* sparc_init.c: Likewise.
|
||||
* x86_64_init.c: Likewise.
|
||||
|
||||
@ -12,7 +12,7 @@
|
||||
2005-11-19 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* ppc64_reloc.def: REL30 -> ADDR30.
|
||||
@@ -89,6 +94,9 @@
|
||||
@@ -118,6 +123,9 @@
|
||||
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
|
||||
(CLEANFILES): Add libebl_$(m).so.
|
||||
|
||||
@ -40,7 +40,7 @@
|
||||
-std=gnu99
|
||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
|
||||
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
|
||||
@@ -63,7 +65,7 @@ textrel_check = if readelf -d $@ | fgrep
|
||||
@@ -62,7 +64,7 @@ textrel_check = if readelf -d $@ | fgrep
|
||||
libebl_%.so: libebl_%_pic.a libebl_%.map $(libelf) $(libdw)
|
||||
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
|
||||
-Wl,--version-script,$(word 2,$^) \
|
||||
@ -51,7 +51,7 @@
|
||||
libebl_%.map: Makefile
|
||||
--- elfutils/backends/Makefile.in
|
||||
+++ elfutils/backends/Makefile.in
|
||||
@@ -158,6 +158,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -159,6 +159,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
@ -59,7 +59,7 @@
|
||||
LEX = @LEX@
|
||||
LEXLIB = @LEXLIB@
|
||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||
@@ -195,6 +196,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
||||
@@ -196,6 +197,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
||||
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -67,7 +67,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -237,9 +239,9 @@ sharedstatedir = @sharedstatedir@
|
||||
@@ -238,9 +240,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -79,7 +79,7 @@
|
||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
|
||||
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
|
||||
-I$(top_srcdir)/lib -I..
|
||||
@@ -597,7 +599,7 @@ uninstall-am: uninstall-info-am
|
||||
@@ -600,7 +602,7 @@ uninstall-am: uninstall-info-am
|
||||
libebl_%.so: libebl_%_pic.a libebl_%.map $(libelf) $(libdw)
|
||||
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
|
||||
-Wl,--version-script,$(word 2,$^) \
|
||||
@ -139,7 +139,7 @@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/configure
|
||||
+++ elfutils/configure
|
||||
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.122'
|
||||
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.123'
|
||||
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
||||
|
||||
ac_unique_file="libelf/libelf.h"
|
||||
@ -525,7 +525,7 @@
|
||||
$(COMPILE)))
|
||||
--- elfutils/libdwfl/ChangeLog
|
||||
+++ elfutils/libdwfl/ChangeLog
|
||||
@@ -337,6 +337,11 @@
|
||||
@@ -353,6 +353,11 @@
|
||||
|
||||
2005-07-21 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -647,7 +647,7 @@
|
||||
|
||||
--- elfutils/libelf/ChangeLog
|
||||
+++ elfutils/libelf/ChangeLog
|
||||
@@ -165,6 +165,11 @@
|
||||
@@ -170,6 +170,11 @@
|
||||
If section content hasn't been read yet, do it before looking for the
|
||||
block size. If no section data present, infer size of section header.
|
||||
|
||||
@ -779,7 +779,7 @@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/src/ChangeLog
|
||||
+++ elfutils/src/ChangeLog
|
||||
@@ -53,6 +53,10 @@
|
||||
@@ -74,6 +74,10 @@
|
||||
* Makefile.am: Add hacks to create dependency files for non-generic
|
||||
linker.
|
||||
|
||||
@ -790,7 +790,7 @@
|
||||
2006-06-12 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* ldgeneric.c (ld_generic_generate_sections): Don't create .interp
|
||||
@@ -401,6 +405,11 @@
|
||||
@@ -422,6 +426,11 @@
|
||||
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
||||
address size.
|
||||
|
||||
@ -936,7 +936,7 @@
|
||||
cannot set access and modification date of '%s'"), fname);
|
||||
--- elfutils/tests/ChangeLog
|
||||
+++ elfutils/tests/ChangeLog
|
||||
@@ -373,6 +373,11 @@
|
||||
@@ -385,6 +385,11 @@
|
||||
* Makefile.am (TESTS): Add run-elflint-test.sh.
|
||||
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
%define eu_version 0.122
|
||||
%define eu_release 4
|
||||
%define eu_version 0.123
|
||||
%define eu_release 1
|
||||
|
||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||
%define compat 1
|
||||
@ -20,7 +20,6 @@ Group: Development/Tools
|
||||
Source: elfutils-%{version}.tar.gz
|
||||
Patch1: elfutils-portability.patch
|
||||
Patch2: elfutils-robustify.patch
|
||||
Patch3: elfutils-0.122-cast.patch
|
||||
Obsoletes: libelf libelf-devel
|
||||
Requires: elfutils-libelf = %{version}-%{release}
|
||||
Requires: elfutils-libs = %{version}-%{release}
|
||||
@ -111,8 +110,6 @@ different sections of an ELF file.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch3 -p0
|
||||
|
||||
%if %{compat}
|
||||
%patch1 -p1
|
||||
sleep 1
|
||||
@ -217,6 +214,14 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libelf.so
|
||||
|
||||
%changelog
|
||||
* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
|
||||
- Update to 0.123
|
||||
- libebl: Backend build fixes, thanks to Stepan Kasal.
|
||||
- libebl: ia64 backend support for register names, return value location
|
||||
- libdwfl: Handle truncated linux kernel module section names.
|
||||
- libdwfl: Look for linux kernel vmlinux files with .debug suffix.
|
||||
- elflint: Fix checks to permit --hash-style=gnu format.
|
||||
|
||||
* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
|
||||
- Fix warnings in elflint compilation.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user