0.106 from upstream
This commit is contained in:
parent
d221b95875
commit
6788433c34
@ -1 +1 @@
|
|||||||
elfutils-0.104.tar.gz
|
elfutils-0.106.tar.gz
|
||||||
|
@ -1,16 +1,22 @@
|
|||||||
2005-02-07 Roland McGrath <roland@frob.com>
|
--- elfutils/ChangeLog
|
||||||
|
+++ elfutils/ChangeLog
|
||||||
* configure.ac (WEXTRA): Check for -Wextra and set this substitution.
|
@@ -1,3 +1,16 @@
|
||||||
|
+2005-02-07 Roland McGrath <roland@frob.com>
|
||||||
2003-08-12 Roland McGrath <roland@redhat.com>
|
+
|
||||||
|
+ * configure.ac (WEXTRA): Check for -Wextra and set this substitution.
|
||||||
* configure.ac: Check for struct stat st_?tim members.
|
+
|
||||||
* src/strip.c (process_file): Use st_?time if st_?tim are not there.
|
+2003-08-12 Roland McGrath <roland@redhat.com>
|
||||||
|
+
|
||||||
* configure.ac: Check for futimes function.
|
+ * configure.ac: Check for struct stat st_?tim members.
|
||||||
* src/strip.c (handle_elf) [! HAVE_FUTIMES]: Use utimes instead.
|
+ * src/strip.c (process_file): Use st_?time if st_?tim are not there.
|
||||||
(handle_ar) [! HAVE_FUTIMES]: Likewise.
|
+
|
||||||
|
+ * configure.ac: Check for futimes function.
|
||||||
|
+ * src/strip.c (handle_elf) [! HAVE_FUTIMES]: Use utimes instead.
|
||||||
|
+ (handle_ar) [! HAVE_FUTIMES]: Likewise.
|
||||||
|
+
|
||||||
|
2005-02-22 Ulrich Drepper <drepper@redhat.com>
|
||||||
|
|
||||||
|
* Makefile.am (all_SUBDIRS): Don't add doc subdir for now.
|
||||||
--- elfutils/Makefile.in
|
--- elfutils/Makefile.in
|
||||||
+++ elfutils/Makefile.in
|
+++ elfutils/Makefile.in
|
||||||
@@ -127,6 +127,7 @@ SHELL = @SHELL@
|
@@ -127,6 +127,7 @@ SHELL = @SHELL@
|
||||||
@ -33,7 +39,7 @@
|
|||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
--- elfutils/configure
|
--- elfutils/configure
|
||||||
+++ elfutils/configure
|
+++ elfutils/configure
|
||||||
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.104'
|
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.106'
|
||||||
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
||||||
|
|
||||||
ac_unique_file="libelf/libelf.h"
|
ac_unique_file="libelf/libelf.h"
|
||||||
@ -42,7 +48,7 @@
|
|||||||
ac_subst_files=''
|
ac_subst_files=''
|
||||||
|
|
||||||
# Initialize some variables set by options.
|
# Initialize some variables set by options.
|
||||||
@@ -3373,6 +3373,56 @@ echo "$as_me: error: gcc with C99 suppor
|
@@ -3373,6 +3373,58 @@ echo "$as_me: error: gcc with C99 suppor
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
||||||
@ -93,13 +99,15 @@
|
|||||||
+
|
+
|
||||||
+if test "x$ac_cv_cc_wextra" = yes; then
|
+if test "x$ac_cv_cc_wextra" = yes; then
|
||||||
+ WEXTRA=-Wextra
|
+ WEXTRA=-Wextra
|
||||||
|
+else
|
||||||
|
+ WEXTRA=-W
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
LOCALEDIR=$datadir
|
LOCALEDIR=$datadir
|
||||||
|
|
||||||
cat >>confdefs.h <<_ACEOF
|
cat >>confdefs.h <<_ACEOF
|
||||||
@@ -4818,6 +4868,7 @@ s,@YACC@,$YACC,;t t
|
@@ -4818,6 +4870,7 @@ s,@YACC@,$YACC,;t t
|
||||||
s,@LEX@,$LEX,;t t
|
s,@LEX@,$LEX,;t t
|
||||||
s,@LEXLIB@,$LEXLIB,;t t
|
s,@LEXLIB@,$LEXLIB,;t t
|
||||||
s,@LEX_OUTPUT_ROOT@,$LEX_OUTPUT_ROOT,;t t
|
s,@LEX_OUTPUT_ROOT@,$LEX_OUTPUT_ROOT,;t t
|
||||||
@ -120,7 +128,7 @@
|
|||||||
+ ac_cv_cc_wextra, ac_cv_cc_wextra=no)
|
+ ac_cv_cc_wextra, ac_cv_cc_wextra=no)
|
||||||
+CFLAGS="$old_CFLAGS"])
|
+CFLAGS="$old_CFLAGS"])
|
||||||
+AC_SUBST(WEXTRA)
|
+AC_SUBST(WEXTRA)
|
||||||
+AS_IF([test "x$ac_cv_cc_wextra" = yes], [WEXTRA=-Wextra])
|
+AS_IF([test "x$ac_cv_cc_wextra" = yes], [WEXTRA=-Wextra], [WEXTRA=-W])
|
||||||
+
|
+
|
||||||
LOCALEDIR=$datadir
|
LOCALEDIR=$datadir
|
||||||
AC_SUBST(LOCALEDIR)
|
AC_SUBST(LOCALEDIR)
|
||||||
@ -215,6 +223,17 @@
|
|||||||
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
|
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
|
||||||
-I$(top_srcdir)/lib
|
-I$(top_srcdir)/lib
|
||||||
|
|
||||||
|
--- elfutils/libcpu/ChangeLog
|
||||||
|
+++ elfutils/libcpu/ChangeLog
|
||||||
|
@@ -1,3 +1,8 @@
|
||||||
|
+2005-04-04 Roland McGrath <roland@redhat.com>
|
||||||
|
+
|
||||||
|
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||||
|
+ (AM_CFLAGS): Use it instead of -Wextra.
|
||||||
|
+
|
||||||
|
2005-02-15 Ulrich Drepper <drepper@redhat.com>
|
||||||
|
|
||||||
|
* Makefile (AM_CFLAGS): Add -Wunused -Wextra -Wformat=2.
|
||||||
--- elfutils/libcpu/Makefile.am
|
--- elfutils/libcpu/Makefile.am
|
||||||
+++ elfutils/libcpu/Makefile.am
|
+++ elfutils/libcpu/Makefile.am
|
||||||
@@ -13,7 +13,8 @@
|
@@ -13,7 +13,8 @@
|
||||||
@ -265,7 +284,7 @@
|
|||||||
|
|
||||||
--- elfutils/libdw/Makefile.in
|
--- elfutils/libdw/Makefile.in
|
||||||
+++ elfutils/libdw/Makefile.in
|
+++ elfutils/libdw/Makefile.in
|
||||||
@@ -183,6 +183,7 @@ SHELL = @SHELL@
|
@@ -190,6 +190,7 @@ SHELL = @SHELL@
|
||||||
STRIP = @STRIP@
|
STRIP = @STRIP@
|
||||||
USE_NLS = @USE_NLS@
|
USE_NLS = @USE_NLS@
|
||||||
VERSION = 1
|
VERSION = 1
|
||||||
@ -273,7 +292,7 @@
|
|||||||
XGETTEXT = @XGETTEXT@
|
XGETTEXT = @XGETTEXT@
|
||||||
YACC = @YACC@
|
YACC = @YACC@
|
||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
@@ -225,9 +226,9 @@ sharedstatedir = @sharedstatedir@
|
@@ -232,9 +233,9 @@ sharedstatedir = @sharedstatedir@
|
||||||
sysconfdir = @sysconfdir@
|
sysconfdir = @sysconfdir@
|
||||||
target_alias = @target_alias@
|
target_alias = @target_alias@
|
||||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
||||||
@ -396,7 +415,7 @@
|
|||||||
if MUDFLAP
|
if MUDFLAP
|
||||||
--- elfutils/src/Makefile.in
|
--- elfutils/src/Makefile.in
|
||||||
+++ elfutils/src/Makefile.in
|
+++ elfutils/src/Makefile.in
|
||||||
@@ -189,6 +189,7 @@ SHELL = @SHELL@
|
@@ -192,6 +192,7 @@ SHELL = @SHELL@
|
||||||
STRIP = @STRIP@
|
STRIP = @STRIP@
|
||||||
USE_NLS = @USE_NLS@
|
USE_NLS = @USE_NLS@
|
||||||
VERSION = @VERSION@
|
VERSION = @VERSION@
|
||||||
@ -404,7 +423,7 @@
|
|||||||
XGETTEXT = @XGETTEXT@
|
XGETTEXT = @XGETTEXT@
|
||||||
YACC = @YACC@ -d
|
YACC = @YACC@ -d
|
||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
@@ -232,10 +233,10 @@ sysconfdir = @sysconfdir@
|
@@ -235,10 +236,10 @@ sysconfdir = @sysconfdir@
|
||||||
target_alias = @target_alias@
|
target_alias = @target_alias@
|
||||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
|
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
|
||||||
@MUDFLAP_FALSE@ $(if $($(*F)_no_Werror),,-Werror) \
|
@MUDFLAP_FALSE@ $(if $($(*F)_no_Werror),,-Werror) \
|
||||||
@ -471,7 +490,7 @@
|
|||||||
cannot set access and modification date of \"%s\""), fname);
|
cannot set access and modification date of \"%s\""), fname);
|
||||||
--- elfutils/tests/Makefile.in
|
--- elfutils/tests/Makefile.in
|
||||||
+++ elfutils/tests/Makefile.in
|
+++ elfutils/tests/Makefile.in
|
||||||
@@ -257,6 +257,7 @@ SHELL = @SHELL@
|
@@ -266,6 +266,7 @@ SHELL = @SHELL@
|
||||||
STRIP = @STRIP@
|
STRIP = @STRIP@
|
||||||
USE_NLS = @USE_NLS@
|
USE_NLS = @USE_NLS@
|
||||||
VERSION = @VERSION@
|
VERSION = @VERSION@
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
%define version 0.104
|
%define version 0.106
|
||||||
%define release 3
|
%define release 1
|
||||||
|
|
||||||
%define gpl 0
|
%define gpl 0
|
||||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||||
@ -11,10 +11,10 @@
|
|||||||
Summary: A collection of utilities and DSOs to handle compiled objects.
|
Summary: A collection of utilities and DSOs to handle compiled objects.
|
||||||
Name: elfutils
|
Name: elfutils
|
||||||
Version: %{version}
|
Version: %{version}
|
||||||
%if %{compat}
|
%if !%{compat}
|
||||||
Release: 0.%{release}
|
|
||||||
%else
|
|
||||||
Release: %{release}
|
Release: %{release}
|
||||||
|
%else
|
||||||
|
Release: 0.%{release}
|
||||||
%endif
|
%endif
|
||||||
%if %{gpl}
|
%if %{gpl}
|
||||||
License: GPL
|
License: GPL
|
||||||
@ -24,9 +24,10 @@ License: OSL
|
|||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
#URL: file://home/devel/drepper/
|
#URL: file://home/devel/drepper/
|
||||||
Source: elfutils-%{version}.tar.gz
|
Source: elfutils-%{version}.tar.gz
|
||||||
|
Patch1: elfutils-0.106-libdw-compile.patch
|
||||||
%if %{compat}
|
%if %{compat}
|
||||||
Patch1: elfutils-portability.patch
|
Patch100: elfutils-portability.patch
|
||||||
Patch2: elfutils-bswap.patch
|
Patch101: elfutils-bswap.patch
|
||||||
%endif
|
%endif
|
||||||
Obsoletes: libelf libelf-devel
|
Obsoletes: libelf libelf-devel
|
||||||
Requires: elfutils-libelf = %{version}-%{release}
|
Requires: elfutils-libelf = %{version}-%{release}
|
||||||
@ -109,9 +110,11 @@ different sections of an ELF file.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%if %{compat}
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
%if %{compat}
|
||||||
|
%patch100 -p1
|
||||||
|
%patch101 -p1
|
||||||
sleep 1
|
sleep 1
|
||||||
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
|
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
|
||||||
sleep 1
|
sleep 1
|
||||||
@ -175,6 +178,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%if %{gpl}
|
%if %{gpl}
|
||||||
%doc fake-src/FULL
|
%doc fake-src/FULL
|
||||||
%endif
|
%endif
|
||||||
|
%{_bindir}/eu-addr2line
|
||||||
%{_bindir}/eu-elflint
|
%{_bindir}/eu-elflint
|
||||||
%{_bindir}/eu-findtextrel
|
%{_bindir}/eu-findtextrel
|
||||||
%{_bindir}/eu-nm
|
%{_bindir}/eu-nm
|
||||||
@ -220,6 +224,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_libdir}/libelf.so
|
%{_libdir}/libelf.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
|
||||||
|
- update to 0.106
|
||||||
|
|
||||||
* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
|
* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
|
||||||
- update to 0.104
|
- update to 0.104
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user