Update to 0.110
This commit is contained in:
parent
a00f4585a9
commit
469b3c7faf
@ -32,12 +32,12 @@
|
||||
+++ elfutils/configure
|
||||
@@ -1,5 +1,5 @@
|
||||
#! /bin/sh
|
||||
-# From configure.ac Revision: 1.49 .
|
||||
+# From configure.ac Revision: 1.47.2.4 .
|
||||
-# From configure.ac Revision: 1.50 .
|
||||
+# From configure.ac Revision: 1.47.2.5 .
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
# Generated by GNU Autoconf 2.59 for Red Hat elfutils 0.109.
|
||||
# Generated by GNU Autoconf 2.59 for Red Hat elfutils 0.110.
|
||||
#
|
||||
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.109'
|
||||
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.110'
|
||||
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
||||
|
||||
ac_unique_file="libelf/libelf.h"
|
||||
@ -119,8 +119,8 @@
|
||||
AC_CONFIG_FILES([config/Makefile])
|
||||
|
||||
AC_COPYRIGHT([Copyright (C) 1996-2003, 2004, 2005 Red Hat, Inc.])
|
||||
-AC_REVISION($Revision: 1.8 $)
|
||||
+AC_REVISION($Revision: 1.8 $)
|
||||
-AC_REVISION($Revision: 1.9 $)
|
||||
+AC_REVISION($Revision: 1.9 $)
|
||||
AC_PREREQ(2.59) dnl Minimum Autoconf version required.
|
||||
|
||||
AM_INIT_AUTOMAKE([gnits 1.7])
|
||||
@ -288,7 +288,7 @@
|
||||
libcpu_i386_a_SOURCES = i386_dis.c
|
||||
--- elfutils/libdw/ChangeLog
|
||||
+++ elfutils/libdw/ChangeLog
|
||||
@@ -35,6 +35,11 @@
|
||||
@@ -44,6 +44,11 @@
|
||||
|
||||
2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -341,7 +341,8 @@
|
||||
@MUDFLAP_FALSE@noinst_LIBRARIES = libdw_pic.a
|
||||
--- elfutils/libdwfl/ChangeLog
|
||||
+++ elfutils/libdwfl/ChangeLog
|
||||
@@ -1,5 +1,10 @@
|
||||
@@ -4,6 +4,11 @@
|
||||
|
||||
2005-07-21 Roland McGrath <roland@redhat.com>
|
||||
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
@ -371,7 +372,7 @@
|
||||
VERSION = 1
|
||||
--- elfutils/libdwfl/Makefile.in
|
||||
+++ elfutils/libdwfl/Makefile.in
|
||||
@@ -179,6 +179,7 @@ SHELL = @SHELL@
|
||||
@@ -184,6 +184,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -379,7 +380,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -221,9 +222,9 @@ sharedstatedir = @sharedstatedir@
|
||||
@@ -226,9 +227,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
||||
@ -393,7 +394,7 @@
|
||||
|
||||
--- elfutils/libebl/ChangeLog
|
||||
+++ elfutils/libebl/ChangeLog
|
||||
@@ -46,6 +46,11 @@
|
||||
@@ -58,6 +58,11 @@
|
||||
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
|
||||
tracking works right.
|
||||
|
||||
@ -446,7 +447,10 @@
|
||||
modules = i386 sh x86_64 ia64 alpha arm sparc ppc ppc64
|
||||
--- elfutils/libelf/ChangeLog
|
||||
+++ elfutils/libelf/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
@@ -18,6 +18,11 @@
|
||||
If section content hasn't been read yet, do it before looking for the
|
||||
block size. If no section data present, infer size of section header.
|
||||
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
@ -537,7 +541,7 @@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/src/ChangeLog
|
||||
+++ elfutils/src/ChangeLog
|
||||
@@ -20,6 +20,11 @@
|
||||
@@ -44,6 +44,11 @@
|
||||
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
||||
address size.
|
||||
|
||||
@ -641,7 +645,7 @@
|
||||
}
|
||||
|
||||
/* Open the file. */
|
||||
@@ -1677,7 +1693,7 @@ handle_elf (int fd, Elf *elf, const char
|
||||
@@ -1678,7 +1694,7 @@ handle_elf (int fd, Elf *elf, const char
|
||||
/* If requested, preserve the timestamp. */
|
||||
if (tvp != NULL)
|
||||
{
|
||||
@ -650,7 +654,7 @@
|
||||
{
|
||||
error (0, errno, gettext ("\
|
||||
cannot set access and modification date of '%s'"),
|
||||
@@ -1734,7 +1750,7 @@ handle_ar (int fd, Elf *elf, const char
|
||||
@@ -1735,7 +1751,7 @@ handle_ar (int fd, Elf *elf, const char
|
||||
|
||||
if (tvp != NULL)
|
||||
{
|
||||
|
@ -1,5 +1,5 @@
|
||||
%define version 0.109
|
||||
%define release 2
|
||||
%define version 0.110
|
||||
%define release 1
|
||||
|
||||
%define gpl 0
|
||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||
@ -226,6 +226,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libelf.so
|
||||
|
||||
%changelog
|
||||
* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
|
||||
- update to 0.110
|
||||
|
||||
* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
|
||||
- update to 0.109
|
||||
- verify that libebl modules are from the same build
|
||||
|
Loading…
Reference in New Issue
Block a user