disable unstrip-n check on s390* and ppc* (#835877)
This commit is contained in:
parent
1d2f5631a4
commit
33bbf67f49
42
elfutils-0.154-nounstripcheck-835877.patch
Normal file
42
elfutils-0.154-nounstripcheck-835877.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
diff -up elfutils-0.154/tests/Makefile.am.835877 elfutils-0.154/tests/Makefile.am
|
||||||
|
--- elfutils-0.154/tests/Makefile.am.835877 2012-07-02 07:20:15.050457120 -0400
|
||||||
|
+++ elfutils-0.154/tests/Makefile.am 2012-07-02 07:21:01.880423371 -0400
|
||||||
|
@@ -79,7 +79,7 @@ TESTS = run-arextract.sh run-arsymtest.s
|
||||||
|
run-early-offscn.sh run-dwarf-getmacros.sh \
|
||||||
|
run-test-flag-nobits.sh run-prelink-addr-test.sh \
|
||||||
|
run-dwarf-getstring.sh run-rerequest_tag.sh run-typeiter.sh \
|
||||||
|
- run-readelf-d.sh run-unstrip-n.sh run-low_high_pc.sh
|
||||||
|
+ run-readelf-d.sh run-low_high_pc.sh
|
||||||
|
|
||||||
|
if !STANDALONE
|
||||||
|
noinst_PROGRAMS += msg_tst md5-sha1-test
|
||||||
|
@@ -156,7 +156,7 @@ EXTRA_DIST = run-arextract.sh run-arsymt
|
||||||
|
testfile56.bz2 testfile57.bz2 testfile58.bz2 \
|
||||||
|
run-typeiter.sh testfile59.bz2 \
|
||||||
|
run-readelf-d.sh testlib_dynseg.so.bz2 \
|
||||||
|
- run-unstrip-n.sh testcore-rtlib.bz2 \
|
||||||
|
+ testcore-rtlib.bz2 \
|
||||||
|
run-low_high_pc.sh testfile_low_high_pc.bz2
|
||||||
|
|
||||||
|
installed_TESTS_ENVIRONMENT = libdir=$(DESTDIR)$(libdir) \
|
||||||
|
diff -up elfutils-0.154/tests/Makefile.in.835877 elfutils-0.154/tests/Makefile.in
|
||||||
|
--- elfutils-0.154/tests/Makefile.in.835877 2012-07-02 07:20:07.830415701 -0400
|
||||||
|
+++ elfutils-0.154/tests/Makefile.in 2012-07-02 07:20:49.900433188 -0400
|
||||||
|
@@ -87,7 +87,7 @@ TESTS = run-arextract.sh run-arsymtest.s
|
||||||
|
run-dwarf-getmacros.sh run-test-flag-nobits.sh \
|
||||||
|
run-prelink-addr-test.sh run-dwarf-getstring.sh \
|
||||||
|
run-rerequest_tag.sh run-typeiter.sh run-readelf-d.sh \
|
||||||
|
- run-unstrip-n.sh run-low_high_pc.sh $(am__EXEEXT_1) \
|
||||||
|
+ run-low_high_pc.sh $(am__EXEEXT_1) \
|
||||||
|
$(am__EXEEXT_3)
|
||||||
|
@STANDALONE_FALSE@am__append_5 = msg_tst md5-sha1-test
|
||||||
|
@STANDALONE_FALSE@am__append_6 = msg_tst md5-sha1-test
|
||||||
|
@@ -575,7 +575,7 @@ EXTRA_DIST = run-arextract.sh run-arsymt
|
||||||
|
testfile56.bz2 testfile57.bz2 testfile58.bz2 \
|
||||||
|
run-typeiter.sh testfile59.bz2 \
|
||||||
|
run-readelf-d.sh testlib_dynseg.so.bz2 \
|
||||||
|
- run-unstrip-n.sh testcore-rtlib.bz2 \
|
||||||
|
+ testcore-rtlib.bz2 \
|
||||||
|
run-low_high_pc.sh testfile_low_high_pc.bz2
|
||||||
|
|
||||||
|
installed_TESTS_ENVIRONMENT = libdir=$(DESTDIR)$(libdir) \
|
@ -1,7 +1,7 @@
|
|||||||
Name: elfutils
|
Name: elfutils
|
||||||
Summary: A collection of utilities and DSOs to handle compiled objects
|
Summary: A collection of utilities and DSOs to handle compiled objects
|
||||||
Version: 0.154
|
Version: 0.154
|
||||||
%global baserelease 1
|
%global baserelease 1.1
|
||||||
URL: https://fedorahosted.org/elfutils/
|
URL: https://fedorahosted.org/elfutils/
|
||||||
%global source_url http://fedorahosted.org/releases/e/l/elfutils/%{version}/
|
%global source_url http://fedorahosted.org/releases/e/l/elfutils/%{version}/
|
||||||
License: GPLv3+ and (GPLv2+ or LGPLv3+)
|
License: GPLv3+ and (GPLv2+ or LGPLv3+)
|
||||||
@ -46,6 +46,9 @@ Source: %{?source_url}%{name}-%{version}.tar.bz2
|
|||||||
Patch1: %{?source_url}elfutils-robustify.patch
|
Patch1: %{?source_url}elfutils-robustify.patch
|
||||||
Patch2: %{?source_url}elfutils-portability.patch
|
Patch2: %{?source_url}elfutils-portability.patch
|
||||||
Patch3: elfutils-0.154-binutils-pr-ld-13621.patch
|
Patch3: elfutils-0.154-binutils-pr-ld-13621.patch
|
||||||
|
%ifarch ppc %{power64} s390 s390x
|
||||||
|
Patch4: elfutils-0.154-nounstripcheck-835877.patch
|
||||||
|
%endif
|
||||||
|
|
||||||
%if !%{compat}
|
%if !%{compat}
|
||||||
Release: %{baserelease}%{?dist}
|
Release: %{baserelease}%{?dist}
|
||||||
@ -211,6 +214,7 @@ sed -i.scanf-m -e 's/%m/%a/g' src/addr2line.c tests/line2addr.c
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch3 -p1 -b .binutils-pr-ld-13621
|
%patch3 -p1 -b .binutils-pr-ld-13621
|
||||||
|
%patch4 -p1 -b .nounstripcheck-835877
|
||||||
|
|
||||||
find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
|
find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
|
||||||
|
|
||||||
@ -327,6 +331,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_libdir}/libelf.a
|
%{_libdir}/libelf.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 02 2012 Karsten Hopp <karsten@redhat.com> 0.154-1.1
|
||||||
|
- disable unstrip-n check for now (835877)
|
||||||
|
|
||||||
* Fri Jun 22 2012 Mark Wielaard <mjw@redhat.com> - 0.154-1
|
* Fri Jun 22 2012 Mark Wielaard <mjw@redhat.com> - 0.154-1
|
||||||
- Update to 0.154
|
- Update to 0.154
|
||||||
- elflint doesn't recognize SHF_INFO_LINK on relocation sections (#807823)
|
- elflint doesn't recognize SHF_INFO_LINK on relocation sections (#807823)
|
||||||
|
Loading…
Reference in New Issue
Block a user