New upstream release 0.118
This commit is contained in:
parent
78e97639f4
commit
3025bebb20
2
Makefile
2
Makefile
@ -26,6 +26,8 @@ portable.srpm = elfutils-$(portable-vr).src.rpm
|
|||||||
$(portable.srpm): elfutils-portable.spec elfutils-portability.patch sources
|
$(portable.srpm): elfutils-portable.spec elfutils-portability.patch sources
|
||||||
$(RPM_WITH_DIRS) --nodeps -bs $<
|
$(RPM_WITH_DIRS) --nodeps -bs $<
|
||||||
|
|
||||||
|
portable-srpm: $(portable.srpm)
|
||||||
|
|
||||||
portable-dist = 3.0E-scratch
|
portable-dist = 3.0E-scratch
|
||||||
portable-beehive = $(redhat)/dist/$(portable-dist)/elfutils/$(portable-vr)
|
portable-beehive = $(redhat)/dist/$(portable-dist)/elfutils/$(portable-vr)
|
||||||
|
|
||||||
|
@ -1,6 +1,9 @@
|
|||||||
--- elfutils/backends/ChangeLog
|
--- elfutils/backends/ChangeLog
|
||||||
+++ elfutils/backends/ChangeLog
|
+++ elfutils/backends/ChangeLog
|
||||||
@@ -1,3 +1,8 @@
|
@@ -19,6 +19,11 @@
|
||||||
|
* sparc_init.c: Likewise.
|
||||||
|
* x86_64_init.c: Likewise.
|
||||||
|
|
||||||
+2005-11-22 Roland McGrath <roland@redhat.com>
|
+2005-11-22 Roland McGrath <roland@redhat.com>
|
||||||
+
|
+
|
||||||
+ * Makefile.am (LD_AS_NEEDED): New variable, substituted by configure.
|
+ * Makefile.am (LD_AS_NEEDED): New variable, substituted by configure.
|
||||||
@ -9,7 +12,7 @@
|
|||||||
2005-11-19 Roland McGrath <roland@redhat.com>
|
2005-11-19 Roland McGrath <roland@redhat.com>
|
||||||
|
|
||||||
* ppc64_reloc.def: REL30 -> ADDR30.
|
* ppc64_reloc.def: REL30 -> ADDR30.
|
||||||
@@ -20,6 +25,9 @@
|
@@ -41,6 +46,9 @@
|
||||||
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
|
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
|
||||||
(CLEANFILES): Add libebl_$(m).so.
|
(CLEANFILES): Add libebl_$(m).so.
|
||||||
|
|
||||||
@ -48,7 +51,7 @@
|
|||||||
libebl_%.map: Makefile
|
libebl_%.map: Makefile
|
||||||
--- elfutils/backends/Makefile.in
|
--- elfutils/backends/Makefile.in
|
||||||
+++ elfutils/backends/Makefile.in
|
+++ elfutils/backends/Makefile.in
|
||||||
@@ -156,6 +156,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
@@ -159,6 +159,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||||
LDFLAGS = @LDFLAGS@
|
LDFLAGS = @LDFLAGS@
|
||||||
@ -56,7 +59,7 @@
|
|||||||
LEX = @LEX@
|
LEX = @LEX@
|
||||||
LEXLIB = @LEXLIB@
|
LEXLIB = @LEXLIB@
|
||||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||||
@@ -191,6 +192,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
@@ -194,6 +195,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
||||||
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
||||||
USE_NLS = @USE_NLS@
|
USE_NLS = @USE_NLS@
|
||||||
VERSION = @VERSION@
|
VERSION = @VERSION@
|
||||||
@ -64,7 +67,7 @@
|
|||||||
XGETTEXT = @XGETTEXT@
|
XGETTEXT = @XGETTEXT@
|
||||||
YACC = @YACC@
|
YACC = @YACC@
|
||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
@@ -233,9 +235,9 @@ sharedstatedir = @sharedstatedir@
|
@@ -236,9 +238,9 @@ sharedstatedir = @sharedstatedir@
|
||||||
sysconfdir = @sysconfdir@
|
sysconfdir = @sysconfdir@
|
||||||
target_alias = @target_alias@
|
target_alias = @target_alias@
|
||||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||||
@ -76,7 +79,7 @@
|
|||||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
|
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
|
||||||
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
|
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
|
||||||
-I$(top_srcdir)/lib -I..
|
-I$(top_srcdir)/lib -I..
|
||||||
@@ -583,7 +585,7 @@ uninstall-am: uninstall-info-am
|
@@ -594,7 +596,7 @@ uninstall-am: uninstall-info-am
|
||||||
libebl_%.so: libebl_%_pic.a libebl_%.map $(libelf) $(libdw)
|
libebl_%.so: libebl_%_pic.a libebl_%.map $(libelf) $(libdw)
|
||||||
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
|
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
|
||||||
-Wl,--version-script,$(word 2,$^) \
|
-Wl,--version-script,$(word 2,$^) \
|
||||||
@ -133,7 +136,7 @@
|
|||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
--- elfutils/configure
|
--- elfutils/configure
|
||||||
+++ elfutils/configure
|
+++ elfutils/configure
|
||||||
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.117'
|
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.118'
|
||||||
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
||||||
|
|
||||||
ac_unique_file="libelf/libelf.h"
|
ac_unique_file="libelf/libelf.h"
|
||||||
@ -455,7 +458,7 @@
|
|||||||
libcpu_i386_a_SOURCES = i386_dis.c
|
libcpu_i386_a_SOURCES = i386_dis.c
|
||||||
--- elfutils/libdw/ChangeLog
|
--- elfutils/libdw/ChangeLog
|
||||||
+++ elfutils/libdw/ChangeLog
|
+++ elfutils/libdw/ChangeLog
|
||||||
@@ -247,6 +247,11 @@
|
@@ -251,6 +251,11 @@
|
||||||
|
|
||||||
2005-05-31 Roland McGrath <roland@redhat.com>
|
2005-05-31 Roland McGrath <roland@redhat.com>
|
||||||
|
|
||||||
@ -519,7 +522,7 @@
|
|||||||
$(COMPILE)))
|
$(COMPILE)))
|
||||||
--- elfutils/libdwfl/ChangeLog
|
--- elfutils/libdwfl/ChangeLog
|
||||||
+++ elfutils/libdwfl/ChangeLog
|
+++ elfutils/libdwfl/ChangeLog
|
||||||
@@ -223,6 +223,11 @@
|
@@ -245,6 +245,11 @@
|
||||||
|
|
||||||
2005-07-21 Roland McGrath <roland@redhat.com>
|
2005-07-21 Roland McGrath <roland@redhat.com>
|
||||||
|
|
||||||
@ -550,7 +553,7 @@
|
|||||||
VERSION = 1
|
VERSION = 1
|
||||||
--- elfutils/libdwfl/Makefile.in
|
--- elfutils/libdwfl/Makefile.in
|
||||||
+++ elfutils/libdwfl/Makefile.in
|
+++ elfutils/libdwfl/Makefile.in
|
||||||
@@ -135,6 +135,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
@@ -136,6 +136,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||||
LDFLAGS = @LDFLAGS@
|
LDFLAGS = @LDFLAGS@
|
||||||
@ -558,7 +561,7 @@
|
|||||||
LEX = @LEX@
|
LEX = @LEX@
|
||||||
LEXLIB = @LEXLIB@
|
LEXLIB = @LEXLIB@
|
||||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||||
@@ -170,6 +171,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
@@ -171,6 +172,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
||||||
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
||||||
USE_NLS = @USE_NLS@
|
USE_NLS = @USE_NLS@
|
||||||
VERSION = 1
|
VERSION = 1
|
||||||
@ -566,7 +569,7 @@
|
|||||||
XGETTEXT = @XGETTEXT@
|
XGETTEXT = @XGETTEXT@
|
||||||
YACC = @YACC@
|
YACC = @YACC@
|
||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
@@ -212,9 +214,9 @@ sharedstatedir = @sharedstatedir@
|
@@ -213,9 +215,9 @@ sharedstatedir = @sharedstatedir@
|
||||||
sysconfdir = @sysconfdir@
|
sysconfdir = @sysconfdir@
|
||||||
target_alias = @target_alias@
|
target_alias = @target_alias@
|
||||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
||||||
@ -580,7 +583,7 @@
|
|||||||
|
|
||||||
--- elfutils/libebl/ChangeLog
|
--- elfutils/libebl/ChangeLog
|
||||||
+++ elfutils/libebl/ChangeLog
|
+++ elfutils/libebl/ChangeLog
|
||||||
@@ -391,6 +391,11 @@
|
@@ -400,6 +400,11 @@
|
||||||
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
|
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
|
||||||
tracking works right.
|
tracking works right.
|
||||||
|
|
||||||
@ -773,7 +776,7 @@
|
|||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
--- elfutils/src/ChangeLog
|
--- elfutils/src/ChangeLog
|
||||||
+++ elfutils/src/ChangeLog
|
+++ elfutils/src/ChangeLog
|
||||||
@@ -220,6 +220,11 @@
|
@@ -236,6 +236,11 @@
|
||||||
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
||||||
address size.
|
address size.
|
||||||
|
|
||||||
@ -906,7 +909,7 @@
|
|||||||
cannot set access and modification date of '%s'"), fname);
|
cannot set access and modification date of '%s'"), fname);
|
||||||
--- elfutils/tests/ChangeLog
|
--- elfutils/tests/ChangeLog
|
||||||
+++ elfutils/tests/ChangeLog
|
+++ elfutils/tests/ChangeLog
|
||||||
@@ -295,6 +295,11 @@
|
@@ -316,6 +316,11 @@
|
||||||
* Makefile.am (TESTS): Add run-elflint-test.sh.
|
* Makefile.am (TESTS): Add run-elflint-test.sh.
|
||||||
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
|
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
|
||||||
|
|
||||||
@ -938,7 +941,7 @@
|
|||||||
endif
|
endif
|
||||||
--- elfutils/tests/Makefile.in
|
--- elfutils/tests/Makefile.in
|
||||||
+++ elfutils/tests/Makefile.in
|
+++ elfutils/tests/Makefile.in
|
||||||
@@ -280,6 +280,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
@@ -283,6 +283,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||||
LDFLAGS = @LDFLAGS@
|
LDFLAGS = @LDFLAGS@
|
||||||
@ -946,7 +949,7 @@
|
|||||||
LEX = @LEX@
|
LEX = @LEX@
|
||||||
LEXLIB = @LEXLIB@
|
LEXLIB = @LEXLIB@
|
||||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||||
@@ -315,6 +316,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
@@ -318,6 +319,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
|
||||||
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
|
||||||
USE_NLS = @USE_NLS@
|
USE_NLS = @USE_NLS@
|
||||||
VERSION = @VERSION@
|
VERSION = @VERSION@
|
||||||
@ -954,7 +957,7 @@
|
|||||||
XGETTEXT = @XGETTEXT@
|
XGETTEXT = @XGETTEXT@
|
||||||
YACC = @YACC@
|
YACC = @YACC@
|
||||||
ac_ct_CC = @ac_ct_CC@
|
ac_ct_CC = @ac_ct_CC@
|
||||||
@@ -356,10 +358,10 @@ sbindir = @sbindir@
|
@@ -359,10 +361,10 @@ sbindir = @sbindir@
|
||||||
sharedstatedir = @sharedstatedir@
|
sharedstatedir = @sharedstatedir@
|
||||||
sysconfdir = @sysconfdir@
|
sysconfdir = @sysconfdir@
|
||||||
target_alias = @target_alias@
|
target_alias = @target_alias@
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
%define version 0.117
|
%define version 0.118
|
||||||
%define release 2
|
%define release 1
|
||||||
|
|
||||||
%define gpl 0
|
%define gpl 0
|
||||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||||
@ -146,7 +146,7 @@ find . \( -name configure -o -name config.h.in \) -print | xargs touch
|
|||||||
# the makefiles disable some specific warnings for specific code.
|
# the makefiles disable some specific warnings for specific code.
|
||||||
RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
|
RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
|
||||||
|
|
||||||
%configure CFLAGS="$RPM_OPT_FLAGS"
|
%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -247,6 +247,13 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_libdir}/libelf.so
|
%{_libdir}/libelf.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
|
||||||
|
- update to 0.118
|
||||||
|
- elflint: more tests.
|
||||||
|
- libdwfl: New function dwfl_module_register_names.
|
||||||
|
- libebl: New backend hook for register names.
|
||||||
|
- Make sure -fexceptions is always in CFLAGS.
|
||||||
|
|
||||||
* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
|
* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
|
||||||
- update to 0.117
|
- update to 0.117
|
||||||
- libdwfl: New function dwfl_module_return_value_location (#166118)
|
- libdwfl: New function dwfl_module_return_value_location (#166118)
|
||||||
|
Loading…
Reference in New Issue
Block a user