New version 0.112
This commit is contained in:
parent
618ac3c0dd
commit
2ca6928443
@ -30,7 +30,7 @@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/configure
|
||||
+++ elfutils/configure
|
||||
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.111'
|
||||
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.112'
|
||||
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
|
||||
|
||||
ac_unique_file="libelf/libelf.h"
|
||||
@ -179,7 +179,10 @@
|
||||
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
|
||||
--- elfutils/libasm/ChangeLog
|
||||
+++ elfutils/libasm/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
@@ -14,6 +14,11 @@
|
||||
* asm_error.c: Add new error ASM_E_IOERROR.
|
||||
* libasmP.h: Add ASM_E_IOERROR definition.
|
||||
|
||||
+2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
|
||||
@ -187,7 +190,7 @@
|
||||
+
|
||||
2005-02-15 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* Makefile (AM_CFLAGS): Add -Wunused -Wextra -Wformat=2.
|
||||
* Makefile.am (AM_CFLAGS): Add -Wunused -Wextra -Wformat=2.
|
||||
--- elfutils/libasm/Makefile.am
|
||||
+++ elfutils/libasm/Makefile.am
|
||||
@@ -13,12 +13,13 @@
|
||||
@ -200,8 +203,8 @@
|
||||
else
|
||||
AM_CFLAGS =
|
||||
endif
|
||||
-AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
|
||||
+AM_CFLAGS += -Wall -Wshadow -Werror -Wunused $(WEXTRA) -Wformat=2
|
||||
-AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
|
||||
+AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused $(WEXTRA) -Wformat=2
|
||||
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
|
||||
-I$(top_srcdir)/lib
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
@ -215,16 +218,15 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -202,10 +203,10 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
@@ -203,9 +204,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -Werror -Wunused -Wextra \
|
||||
+@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -Werror -Wunused $(WEXTRA) \
|
||||
@MUDFLAP_FALSE@ -Wformat=2
|
||||
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -Wall -Wshadow -Werror -Wunused \
|
||||
-@MUDFLAP_TRUE@ -Wextra -Wformat=2
|
||||
+@MUDFLAP_TRUE@ $(WEXTRA) -Wformat=2
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -std=gnu99 -Wall -Wshadow -Werror -Wunused \
|
||||
-@MUDFLAP_FALSE@ -Wextra -Wformat=2
|
||||
+@MUDFLAP_FALSE@ $(WEXTRA) -Wformat=2
|
||||
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -std=gnu99 -Wall -Wshadow -Werror \
|
||||
-@MUDFLAP_TRUE@ -Wunused -Wextra -Wformat=2
|
||||
+@MUDFLAP_TRUE@ -Wunused $(WEXTRA) -Wformat=2
|
||||
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
|
||||
-I$(top_srcdir)/lib
|
||||
|
||||
@ -272,7 +274,7 @@
|
||||
libcpu_i386_a_SOURCES = i386_dis.c
|
||||
--- elfutils/libdw/ChangeLog
|
||||
+++ elfutils/libdw/ChangeLog
|
||||
@@ -60,6 +60,11 @@
|
||||
@@ -65,6 +65,11 @@
|
||||
|
||||
2005-05-31 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -325,7 +327,7 @@
|
||||
@MUDFLAP_FALSE@noinst_LIBRARIES = libdw_pic.a
|
||||
--- elfutils/libdwfl/ChangeLog
|
||||
+++ elfutils/libdwfl/ChangeLog
|
||||
@@ -32,6 +32,11 @@
|
||||
@@ -43,6 +43,11 @@
|
||||
|
||||
2005-07-21 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -339,7 +341,7 @@
|
||||
* test2.c (main): Check sscanf result to quiet warning.
|
||||
--- elfutils/libdwfl/Makefile.am
|
||||
+++ elfutils/libdwfl/Makefile.am
|
||||
@@ -15,12 +15,13 @@
|
||||
@@ -15,16 +15,16 @@
|
||||
## 3001 King Ranch Road, Ukiah, CA 95482.
|
||||
##
|
||||
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
|
||||
@ -354,6 +356,10 @@
|
||||
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw -I.. -I$(srcdir)/../lib
|
||||
VERSION = 1
|
||||
-
|
||||
noinst_LIBRARIES = libdwfl.a
|
||||
if !MUDFLAP
|
||||
noinst_LIBRARIES += libdwfl_pic.a
|
||||
--- elfutils/libdwfl/Makefile.in
|
||||
+++ elfutils/libdwfl/Makefile.in
|
||||
@@ -155,6 +155,7 @@ SHELL = @SHELL@
|
||||
@ -378,7 +384,7 @@
|
||||
|
||||
--- elfutils/libebl/ChangeLog
|
||||
+++ elfutils/libebl/ChangeLog
|
||||
@@ -58,6 +58,11 @@
|
||||
@@ -80,6 +80,11 @@
|
||||
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
|
||||
tracking works right.
|
||||
|
||||
@ -409,7 +415,7 @@
|
||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
|
||||
--- elfutils/libebl/Makefile.in
|
||||
+++ elfutils/libebl/Makefile.in
|
||||
@@ -249,6 +249,7 @@ SHELL = @SHELL@
|
||||
@@ -251,6 +251,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -417,7 +423,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -291,9 +292,9 @@ sharedstatedir = @sharedstatedir@
|
||||
@@ -293,9 +294,9 @@ sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -431,7 +437,7 @@
|
||||
modules = i386 sh x86_64 ia64 alpha arm sparc ppc ppc64
|
||||
--- elfutils/libelf/ChangeLog
|
||||
+++ elfutils/libelf/ChangeLog
|
||||
@@ -18,6 +18,11 @@
|
||||
@@ -33,6 +33,11 @@
|
||||
If section content hasn't been read yet, do it before looking for the
|
||||
block size. If no section data present, infer size of section header.
|
||||
|
||||
@ -482,7 +488,7 @@
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
--- elfutils/libelf/Makefile.in
|
||||
+++ elfutils/libelf/Makefile.in
|
||||
@@ -201,6 +201,7 @@ SHELL = @SHELL@
|
||||
@@ -202,6 +202,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -490,7 +496,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -242,10 +243,10 @@ sbindir = @sbindir@
|
||||
@@ -243,10 +244,10 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@ -525,7 +531,7 @@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
--- elfutils/src/ChangeLog
|
||||
+++ elfutils/src/ChangeLog
|
||||
@@ -52,6 +52,11 @@
|
||||
@@ -87,6 +87,11 @@
|
||||
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
||||
address size.
|
||||
|
||||
@ -574,7 +580,7 @@
|
||||
if MUDFLAP
|
||||
--- elfutils/src/Makefile.in
|
||||
+++ elfutils/src/Makefile.in
|
||||
@@ -200,6 +200,7 @@ SHELL = @SHELL@
|
||||
@@ -207,6 +207,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -582,7 +588,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
YACC = @YACC@ -d
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
@@ -243,10 +244,10 @@ sysconfdir = @sysconfdir@
|
||||
@@ -250,10 +251,10 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
|
||||
@MUDFLAP_FALSE@ $(if $($(*F)_no_Werror),,-Werror) \
|
||||
@ -649,7 +655,7 @@
|
||||
cannot set access and modification date of '%s'"), fname);
|
||||
--- elfutils/tests/ChangeLog
|
||||
+++ elfutils/tests/ChangeLog
|
||||
@@ -16,6 +16,11 @@
|
||||
@@ -32,6 +32,11 @@
|
||||
* Makefile.am (TESTS): Add run-elflint-test.sh.
|
||||
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
%define version 0.111
|
||||
%define release 2
|
||||
%define version 0.112
|
||||
%define release 1
|
||||
|
||||
%define gpl 0
|
||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||
@ -222,6 +222,15 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libelf.so
|
||||
|
||||
%changelog
|
||||
* Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
|
||||
- update to 0.112
|
||||
- elfcmp: some more relaxation.
|
||||
- elflint: many more tests, especially regarding to symbol versioning.
|
||||
- libelf: Add elfXX_offscn and gelf_offscn.
|
||||
- libasm: asm_begin interface changes.
|
||||
- libebl: Add three new interfaces to directly access machine, class,
|
||||
and data encoding information.
|
||||
|
||||
* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
|
||||
- update portability patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user