Import elementary-onboarding-6.1.0-3.el9
This commit is contained in:
commit
c5ecb960e8
1
.elementary-onboarding.metadata
Normal file
1
.elementary-onboarding.metadata
Normal file
@ -0,0 +1 @@
|
||||
80ef2fd8d875d22a3b207d8ae8aafe17dba290ae SOURCES/onboarding-6.1.0.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/onboarding-6.1.0.tar.gz
|
46
SOURCES/155.patch
Normal file
46
SOURCES/155.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From 112da16f3fb64d2616f692e545242899bac107e1 Mon Sep 17 00:00:00 2001
|
||||
From: Christopher Crouse <mail@amz-x.com>
|
||||
Date: Tue, 21 Dec 2021 13:19:15 +0200
|
||||
Subject: [PATCH 1/2] fix custom not show in installer entry
|
||||
|
||||
---
|
||||
data/autostart.desktop | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/data/autostart.desktop b/data/autostart.desktop
|
||||
index 146dbbb6..41f7a7de 100644
|
||||
--- a/data/autostart.desktop
|
||||
+++ b/data/autostart.desktop
|
||||
@@ -3,7 +3,7 @@ Name=Welcome
|
||||
Comment=Change common settings on first-run
|
||||
Exec=io.elementary.onboarding
|
||||
Icon=io.elementary.onboarding
|
||||
-NotShowIn=Installer;
|
||||
+NotShowIn=X-Installer;
|
||||
Terminal=false
|
||||
Type=Application
|
||||
StartupNotify=true
|
||||
|
||||
From f7fa7df527379c81d754c4c3011bcdb0e15b2ba1 Mon Sep 17 00:00:00 2001
|
||||
From: Christopher Crouse <mail@amz-x.com>
|
||||
Date: Mon, 3 Jan 2022 11:08:12 +0200
|
||||
Subject: [PATCH 2/2] updated autostart.desktop to be more generic
|
||||
|
||||
Ref: https://github.com/elementary/onboarding/issues/154#issuecomment-1003128974
|
||||
---
|
||||
data/autostart.desktop | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/data/autostart.desktop b/data/autostart.desktop
|
||||
index 41f7a7de..d59058bb 100644
|
||||
--- a/data/autostart.desktop
|
||||
+++ b/data/autostart.desktop
|
||||
@@ -3,7 +3,7 @@ Name=Welcome
|
||||
Comment=Change common settings on first-run
|
||||
Exec=io.elementary.onboarding
|
||||
Icon=io.elementary.onboarding
|
||||
-NotShowIn=X-Installer;
|
||||
+OnlyShowIn=Pantheon;
|
||||
Terminal=false
|
||||
Type=Application
|
||||
StartupNotify=true
|
100
SPECS/elementary-onboarding.spec
Normal file
100
SPECS/elementary-onboarding.spec
Normal file
@ -0,0 +1,100 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.1)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
%global srcname onboarding
|
||||
%global appname io.elementary.onboarding
|
||||
|
||||
Name: elementary-onboarding
|
||||
Summary: Onboarding app for new users
|
||||
Version: 6.1.0
|
||||
Release: %autorelease
|
||||
License: GPLv3+
|
||||
|
||||
URL: https://github.com/elementary/onboarding
|
||||
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
|
||||
|
||||
# Patch to fix "NotShowIn" in group "Desktop Entry" contains an unregistered value "Installer"
|
||||
# https://github.com/elementary/onboarding/issues/154
|
||||
Patch0: %{url}/pull/155.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libappstream-glib
|
||||
BuildRequires: meson
|
||||
BuildRequires: vala
|
||||
|
||||
BuildRequires: pkgconfig(gee-0.8)
|
||||
BuildRequires: pkgconfig(glib-2.0) >= 2.64.0
|
||||
BuildRequires: pkgconfig(gobject-2.0)
|
||||
BuildRequires: pkgconfig(granite) >= 5.5.0
|
||||
BuildRequires: pkgconfig(gtk+-3.0)
|
||||
BuildRequires: pkgconfig(libhandy-1) >= 0.80.0
|
||||
|
||||
Requires: hicolor-icon-theme
|
||||
|
||||
%description
|
||||
Onboarding application for new users to the Pantheon DE.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -n %{srcname}-%{version} -p1
|
||||
|
||||
|
||||
%build
|
||||
%meson
|
||||
%meson_build
|
||||
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
|
||||
# Remove @2 scaled icons that's not supported by hicolor-icon-theme
|
||||
# - https://bugzilla.redhat.com/show_bug.cgi?id=1537318
|
||||
# - https://gitlab.freedesktop.org/xdg/default-icon-theme/-/issues/2
|
||||
# - https://src.fedoraproject.org/rpms/hicolor-icon-theme/pull-request/2
|
||||
rm -r %{buildroot}/%{_datadir}/icons/hicolor/*@2/
|
||||
|
||||
%find_lang %{appname}
|
||||
|
||||
|
||||
%check
|
||||
desktop-file-validate \
|
||||
%{buildroot}/%{_datadir}/applications/%{appname}.desktop
|
||||
|
||||
desktop-file-validate \
|
||||
%{buildroot}/%{_sysconfdir}/xdg/autostart/%{appname}.desktop
|
||||
|
||||
appstream-util validate-relax --nonet \
|
||||
%{buildroot}/%{_datadir}/metainfo/%{appname}.appdata.xml
|
||||
|
||||
|
||||
%files -f %{appname}.lang
|
||||
%license COPYING
|
||||
%doc README.md
|
||||
|
||||
%config(noreplace) %{_sysconfdir}/xdg/autostart/%{appname}.desktop
|
||||
|
||||
%{_bindir}/%{appname}
|
||||
|
||||
%{_datadir}/applications/%{appname}.desktop
|
||||
%{_datadir}/glib-2.0/schemas/%{appname}.gschema.xml
|
||||
%{_datadir}/metainfo/%{appname}.appdata.xml
|
||||
%{_datadir}/icons/hicolor/*/apps/%{appname}.svg
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Feb 14 2022 Christopher Crouse <mail@amz-x.com> - 6.1.0-1
|
||||
- Initial package import for F36; Fixes #RHBZ2033757
|
Loading…
Reference in New Issue
Block a user