Update to 3.3.8

This commit is contained in:
Sandro Mani 2020-10-05 15:23:42 +02:00
parent d1f802a32a
commit ec5972bb6f
6 changed files with 12 additions and 54 deletions

1
.gitignore vendored
View File

@ -25,3 +25,4 @@
/3.3.6.tar.bz2
/3.3.7.tar.bz2
/eigen-3.3.7.tar.bz2
/eigen-3.3.8.tar.bz2

View File

@ -1,15 +0,0 @@
diff -rupN eigen-eigen-323c052e1731/CMakeLists.txt eigen-eigen-323c052e1731-new/CMakeLists.txt
--- eigen-eigen-323c052e1731/CMakeLists.txt 2018-12-11 18:57:55.000000000 +0100
+++ eigen-eigen-323c052e1731-new/CMakeLists.txt 2018-12-25 23:10:48.527420853 +0100
@@ -424,6 +424,11 @@ install(FILES
DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel
)
+install(FILES
+ cmake/FindEigen3.cmake
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/cmake/Modules
+ )
+
if(EIGEN_BUILD_PKGCONFIG)
configure_file(eigen3.pc.in eigen3.pc @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/eigen3.pc

View File

@ -1,12 +0,0 @@
diff -rupN eigen-eigen-323c052e1731/CMakeLists.txt eigen-eigen-323c052e1731-new/CMakeLists.txt
--- eigen-eigen-323c052e1731/CMakeLists.txt 2018-12-25 23:10:48.592420583 +0100
+++ eigen-eigen-323c052e1731-new/CMakeLists.txt 2018-12-25 23:10:48.659420305 +0100
@@ -531,7 +531,7 @@ set ( EIGEN_VERSION_MAJOR ${EIGEN_WORLD
set ( EIGEN_VERSION_MINOR ${EIGEN_MAJOR_VERSION} )
set ( EIGEN_VERSION_PATCH ${EIGEN_MINOR_VERSION} )
set ( EIGEN_DEFINITIONS "")
-set ( EIGEN_INCLUDE_DIR "${CMAKE_INSTALL_PREFIX}/${INCLUDE_INSTALL_DIR}" )
+set ( EIGEN_INCLUDE_DIR ${INCLUDE_INSTALL_DIR} )
set ( EIGEN_ROOT_DIR ${CMAKE_INSTALL_PREFIX} )
# Interface libraries require at least CMake 3.0

View File

@ -11,23 +11,14 @@
%endif
Name: eigen3
Version: 3.3.7
Release: 7%{?dist}
Version: 3.3.8
Release: 1%{?dist}
Summary: A lightweight C++ template library for vector and matrix math
License: MPLv2.0 and LGPLv2+ and BSD
URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
Source0: https://gitlab.com/libeigen/eigen/-/archive/%{version}/eigen-%{version}.tar.bz2
# Install FindEigen3.cmake
# Adapted from Debian eigen3 package
Patch0: 01_install_FindEigen3.patch
# Fix pkg-config file
Patch1: eigen_pkgconfig.patch
# Fix the include paths in the new Eigen3Config.cmake file
Patch2: eigen3-3.3.1-fixcmake.patch
BuildRequires: %{blaslib}-devel
BuildRequires: fftw-devel
BuildRequires: glew-devel
@ -79,12 +70,12 @@ Developer documentation for Eigen.
%build
%cmake \
-DINCLUDE_INSTALL_DIR=%{_includedir}/eigen3 \
-DINCLUDE_INSTALL_DIR=include/%{name} \
-DBLAS_LIBRARIES="-l%{blaslib}" \
-DSUPERLU_INCLUDES=%{_includedir}/SuperLU \
-DSCOTCH_INCLUDES=%{_includedir} -DSCOTCH_LIBRARIES="scotch" \
-DMETIS_INCLUDES=%{_includedir} -DMETIS_LIBRARIES="metis" \
-DCMAKEPACKAGE_INSTALL_DIR=%{_datadir}/%{name}
-DCMAKEPACKAGE_INSTALL_DIR=share/cmake/%{name}
%cmake_build
%cmake_build --target doc
@ -106,16 +97,18 @@ rm -f %{_vpath_builddir}/doc/html/unsupported/installdox
%files devel
%license COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
%{_includedir}/eigen3
%{_datadir}/%{name}
%{_datadir}/pkgconfig/*
%{_datadir}/cmake/Modules/*.cmake
%{_includedir}/%{name}
%{_datadir}/cmake/%{name}
%{_datadir}/pkgconfig/%{name}.pc
%files doc
%doc %{_vpath_builddir}/doc/html
%changelog
* Mon Oct 05 2020 Sandro Mani <manisandro@gmail.com> - 3.3.8-1
- Update to 3.3.8
* Tue Sep 01 2020 Iñaki Úcar <iucar@fedoraproject.org> - 3.3.7-7
- https://fedoraproject.org/wiki/Changes/FlexiBLAS_as_BLAS/LAPACK_manager

View File

@ -1,9 +0,0 @@
diff -rupN eigen-eigen-323c052e1731/eigen3.pc.in eigen-eigen-323c052e1731-new/eigen3.pc.in
--- eigen-eigen-323c052e1731/eigen3.pc.in 2018-12-11 18:57:55.000000000 +0100
+++ eigen-eigen-323c052e1731-new/eigen3.pc.in 2018-12-25 23:10:48.594420575 +0100
@@ -6,4 +6,4 @@ Description: A C++ template library for
Requires:
Version: @EIGEN_VERSION_NUMBER@
Libs:
-Cflags: -I${prefix}/@INCLUDE_INSTALL_DIR@
+Cflags: -I@INCLUDE_INSTALL_DIR@

View File

@ -1 +1 @@
SHA512 (eigen-3.3.7.tar.bz2) = ea3f1570de3be9ec230d2fbd0f2ae246bf5fd13da79835bf546eb31524796f26f9f633ee779f77942b370a8d540c5cbbd8dd033ccec53a44b692c7e407d6266f
SHA512 (eigen-3.3.8.tar.bz2) = 77fa26322b901fbcff5a956fe48b83b7697efe5e52cd626749c88e5d736a4acaae2832bfdf111d556672cbd4a0677dc80a0dfd2de45ded4f2912f73b47b1ec2d