Upgrade to 3.1.2
This commit is contained in:
parent
db72d23aff
commit
533aa7c5db
@ -1,12 +0,0 @@
|
|||||||
diff -up ./Eigen/src/StlSupport/details.h.ptrdiff ./Eigen/src/StlSupport/details.h
|
|
||||||
--- ./Eigen/src/StlSupport/details.h.ptrdiff 2011-04-17 23:07:20.116801391 -0400
|
|
||||||
+++ ./Eigen/src/StlSupport/details.h 2011-04-17 23:07:49.699857645 -0400
|
|
||||||
@@ -30,6 +30,8 @@
|
|
||||||
#define EIGEN_ALIGNED_ALLOCATOR Eigen::aligned_allocator
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#include <cstddef> // for ptrdiff_t
|
|
||||||
+
|
|
||||||
namespace Eigen {
|
|
||||||
|
|
||||||
// This one is needed to prevent reimplementing the whole std::vector.
|
|
14
eigen3.spec
14
eigen3.spec
@ -1,21 +1,17 @@
|
|||||||
Name: eigen3
|
Name: eigen3
|
||||||
Version: 3.0.6
|
Version: 3.1.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A lightweight C++ template library for vector and matrix math
|
Summary: A lightweight C++ template library for vector and matrix math
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: LGPLv3+ or GPLv2+
|
License: LGPLv3+ or GPLv2+
|
||||||
URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
|
URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
|
||||||
# Source file is at: http://bitbucket.org/eigen/eigen/get/3.0.5.tar.bz2
|
# Source file is at: http://bitbucket.org/eigen/eigen/get/3.1.2.tar.bz2
|
||||||
# Renamed source file so it's not just a version number
|
# Renamed source file so it's not just a version number
|
||||||
Source0: eigen-%{version}.tar.bz2
|
Source0: eigen-%{version}.tar.bz2
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
# Fixes build by adding the cstdef to a source file.
|
|
||||||
# Not yet submitted upstream
|
|
||||||
Patch0: eigen-3.0.0.ptrdiff.patch
|
|
||||||
|
|
||||||
BuildRequires: atlas-devel
|
BuildRequires: atlas-devel
|
||||||
BuildRequires: fftw-devel
|
BuildRequires: fftw-devel
|
||||||
BuildRequires: glew-devel
|
BuildRequires: glew-devel
|
||||||
@ -44,8 +40,7 @@ Provides: %{name}-static = %{version}-%{release}
|
|||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n eigen-eigen-c76e08cca8eb
|
%setup -q -n eigen-eigen-5097c01bcdc4
|
||||||
%patch0 -p0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
mkdir %{_target_platform}
|
mkdir %{_target_platform}
|
||||||
@ -73,6 +68,9 @@ rm -rf %{buildroot}
|
|||||||
%{_datadir}/pkgconfig/*
|
%{_datadir}/pkgconfig/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 01 2012 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
|
||||||
|
- Update to release 3.1.2
|
||||||
|
|
||||||
* Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
|
* Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
|
||||||
- Update to release 3.0.6 (fixes GCC 4.7 warnings)
|
- Update to release 3.0.6 (fixes GCC 4.7 warnings)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user