Apply patch to install FindEigen3.cmake
This commit is contained in:
parent
318fa0c633
commit
4826eba128
20
01_install_FindEigen3.patch
Normal file
20
01_install_FindEigen3.patch
Normal file
@ -0,0 +1,20 @@
|
||||
Description: install FindEigen3.cmake into usr/share/cmake-2.8/Modules
|
||||
Author: Anton Gladky <gladk@debian.org>
|
||||
Last-Update: 2013-11-09
|
||||
|
||||
Index: eigen-eigen-1306d75b4a21/CMakeLists.txt
|
||||
===================================================================
|
||||
--- eigen-eigen-1306d75b4a21.orig/CMakeLists.txt
|
||||
+++ eigen-eigen-1306d75b4a21/CMakeLists.txt
|
||||
@@ -323,6 +323,11 @@ install(FILES
|
||||
DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel
|
||||
)
|
||||
|
||||
+install(FILES
|
||||
+ cmake/FindEigen3.cmake
|
||||
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/cmake/Modules
|
||||
+ )
|
||||
+
|
||||
if(EIGEN_BUILD_PKGCONFIG)
|
||||
SET(path_separator ":")
|
||||
STRING(REPLACE ${path_separator} ";" pkg_config_libdir_search "$ENV{PKG_CONFIG_LIBDIR}")
|
10
eigen3.spec
10
eigen3.spec
@ -8,7 +8,7 @@
|
||||
|
||||
Name: eigen3
|
||||
Version: 3.2.5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: A lightweight C++ template library for vector and matrix math
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -20,6 +20,9 @@ Source0: eigen-%{version}.tar.bz2
|
||||
|
||||
# Fix build with recent suitesparse versions
|
||||
Patch0: eigen-3.2.3_suitesparse.patch
|
||||
# Install FindEigen3.cmake
|
||||
# Adapted from Debian eigen3 package
|
||||
Patch1: 01_install_FindEigen3.patch
|
||||
|
||||
BuildRequires: atlas-devel
|
||||
BuildRequires: fftw-devel
|
||||
@ -62,6 +65,7 @@ Developer documentation for Eigen.
|
||||
%prep
|
||||
%setup -q -n eigen-eigen-%{commit}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
mkdir %{_target_platform}
|
||||
@ -92,11 +96,15 @@ make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
|
||||
%license COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
|
||||
%{_includedir}/eigen3
|
||||
%{_datadir}/pkgconfig/*
|
||||
%{_datadir}/cmake/Modules/*.cmake
|
||||
|
||||
%files doc
|
||||
%doc %{_target_platform}/doc/html
|
||||
|
||||
%changelog
|
||||
* Fri Aug 21 2015 Rich Mattes <richmattes@gmail.com> - 3.2.5-2
|
||||
- Apply patch to install FindEigen3.cmake
|
||||
|
||||
* Tue Jun 16 2015 Sandro Mani <manisandro@gmail.com> - 3.2.5-1
|
||||
- Update to release 3.2.5
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user