Update to 3.2.4
This commit is contained in:
parent
671ad21410
commit
2bd9b730d4
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
||||
/eigen-3.2.1.tar.bz2
|
||||
/eigen-3.2.2.tar.bz2
|
||||
/eigen-3.2.3.tar.bz2
|
||||
/eigen-3.2.4.tar.bz2
|
||||
|
@ -1,20 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Gael Guennebaud <g.gael@free.fr>
|
||||
# Date 1418910820 -3600
|
||||
# Branch 3.2
|
||||
# Node ID 5d9e54445535570698f7465582c7256d9d74c004
|
||||
# Parent 9716ca6de21838927484f3c33050648bac890ac3
|
||||
rm explicit keyword introduced by backporting another change
|
||||
|
||||
diff --git a/Eigen/src/Geometry/Rotation2D.h b/Eigen/src/Geometry/Rotation2D.h
|
||||
--- a/Eigen/src/Geometry/Rotation2D.h
|
||||
+++ b/Eigen/src/Geometry/Rotation2D.h
|
||||
@@ -59,7 +59,7 @@
|
||||
public:
|
||||
|
||||
/** Construct a 2D counter clock wise rotation from the angle \a a in radian. */
|
||||
- explicit inline Rotation2D(const Scalar& a) : m_angle(a) {}
|
||||
+ inline Rotation2D(const Scalar& a) : m_angle(a) {}
|
||||
|
||||
/** Default constructor wihtout initialization. The represented rotation is undefined. */
|
||||
Rotation2D() {}
|
12
eigen3.spec
12
eigen3.spec
@ -4,11 +4,11 @@
|
||||
# debuginfo package for the empty main package.
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global commit 36fd1ba04c12
|
||||
%global commit 10219c95fe65
|
||||
|
||||
Name: eigen3
|
||||
Version: 3.2.3
|
||||
Release: 2%{?dist}
|
||||
Version: 3.2.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A lightweight C++ template library for vector and matrix math
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -20,8 +20,6 @@ Source0: eigen-%{version}.tar.bz2
|
||||
|
||||
# Fix build with recent suitesparse versions
|
||||
Patch0: eigen-3.2.3_suitesparse.patch
|
||||
# Backport of upstream regression fix in Rotation2D.
|
||||
Patch1: eigen3-5d9e44.patch
|
||||
|
||||
BuildRequires: atlas-devel
|
||||
BuildRequires: fftw-devel
|
||||
@ -64,7 +62,6 @@ Developer documentation for Eigen.
|
||||
%prep
|
||||
%setup -q -n eigen-eigen-%{commit}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
mkdir %{_target_platform}
|
||||
@ -100,6 +97,9 @@ make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
|
||||
%doc %{_target_platform}/doc/html
|
||||
|
||||
%changelog
|
||||
* Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
|
||||
- Update to release 3.2.4
|
||||
|
||||
* Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
|
||||
- Backport upstream Rotation2D fix
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user