Update to 3.2.3
This commit is contained in:
parent
3324306d09
commit
18c5916d01
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/eigen-3.2.tar.bz2
|
||||
/eigen-3.2.1.tar.bz2
|
||||
/eigen-3.2.2.tar.bz2
|
||||
/eigen-3.2.3.tar.bz2
|
||||
|
33
eigen-3.2.3_suitesparse.patch
Normal file
33
eigen-3.2.3_suitesparse.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -rupN eigen-eigen-36fd1ba04c12/Eigen/src/CholmodSupport/CholmodSupport.h eigen-eigen-36fd1ba04c12-new/Eigen/src/CholmodSupport/CholmodSupport.h
|
||||
--- eigen-eigen-36fd1ba04c12/Eigen/src/CholmodSupport/CholmodSupport.h 2014-12-16 18:30:52.000000000 +0100
|
||||
+++ eigen-eigen-36fd1ba04c12-new/Eigen/src/CholmodSupport/CholmodSupport.h 2014-12-17 23:35:28.080925651 +0100
|
||||
@@ -78,7 +78,7 @@ cholmod_sparse viewAsCholmod(SparseMatri
|
||||
{
|
||||
res.itype = CHOLMOD_INT;
|
||||
}
|
||||
- else if (internal::is_same<_Index,UF_long>::value)
|
||||
+ else if (internal::is_same<_Index,SuiteSparse_long>::value)
|
||||
{
|
||||
res.itype = CHOLMOD_LONG;
|
||||
}
|
||||
diff -rupN eigen-eigen-36fd1ba04c12/Eigen/src/SPQRSupport/SuiteSparseQRSupport.h eigen-eigen-36fd1ba04c12-new/Eigen/src/SPQRSupport/SuiteSparseQRSupport.h
|
||||
--- eigen-eigen-36fd1ba04c12/Eigen/src/SPQRSupport/SuiteSparseQRSupport.h 2014-12-16 18:30:52.000000000 +0100
|
||||
+++ eigen-eigen-36fd1ba04c12-new/Eigen/src/SPQRSupport/SuiteSparseQRSupport.h 2014-12-17 23:35:28.063925342 +0100
|
||||
@@ -47,7 +47,7 @@ namespace Eigen {
|
||||
* You can then apply it to a vector.
|
||||
*
|
||||
* R is the sparse triangular factor. Use matrixQR() to get it as SparseMatrix.
|
||||
- * NOTE : The Index type of R is always UF_long. You can get it with SPQR::Index
|
||||
+ * NOTE : The Index type of R is always SuiteSparse_long. You can get it with SPQR::Index
|
||||
*
|
||||
* \tparam _MatrixType The type of the sparse matrix A, must be a column-major SparseMatrix<>
|
||||
* NOTE
|
||||
@@ -59,7 +59,7 @@ class SPQR
|
||||
public:
|
||||
typedef typename _MatrixType::Scalar Scalar;
|
||||
typedef typename _MatrixType::RealScalar RealScalar;
|
||||
- typedef UF_long Index ;
|
||||
+ typedef SuiteSparse_long Index ;
|
||||
typedef SparseMatrix<Scalar, ColMajor, Index> MatrixType;
|
||||
typedef PermutationMatrix<Dynamic, Dynamic> PermutationType;
|
||||
public:
|
@ -1,12 +0,0 @@
|
||||
diff -up eigen-eigen-ffa86ffb5570/unsupported/test/mpreal/mpreal.h.ppc64 eigen-eigen-ffa86ffb5570/unsupported/test/mpreal/mpreal.h
|
||||
--- eigen-eigen-ffa86ffb5570/unsupported/test/mpreal/mpreal.h.ppc64 2013-07-23 19:48:35.000000000 -0600
|
||||
+++ eigen-eigen-ffa86ffb5570/unsupported/test/mpreal/mpreal.h 2014-02-13 10:18:48.290136534 -0700
|
||||
@@ -97,7 +97,7 @@
|
||||
#endif
|
||||
|
||||
#elif defined (__GNUC__) && defined(__linux__)
|
||||
- #if defined(__amd64__) || defined(__amd64) || defined(__x86_64__) || defined(__x86_64) || defined(__ia64) || defined(__itanium__) || defined(_M_IA64)
|
||||
+ #if defined(__amd64__) || defined(__amd64) || defined(__x86_64__) || defined(__x86_64) || defined(__ia64) || defined(__itanium__) || defined(_M_IA64) || defined (__PPC64__)
|
||||
#undef MPREAL_HAVE_INT64_SUPPORT // Remove all shaman dances for x64 builds since
|
||||
#undef MPFR_USE_INTMAX_T // GCC already supports x64 as of "long int" is 64-bit integer, nothing left to do
|
||||
#else
|
17
eigen3.spec
17
eigen3.spec
@ -4,11 +4,11 @@
|
||||
# debuginfo package for the empty main package.
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global commit 1306d75b4a21
|
||||
%global commit 36fd1ba04c12
|
||||
|
||||
Name: eigen3
|
||||
Version: 3.2.2
|
||||
Release: 2%{?dist}
|
||||
Version: 3.2.3
|
||||
Release: 1%{?dist}
|
||||
Summary: A lightweight C++ template library for vector and matrix math
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -17,8 +17,9 @@ URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
|
||||
# Source file is at: http://bitbucket.org/eigen/eigen/get/3.1.3.tar.bz2
|
||||
# Renamed source file so it's not just a version number
|
||||
Source0: eigen-%{version}.tar.bz2
|
||||
# Add ppc64 support
|
||||
Patch0: eigen3-ppc64.patch
|
||||
|
||||
# Fix build with recent suitesparse versions
|
||||
Patch0: eigen-3.2.3_suitesparse.patch
|
||||
|
||||
BuildRequires: atlas-devel
|
||||
BuildRequires: fftw-devel
|
||||
@ -60,7 +61,7 @@ Developer documentation for Eigen.
|
||||
|
||||
%prep
|
||||
%setup -q -n eigen-eigen-%{commit}
|
||||
%patch0 -p1 -b .ppc64
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
mkdir %{_target_platform}
|
||||
@ -96,6 +97,10 @@ make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
|
||||
%doc %{_target_platform}/doc/html
|
||||
|
||||
%changelog
|
||||
* Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
|
||||
- Update to release 3.2.3
|
||||
- Drop upstreamed eigen3-ppc64.patch
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user