Update to 3.4.0
This commit is contained in:
parent
ee3cce0f1d
commit
0fff5afa78
1
.gitignore
vendored
1
.gitignore
vendored
@ -27,3 +27,4 @@
|
||||
/eigen-3.3.7.tar.bz2
|
||||
/eigen-3.3.8.tar.bz2
|
||||
/eigen-3.3.9.tar.bz2
|
||||
/eigen-3.4.0.tar.bz2
|
||||
|
30
eigen3.spec
30
eigen3.spec
@ -19,25 +19,15 @@
|
||||
%global cmake_blas_flags -DBLAS_LIBRARIES=%{_libdir}/lib%{blaslib}%{blasvar}.so
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel} >= 8
|
||||
%bcond_with qt
|
||||
%else
|
||||
%bcond_without qt
|
||||
%endif
|
||||
|
||||
Name: eigen3
|
||||
Version: 3.3.9
|
||||
Release: 7%{?dist}
|
||||
Version: 3.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A lightweight C++ template library for vector and matrix math
|
||||
|
||||
License: MPLv2.0 and LGPLv2+ and BSD and Minpack
|
||||
URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
|
||||
Source0: https://gitlab.com/libeigen/eigen/-/archive/%{version}/eigen-%{version}.tar.bz2
|
||||
|
||||
# Backport fix for conflicting declarations of log1p
|
||||
# https://gitlab.com/libeigen/eigen/-/commit/d55d392e7b1136655b4223bea8e99cb2fe0a8afd.patch
|
||||
Patch0: eigen3_logp.patch
|
||||
|
||||
BuildRequires: %{blaslib}-devel
|
||||
BuildRequires: fftw-devel
|
||||
BuildRequires: glew-devel
|
||||
@ -48,9 +38,6 @@ BuildRequires: sparsehash-devel
|
||||
BuildRequires: suitesparse-devel
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: SuperLU-devel
|
||||
%if %{with qt}
|
||||
BuildRequires: qt-devel
|
||||
%endif
|
||||
BuildRequires: scotch-devel
|
||||
BuildRequires: metis-devel
|
||||
|
||||
@ -91,12 +78,13 @@ Developer documentation for Eigen.
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
-DINCLUDE_INSTALL_DIR=include/%{name} \
|
||||
-DINCLUDE_INSTALL_DIR=%{_includedir}/%{name} \
|
||||
-DCMAKEPACKAGE_INSTALL_DIR=%{_datadir}/cmake/%{name} \
|
||||
%{cmake_blas_flags} \
|
||||
-DSUPERLU_INCLUDES=%{_includedir}/SuperLU \
|
||||
-DSCOTCH_INCLUDES=%{_includedir} -DSCOTCH_LIBRARIES="scotch" \
|
||||
-DMETIS_INCLUDES=%{_includedir} -DMETIS_LIBRARIES="metis" \
|
||||
-DCMAKEPACKAGE_INSTALL_DIR=share/cmake/%{name}
|
||||
-DEIGEN_TEST_CXX11=ON
|
||||
|
||||
%cmake_build
|
||||
%cmake_build --target doc
|
||||
@ -110,10 +98,9 @@ rm -f %{_vpath_builddir}/doc/html/unsupported/installdox
|
||||
|
||||
|
||||
%check
|
||||
# Run tests but make failures non-fatal. Note that upstream doesn't expect the
|
||||
# tests to pass consistently since they're seeded randomly.
|
||||
# Test fail to build due to compiler crashes
|
||||
#cmake_build --target buildtests
|
||||
#cmake_build --target test -- test ARGS="-V" || :
|
||||
#ctest
|
||||
|
||||
|
||||
%files devel
|
||||
@ -127,6 +114,9 @@ rm -f %{_vpath_builddir}/doc/html/unsupported/installdox
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 19 2021 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
|
||||
- Update to 3.4.0
|
||||
|
||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.9-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -rupN --no-dereference eigen-3.3.9/Eigen/src/Core/MathFunctions.h eigen-3.3.9-new/Eigen/src/Core/MathFunctions.h
|
||||
--- eigen-3.3.9/Eigen/src/Core/MathFunctions.h 2020-12-04 22:53:41.000000000 +0100
|
||||
+++ eigen-3.3.9-new/Eigen/src/Core/MathFunctions.h 2021-01-19 12:32:05.328624222 +0100
|
||||
@@ -485,12 +485,22 @@ struct log1p_impl {
|
||||
EIGEN_STATIC_ASSERT_NON_INTEGER(Scalar)
|
||||
#if EIGEN_HAS_CXX11_MATH
|
||||
using std::log1p;
|
||||
- #endif
|
||||
+ #else
|
||||
using std_fallback::log1p;
|
||||
+ #endif
|
||||
return log1p(x);
|
||||
}
|
||||
};
|
||||
|
||||
+// Specialization for complex types that are not supported by std::log1p.
|
||||
+template <typename RealScalar>
|
||||
+struct log1p_impl<std::complex<RealScalar> > {
|
||||
+ EIGEN_DEVICE_FUNC static inline std::complex<RealScalar> run(
|
||||
+ const std::complex<RealScalar>& x) {
|
||||
+ EIGEN_STATIC_ASSERT_NON_INTEGER(RealScalar)
|
||||
+ return std_fallback::log1p(x);
|
||||
+ }
|
||||
+};
|
||||
|
||||
template<typename Scalar>
|
||||
struct log1p_retval
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (eigen-3.3.9.tar.bz2) = 6f222e27480d02d90f258c94a4a4787771491fc30c73d5fb025a8089484fdeb2c65d464172f5c29d0c3096b69ff98027a18a40c04b006da670733a2c75f55b65
|
||||
SHA512 (eigen-3.4.0.tar.bz2) = cc488eb111e0e248744d2bc4475b345b5fb82361dff226a5b73a33bd0388de8c219cff8cffcf8f476b672fc0e223f339e8c6a1cfb6293840a4a6abf232438a89
|
||||
|
Loading…
Reference in New Issue
Block a user