Fix the crappy warning epel7 generates

This commit is contained in:
Leigh Scott 2018-12-06 12:01:56 +00:00
parent 942f43a5d7
commit 0d026e868e
2 changed files with 19 additions and 2 deletions

View File

@ -1,12 +1,15 @@
Name: egl-wayland Name: egl-wayland
Version: 1.1.1 Version: 1.1.1
Release: 1%{?dist} Release: 2%{?dist}
Summary: Wayland EGL External Platform library Summary: Wayland EGL External Platform library
License: MIT License: MIT
URL: https://github.com/NVIDIA/%{name} URL: https://github.com/NVIDIA/%{name}
Source0: %url/archive/%{version}/%{name}-%{version}.tar.gz Source0: %url/archive/%{version}/%{name}-%{version}.tar.gz
Source1: 10_nvidia_wayland.json Source1: 10_nvidia_wayland.json
%if 0%{?rhel}
Patch0: fix_deprecated-declarations.patch
%endif
BuildRequires: meson BuildRequires: meson
BuildRequires: libtool BuildRequires: libtool
@ -28,7 +31,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
Wayland EGL External Platform library development package Wayland EGL External Platform library development package
%prep %prep
%autosetup -n %{name}-%{version} %autosetup -p1 -n %{name}-%{version}
%build %build
%meson %meson
@ -58,6 +61,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
%{_datadir}/wayland-eglstream/ %{_datadir}/wayland-eglstream/
%changelog %changelog
* Thu Dec 06 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.1-2
- Fix the crappy warning epel7 generates
* Thu Dec 06 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.1-1 * Thu Dec 06 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.1-1
- Update to 1.1.1 - Update to 1.1.1

View File

@ -0,0 +1,11 @@
--- a/src/meson.build
+++ b/src/meson.build
@@ -6,6 +6,7 @@
add_project_arguments('-Wall', language : 'c')
add_project_arguments('-Werror', language : 'c')
+add_project_arguments('-Wno-deprecated-declarations', language : 'c')
add_project_arguments('-fvisibility=hidden', language : 'c')
add_project_link_arguments('-Wl,-Bsymbolic', language : 'c')