Update to efivar-39
Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
eaa67b49f0
commit
c402763eef
@ -1,35 +0,0 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Wei Fu <wefu@redhat.com>
|
||||
Date: Sat, 2 Apr 2022 22:53:36 +0800
|
||||
Subject: [PATCH] Fix the -march issue for riscv64
|
||||
|
||||
There is an issue on riscv64 system when compiling it natively:
|
||||
gcc: error: '-march=native': ISA string must begin with rv32 or rv64
|
||||
|
||||
This patch set HOST_MARCH= like ia64 to resolve the issue.
|
||||
|
||||
Signed-off-by: Wei Fu <wefu@redhat.com>
|
||||
(cherry picked from commit aab4e9b10ac9e98588a1b19771cf6f4c8c0a3096)
|
||||
---
|
||||
src/include/defaults.mk | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/include/defaults.mk b/src/include/defaults.mk
|
||||
index 632b155..b8cc590 100644
|
||||
--- a/src/include/defaults.mk
|
||||
+++ b/src/include/defaults.mk
|
||||
@@ -73,10 +73,14 @@ override SOFLAGS = $(_SOFLAGS) \
|
||||
|
||||
HOST_ARCH=$(shell uname -m)
|
||||
ifneq ($(HOST_ARCH),ia64)
|
||||
+ifneq ($(HOST_ARCH),riscv64)
|
||||
HOST_MARCH=-march=native
|
||||
else
|
||||
HOST_MARCH=
|
||||
endif
|
||||
+else
|
||||
+ HOST_MARCH=
|
||||
+endif
|
||||
HOST_CPPFLAGS ?= $(CPPFLAGS)
|
||||
override _HOST_CPPFLAGS := $(HOST_CPPFLAGS)
|
||||
override HOST_CPPFLAGS = $(_HOST_CPPFLAGS) \
|
@ -1,56 +0,0 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Robbie Harwood <rharwood@redhat.com>
|
||||
Date: Thu, 28 Jul 2022 16:11:24 -0400
|
||||
Subject: [PATCH] Fix glibc 2.36 build (mount.h conflicts)
|
||||
|
||||
glibc has decided that sys/mount.h and linux/mount.h are no longer
|
||||
usable at the same time. This broke the build, since linux/fs.h itself
|
||||
includes linux/mount.h. For now, fix the build by only including
|
||||
sys/mount.h where we need it.
|
||||
|
||||
See-also: https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
|
||||
Resolves: #227
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
(cherry picked from commit bc65d63ebf8fe6ac8a099ff15ca200986dba1565)
|
||||
---
|
||||
src/gpt.c | 1 +
|
||||
src/linux.c | 1 +
|
||||
src/util.h | 1 -
|
||||
3 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gpt.c b/src/gpt.c
|
||||
index 1eda049..21413c3 100644
|
||||
--- a/src/gpt.c
|
||||
+++ b/src/gpt.c
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <sys/mount.h>
|
||||
#include <sys/param.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/utsname.h>
|
||||
diff --git a/src/linux.c b/src/linux.c
|
||||
index 47e45ae..1780816 100644
|
||||
--- a/src/linux.c
|
||||
+++ b/src/linux.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <stdbool.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/ioctl.h>
|
||||
+#include <sys/mount.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/sysmacros.h>
|
||||
#include <sys/types.h>
|
||||
diff --git a/src/util.h b/src/util.h
|
||||
index 3300666..1e67e44 100644
|
||||
--- a/src/util.h
|
||||
+++ b/src/util.h
|
||||
@@ -23,7 +23,6 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#include <sys/mount.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/types.h>
|
||||
#include <tgmath.h>
|
@ -1,2 +0,0 @@
|
||||
Patch0001: 0001-Fix-the-march-issue-for-riscv64.patch
|
||||
Patch0002: 0002-Fix-glibc-2.36-build-mount.h-conflicts.patch
|
@ -1,6 +1,6 @@
|
||||
Name: efivar
|
||||
Version: 38
|
||||
Release: 10%{?dist}
|
||||
Version: 39
|
||||
Release: 1%{?dist}
|
||||
Summary: Tools to manage UEFI variables
|
||||
License: LGPL-2.1-only
|
||||
URL: https://github.com/rhboot/efivar
|
||||
@ -83,6 +83,9 @@ make abicheck CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 31 2024 Peter Jones <pjones@redhat.com> - 39-1
|
||||
- Update to efivar-39
|
||||
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org>
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
SHA512 (efivar-37.tar.bz2) = 305a82ed103c7e3d8f723934019d552677c73558768dd5341f87d0364f5c60824d24f5a8e1bf90075e825908085083d4ecdccec5ac757fd38ee6ac8fea28c3e4
|
||||
SHA512 (efivar-38.tar.bz2) = c2f17297c863ece134a9dd758d237fd2df8c8d072f87af1d0bf2bcf9acfc7a53c25597f03fd4fb8cc664b205743d4ffa0ef1b068d0f73c58fa573d40993f3155
|
||||
SHA512 (efivar-39.tar.bz2) = 44386be3a2cf0ee0868a7b1d774fd4a6649a859b50cda4a138fbf2037f8d953ab7b9f7857a44b8c3d9e12895c2a3371a37cc9d09d46e30702d634709e1d10aba
|
||||
|
Loading…
Reference in New Issue
Block a user