import RHEL 10 Beta efi-rpm-macros-6-3.el10
This commit is contained in:
parent
c520f8da05
commit
13e36968d0
@ -1 +0,0 @@
|
|||||||
d8c779df5999416a0376754b7a8712d990aea547 SOURCES/efi-rpm-macros-3.tar.bz2
|
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/efi-rpm-macros-3.tar.bz2
|
efi-rpm-macros-6.tar.bz2
|
||||||
|
@ -1,74 +0,0 @@
|
|||||||
From 29e47cd8011b1569c4a73c8e395c7fb5192e6dc1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Jones <pjones@redhat.com>
|
|
||||||
Date: Fri, 4 May 2018 15:02:14 -0400
|
|
||||||
Subject: [PATCH] macros.efi-srpm: make all of our macros always expandable,
|
|
||||||
even if wrong
|
|
||||||
|
|
||||||
In particular, arch and altarch give "none", and when they do efi_has_arch
|
|
||||||
and efi_has_alt_arch are 0 (respectively). if they're correct, they'll
|
|
||||||
be 1.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
||||||
---
|
|
||||||
macros.efi-srpm.in | 17 ++++++++++++-----
|
|
||||||
1 file changed, 12 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/macros.efi-srpm.in b/macros.efi-srpm.in
|
|
||||||
index 5f8a784af8a..f3b4c68b2f9 100644
|
|
||||||
--- a/macros.efi-srpm.in
|
|
||||||
+++ b/macros.efi-srpm.in
|
|
||||||
@@ -38,7 +38,7 @@
|
|
||||||
elseif arch("%{arm}") then
|
|
||||||
return("arm")
|
|
||||||
else
|
|
||||||
- return("")
|
|
||||||
+ return("none")
|
|
||||||
end
|
|
||||||
end
|
|
||||||
-- alt arch
|
|
||||||
@@ -46,24 +46,30 @@
|
|
||||||
if arch("x86_64") then
|
|
||||||
return("ia32")
|
|
||||||
else
|
|
||||||
- return(nil)
|
|
||||||
+ return("none")
|
|
||||||
end
|
|
||||||
end
|
|
||||||
-- make some macros
|
|
||||||
local done = rpm.expand("%{?_efi}")
|
|
||||||
if done == nil or done == "" then
|
|
||||||
+ local arch = getarch()
|
|
||||||
local alt = getaltarch()
|
|
||||||
print("%global _efi @@EFI_ARCHES@@\\n")
|
|
||||||
print("%global _efi_vendor @@EFI_VENDOR@@\\n")
|
|
||||||
+ if arch == "none" then
|
|
||||||
+ print("%global _efi_has_arch 0\\n")
|
|
||||||
+ else
|
|
||||||
+ print("%global _efi_has_arch 1\\n")
|
|
||||||
+ end
|
|
||||||
print("%global _efi_arch " .. getarch() .. "\\n")
|
|
||||||
print("%global _efi_arch_upper " .. string.upper(getarch()) .. "\\n")
|
|
||||||
- if alt == nil then
|
|
||||||
+ if alt == "none" then
|
|
||||||
print("%global _efi_has_alt_arch 0\\n")
|
|
||||||
else
|
|
||||||
print("%global _efi_has_alt_arch 1\\n")
|
|
||||||
- print("%global _efi_alt_arch " .. alt .. "\\n")
|
|
||||||
- print("%global _efi_alt_arch_upper " .. string.upper(alt) .. "\\n")
|
|
||||||
end
|
|
||||||
+ print("%global _efi_alt_arch " .. alt .. "\\n")
|
|
||||||
+ print("%global _efi_alt_arch_upper " .. string.upper(alt) .. "\\n")
|
|
||||||
end
|
|
||||||
}}
|
|
||||||
|
|
||||||
@@ -79,6 +85,7 @@
|
|
||||||
|
|
||||||
%efi_arch %{expand:%{_efi_srpm_macros_setup}}%{_efi_arch}
|
|
||||||
%efi_arch_upper %{expand:%{_efi_srpm_macros_setup}}%{_efi_arch_upper}
|
|
||||||
+%efi_has_arch %{expand:%{_efi_srpm_macros_setup}}0%{_efi_has_arch}
|
|
||||||
%efi_has_alt_arch %{expand:%{_efi_srpm_macros_setup}}0%{_efi_has_alt_arch}
|
|
||||||
%efi_alt_arch %{expand:%{_efi_srpm_macros_setup}}%{?_efi_alt_arch}%{nil}
|
|
||||||
%efi_alt_arch_upper %{expand:%{_efi_srpm_macros_setup}}%{?_efi_alt_arch_upper}%{nil}
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
@ -1,102 +0,0 @@
|
|||||||
Summary: Common RPM Macros for building EFI-related packages
|
|
||||||
Name: efi-rpm-macros
|
|
||||||
Version: 3
|
|
||||||
Release: 3%{?dist}
|
|
||||||
Group: Development/System
|
|
||||||
License: GPLv3+
|
|
||||||
URL: https://github.com/rhboot/%{name}/
|
|
||||||
BuildRequires: git sed
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
Source0: https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
|
|
||||||
Patch0001: 0001-macros.efi-srpm-make-all-of-our-macros-always-expand.patch
|
|
||||||
|
|
||||||
%global debug_package %{nil}
|
|
||||||
%global _efi_vendor_ %(eval echo $(sed -n -e 's/rhel/redhat/' -e 's/^ID=//p' /etc/os-release))
|
|
||||||
|
|
||||||
%description
|
|
||||||
%{name} provides a set of RPM macros for use in EFI-related packages.
|
|
||||||
|
|
||||||
%package -n efi-srpm-macros
|
|
||||||
Summary: Common SRPM Macros for building EFI-related packages
|
|
||||||
Group: Development/System
|
|
||||||
BuildArch: noarch
|
|
||||||
Requires: rpm
|
|
||||||
|
|
||||||
%description -n efi-srpm-macros
|
|
||||||
efi-srpm-macros provides a set of SRPM macros for use in EFI-related packages.
|
|
||||||
|
|
||||||
%package -n efi-filesystem
|
|
||||||
Summary: The basic directory layout for EFI machines
|
|
||||||
Group: System Environment/Base
|
|
||||||
BuildArch: noarch
|
|
||||||
Requires: filesystem
|
|
||||||
|
|
||||||
%description -n efi-filesystem
|
|
||||||
The efi-filesystem package contains the basic directory layout for EFI
|
|
||||||
machine bootloaders and tools.
|
|
||||||
|
|
||||||
%prep
|
|
||||||
%autosetup -S git
|
|
||||||
|
|
||||||
%build
|
|
||||||
%make_build EFI_VENDOR=%{_efi_vendor_} clean all
|
|
||||||
|
|
||||||
%install
|
|
||||||
%make_install EFI_VENDOR=%{_efi_vendor_}
|
|
||||||
|
|
||||||
#%%files
|
|
||||||
#%%{!?_licensedir:%%global license %%%%doc}
|
|
||||||
#%%license LICENSE
|
|
||||||
#%%doc README
|
|
||||||
#%%{_rpmmacrodir}/macros.efi
|
|
||||||
|
|
||||||
%files -n efi-srpm-macros
|
|
||||||
%{!?_licensedir:%global license %%doc}
|
|
||||||
%license LICENSE
|
|
||||||
%doc README
|
|
||||||
%{_rpmmacrodir}/macros.efi-srpm
|
|
||||||
|
|
||||||
%files -n efi-filesystem
|
|
||||||
%defattr(0700,root,root,-)
|
|
||||||
%verify(not mode) %dir /boot/efi
|
|
||||||
%verify(not mode) %dir /boot/efi/EFI
|
|
||||||
%verify(not mode) %dir /boot/efi/EFI/BOOT
|
|
||||||
%verify(not mode) %dir /boot/efi/EFI/%{_efi_vendor_}
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
* Thu Nov 05 2020 Javier Martinez Canillas <javierm@redhat.com> - 3-3
|
|
||||||
- Ignore the mode bits when doing RPM verification of files in /boot/efi
|
|
||||||
Resolves: rhbz#1845052
|
|
||||||
|
|
||||||
* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-2
|
|
||||||
- Always provide macros for efi_arch and efi_alt_arch (and their _upper
|
|
||||||
variants), and make efi_has_arch and efi_has_alt_arch 0 when they will be
|
|
||||||
wrong. This ensures everything can always expand when we're on a non-efi
|
|
||||||
architecture.
|
|
||||||
|
|
||||||
* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-1
|
|
||||||
- Update to version 3 to try and un-break rawhide composes due to
|
|
||||||
ExclusiveArch constraints.
|
|
||||||
|
|
||||||
* Thu May 03 2018 Peter Jones <pjones@redhat.com> - 2-6
|
|
||||||
- Rework the macros for better srpm use.
|
|
||||||
|
|
||||||
* Wed May 02 2018 Peter Jones <pjones@redhat.com> - 2-5
|
|
||||||
- Add efi-filesystem subpackage
|
|
||||||
|
|
||||||
* Wed May 02 2018 Peter Jones <pjones@redhat.com> - 2-4
|
|
||||||
- Add %%{efi_has_alt_arch}
|
|
||||||
|
|
||||||
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-3
|
|
||||||
- Make an efi-srpm-macros subpackage to pull in so %%{efi} works in
|
|
||||||
ExclusiveArch in koji.
|
|
||||||
|
|
||||||
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-2
|
|
||||||
- Fix the non-efi and non-efi-alt-arch cases, hopefully.
|
|
||||||
|
|
||||||
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-1
|
|
||||||
- Lots of rpmlint fixups and the like.
|
|
||||||
|
|
||||||
* Mon Apr 30 2018 Peter Jones <pjones@redhat.com> - 1-1
|
|
||||||
- First shot at building it.
|
|
167
efi-rpm-macros.spec
Normal file
167
efi-rpm-macros.spec
Normal file
@ -0,0 +1,167 @@
|
|||||||
|
Summary: Common RPM Macros for building EFI-related packages
|
||||||
|
Name: efi-rpm-macros
|
||||||
|
Version: 6
|
||||||
|
Release: 3%{?dist}
|
||||||
|
License: GPL-3.0-or-later
|
||||||
|
URL: https://github.com/rhboot/%{name}/
|
||||||
|
BuildRequires: git sed
|
||||||
|
BuildRequires: make
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
Source0: https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-6.tar.bz2
|
||||||
|
|
||||||
|
%global debug_package %{nil}
|
||||||
|
%global _efi_vendor_ %(eval echo $(sed -n -e 's/rhel/redhat/' -e 's/^ID=//p' /etc/os-release))
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{name} provides a set of RPM macros for use in EFI-related packages.
|
||||||
|
|
||||||
|
%package -n efi-srpm-macros
|
||||||
|
Summary: Common SRPM Macros for building EFI-related packages
|
||||||
|
BuildArch: noarch
|
||||||
|
Requires: rpm
|
||||||
|
|
||||||
|
%description -n efi-srpm-macros
|
||||||
|
efi-srpm-macros provides a set of SRPM macros for use in EFI-related packages.
|
||||||
|
|
||||||
|
%package -n efi-filesystem
|
||||||
|
Summary: The basic directory layout for EFI machines
|
||||||
|
BuildArch: noarch
|
||||||
|
Requires: filesystem
|
||||||
|
|
||||||
|
%description -n efi-filesystem
|
||||||
|
The efi-filesystem package contains the basic directory layout for EFI
|
||||||
|
machine bootloaders and tools.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -S git_am -n %{name}-6
|
||||||
|
git config --local --add efi.vendor "%{_efi_vendor_}"
|
||||||
|
git config --local --add efi.esp-root /boot/efi
|
||||||
|
git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86}"
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make_build clean all
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
|
||||||
|
#%%files
|
||||||
|
#%%{!?_licensedir:%%global license %%%%doc}
|
||||||
|
#%%license LICENSE
|
||||||
|
#%%doc README
|
||||||
|
#%%{_rpmmacrodir}/macros.efi
|
||||||
|
|
||||||
|
%files -n efi-srpm-macros
|
||||||
|
%{!?_licensedir:%global license %%doc}
|
||||||
|
%license LICENSE
|
||||||
|
%doc README
|
||||||
|
%{_rpmmacrodir}/macros.efi-srpm
|
||||||
|
%{_rpmconfigdir}/brp-boot-efi-times
|
||||||
|
|
||||||
|
%files -n efi-filesystem
|
||||||
|
%defattr(0700,root,root,-)
|
||||||
|
%dir /boot/efi
|
||||||
|
%dir /boot/efi/EFI
|
||||||
|
%dir /boot/efi/EFI/BOOT
|
||||||
|
%dir /boot/efi/EFI/%{_efi_vendor_}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jul 30 2024 Nicolas Frayer <nfrayer@redhat.com> - 6-3
|
||||||
|
- Update to efi-rpm-macros version 6
|
||||||
|
- Resolves: #RHEL-50848
|
||||||
|
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 5-12
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 5-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 5-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Dec 13 2023 Nicolas Frayer <nfrayer@redhat.com>
|
||||||
|
- Migrate to SPDX license
|
||||||
|
- Please refer to https://fedoraproject.org/wiki/Changes/SPDX_Licenses_Phase_2
|
||||||
|
|
||||||
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 5-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 09 2023 Sandro Bonazzola <sbonazzo@redhat.com> - 5-8
|
||||||
|
- Fixes permissions on /boot/efi/EFI
|
||||||
|
- Resolves: rhbz#2144459
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 5-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Sep 02 2021 Robbie Harwood <rharwood@redhat.com> - 5-4
|
||||||
|
- Remove arm as an alt for aarch64 (would require cross compiler)
|
||||||
|
|
||||||
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 06 2021 Peter Jones <pjones@redhat.com> - 5-2
|
||||||
|
- There's always a typo.
|
||||||
|
|
||||||
|
* Tue Apr 06 2021 Peter Jones <pjones@redhat.com> - 5-1
|
||||||
|
- Add arm as an alt for aarch64
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Sep 26 2018 Peter Jones <pjones@redhat.com> - 4-1
|
||||||
|
- Provide %%{efi_build_requires} and brp-boot-efi-times
|
||||||
|
|
||||||
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-2
|
||||||
|
- Always provide macros for efi_arch and efi_alt_arch (and their _upper
|
||||||
|
variants), and make efi_has_arch and efi_has_alt_arch 0 when they will be
|
||||||
|
wrong. This ensures everything can always expand when we're on a non-efi
|
||||||
|
architecture.
|
||||||
|
|
||||||
|
* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-1
|
||||||
|
- Update to version 3 to try and un-break rawhide composes due to
|
||||||
|
ExclusiveArch constraints.
|
||||||
|
|
||||||
|
* Thu May 03 2018 Peter Jones <pjones@redhat.com> - 2-6
|
||||||
|
- Rework the macros for better srpm use.
|
||||||
|
|
||||||
|
* Wed May 02 2018 Peter Jones <pjones@redhat.com> - 2-5
|
||||||
|
- Add efi-filesystem subpackage
|
||||||
|
|
||||||
|
* Wed May 02 2018 Peter Jones <pjones@redhat.com> - 2-4
|
||||||
|
- Add %%{efi_has_alt_arch}
|
||||||
|
|
||||||
|
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-3
|
||||||
|
- Make an efi-srpm-macros subpackage to pull in so %%{efi} works in
|
||||||
|
ExclusiveArch in koji.
|
||||||
|
|
||||||
|
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-2
|
||||||
|
- Fix the non-efi and non-efi-alt-arch cases, hopefully.
|
||||||
|
- Make efi-*-macros packages not be ExclusiveArch, because they need to work
|
||||||
|
in non-efi-arch packages.
|
||||||
|
|
||||||
|
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-1
|
||||||
|
- Lots of rpmlint fixups and the like.
|
||||||
|
|
||||||
|
* Mon Apr 30 2018 Peter Jones <pjones@redhat.com> - 1-1
|
||||||
|
- First shot at building it.
|
Loading…
Reference in New Issue
Block a user