36 lines
1.4 KiB
Diff
36 lines
1.4 KiB
Diff
From eebbf279b59afa3787d11734d9707cc7ab24d651 Mon Sep 17 00:00:00 2001
|
|
From: Laszlo Ersek <lersek@redhat.com>
|
|
Date: Wed, 25 Jul 2018 22:27:53 +0200
|
|
Subject: [PATCH] BaseTools/footer.makefile: expand BUILD_CFLAGS last for C
|
|
files too
|
|
|
|
BUILD_CPPFLAGS should be expanded before BUILD_CFLAGS. (The rule for C++
|
|
source files already does this, with BUILD_CPPFLAGS and BUILD_CXXFLAGS.)
|
|
|
|
This patch doesn't change behavior.
|
|
|
|
Cc: Liming Gao <liming.gao@intel.com>
|
|
Cc: Yonghong Zhu <yonghong.zhu@intel.com>
|
|
Ref: https://bugzilla.redhat.com/show_bug.cgi?id=1540244
|
|
Contributed-under: TianoCore Contribution Agreement 1.1
|
|
Signed-off-by: Laszlo Ersek <lersek@redhat.com>
|
|
Reviewed-by: Liming Gao <liming.gao@intel.com>
|
|
(cherry picked from commit 67983484a4430c5f82bb5f1397e010c759136321)
|
|
---
|
|
BaseTools/Source/C/Makefiles/footer.makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/BaseTools/Source/C/Makefiles/footer.makefile b/BaseTools/Source/C/Makefiles/footer.makefile
|
|
index 0926aa9645..5bda9e4e36 100644
|
|
--- a/BaseTools/Source/C/Makefiles/footer.makefile
|
|
+++ b/BaseTools/Source/C/Makefiles/footer.makefile
|
|
@@ -24,7 +24,7 @@ $(LIBRARY): $(OBJECTS)
|
|
$(BUILD_AR) crs $@ $^
|
|
|
|
%.o : %.c
|
|
- $(BUILD_CC) -c $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $< -o $@
|
|
+ $(BUILD_CC) -c $(BUILD_CPPFLAGS) $(BUILD_CFLAGS) $< -o $@
|
|
|
|
%.o : %.cpp
|
|
$(BUILD_CXX) -c $(BUILD_CPPFLAGS) $(BUILD_CXXFLAGS) $< -o $@
|