Update to git master 20170209git296153c5
New patch 0010 fixes failure to build from source.
This commit is contained in:
parent
63f9c47982
commit
d7ad69217c
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
||||
/openssl-1.0.2g-hobbled.tar.gz
|
||||
/openssl-1.0.2j-hobbled.tar.xz
|
||||
/edk2-20161105-3b25ca8.tar.gz
|
||||
/edk2-20170209-296153c5.tar.xz
|
||||
|
@ -15,12 +15,12 @@ Signed-off-by: Laszlo Ersek <lersek@redhat.com>
|
||||
3 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/OvmfPkg/OvmfPkgIa32.dsc b/OvmfPkg/OvmfPkgIa32.dsc
|
||||
index 048a144..c0440d9 100644
|
||||
index 767fd7d..40688dd 100644
|
||||
--- a/OvmfPkg/OvmfPkgIa32.dsc
|
||||
+++ b/OvmfPkg/OvmfPkgIa32.dsc
|
||||
@@ -543,6 +543,8 @@
|
||||
@@ -562,6 +562,8 @@
|
||||
<LibraryClasses>
|
||||
NULL|IntelFrameworkModulePkg/Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf
|
||||
NULL|MdeModulePkg/Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf
|
||||
DevicePathLib|MdePkg/Library/UefiDevicePathLib/UefiDevicePathLib.inf
|
||||
+ <PcdsFixedAtBuild>
|
||||
+ gEfiMdePkgTokenSpaceGuid.PcdDebugPrintErrorLevel|0x8000004F
|
||||
@ -28,12 +28,12 @@ index 048a144..c0440d9 100644
|
||||
|
||||
MdeModulePkg/Universal/ReportStatusCodeRouter/RuntimeDxe/ReportStatusCodeRouterRuntimeDxe.inf
|
||||
diff --git a/OvmfPkg/OvmfPkgIa32X64.dsc b/OvmfPkg/OvmfPkgIa32X64.dsc
|
||||
index fac0cf0..6f94bc7 100644
|
||||
index 7460d50..3e75388 100644
|
||||
--- a/OvmfPkg/OvmfPkgIa32X64.dsc
|
||||
+++ b/OvmfPkg/OvmfPkgIa32X64.dsc
|
||||
@@ -552,6 +552,8 @@
|
||||
@@ -571,6 +571,8 @@
|
||||
<LibraryClasses>
|
||||
NULL|IntelFrameworkModulePkg/Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf
|
||||
NULL|MdeModulePkg/Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf
|
||||
DevicePathLib|MdePkg/Library/UefiDevicePathLib/UefiDevicePathLib.inf
|
||||
+ <PcdsFixedAtBuild>
|
||||
+ gEfiMdePkgTokenSpaceGuid.PcdDebugPrintErrorLevel|0x8000004F
|
||||
@ -41,12 +41,12 @@ index fac0cf0..6f94bc7 100644
|
||||
|
||||
MdeModulePkg/Universal/ReportStatusCodeRouter/RuntimeDxe/ReportStatusCodeRouterRuntimeDxe.inf
|
||||
diff --git a/OvmfPkg/OvmfPkgX64.dsc b/OvmfPkg/OvmfPkgX64.dsc
|
||||
index bc62a64..a92bf19 100644
|
||||
index 765506a..e169f13 100644
|
||||
--- a/OvmfPkg/OvmfPkgX64.dsc
|
||||
+++ b/OvmfPkg/OvmfPkgX64.dsc
|
||||
@@ -550,6 +550,8 @@
|
||||
@@ -569,6 +569,8 @@
|
||||
<LibraryClasses>
|
||||
NULL|IntelFrameworkModulePkg/Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf
|
||||
NULL|MdeModulePkg/Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf
|
||||
DevicePathLib|MdePkg/Library/UefiDevicePathLib/UefiDevicePathLib.inf
|
||||
+ <PcdsFixedAtBuild>
|
||||
+ gEfiMdePkgTokenSpaceGuid.PcdDebugPrintErrorLevel|0x8000004F
|
||||
|
@ -56,18 +56,22 @@ resolution too.
|
||||
Contributed-under: TianoCore Contribution Agreement 1.0
|
||||
Signed-off-by: Laszlo Ersek <lersek@redhat.com>
|
||||
---
|
||||
.../Universal/Console/TerminalDxe/Terminal.c | 37 +++++++++++++++++++++-
|
||||
1 file changed, 36 insertions(+), 1 deletion(-)
|
||||
.../Universal/Console/TerminalDxe/Terminal.c | 41 ++++++++++++++++++++--
|
||||
1 file changed, 38 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/MdeModulePkg/Universal/Console/TerminalDxe/Terminal.c b/MdeModulePkg/Universal/Console/TerminalDxe/Terminal.c
|
||||
index 3f445f0..2537e27 100644
|
||||
index 5d55969..13620ac 100644
|
||||
--- a/MdeModulePkg/Universal/Console/TerminalDxe/Terminal.c
|
||||
+++ b/MdeModulePkg/Universal/Console/TerminalDxe/Terminal.c
|
||||
@@ -103,7 +103,42 @@ TERMINAL_DEV mTerminalDevTemplate = {
|
||||
@@ -113,9 +113,44 @@ TERMINAL_DEV mTerminalDevTemplate = {
|
||||
};
|
||||
|
||||
TERMINAL_CONSOLE_MODE_DATA mTerminalConsoleModeData[] = {
|
||||
- {80, 25},
|
||||
- {80, 50},
|
||||
- {100, 31},
|
||||
+ { 80, 25 }, // from graphics resolution 640 x 480
|
||||
+ { 80, 50 }, // from graphics resolution 640 x 480
|
||||
+ { 100, 25 }, // from graphics resolution 800 x 480
|
||||
+ { 100, 31 }, // from graphics resolution 800 x 600
|
||||
+ { 104, 32 }, // from graphics resolution 832 x 624
|
||||
|
@ -0,0 +1,30 @@
|
||||
From 06c3814868bebbe7f2cd9a51c11fbfc407c14349 Mon Sep 17 00:00:00 2001
|
||||
From: Paolo Bonzini <pbonzini@redhat.com>
|
||||
Date: Mon, 13 Feb 2017 13:49:14 +0100
|
||||
Subject: [PATCH] VfrCompile: fix invalid comparison between pointer and
|
||||
integer
|
||||
|
||||
This would be valid C but is not valid C++, so change the comparison
|
||||
to do what it has always been doing.
|
||||
|
||||
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
||||
---
|
||||
BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp b/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp
|
||||
index 3ca57ed..2f97975 100644
|
||||
--- a/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp
|
||||
+++ b/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp
|
||||
@@ -3372,7 +3372,7 @@ CVfrStringDB::GetVarStoreNameFormStringId (
|
||||
UINT8 BlockType;
|
||||
EFI_HII_STRING_PACKAGE_HDR *PkgHeader;
|
||||
|
||||
- if (mStringFileName == '\0' ) {
|
||||
+ if (mStringFileName == NULL) {
|
||||
return NULL;
|
||||
}
|
||||
|
||||
--
|
||||
2.9.3
|
||||
|
15
edk2.spec
15
edk2.spec
@ -1,16 +1,16 @@
|
||||
%global edk2_date 20161105
|
||||
%global edk2_githash 3b25ca8
|
||||
%global edk2_date 20170209
|
||||
%global edk2_githash 296153c5
|
||||
%global openssl_version 1.0.2j
|
||||
|
||||
Name: edk2
|
||||
Version: %{edk2_date}git%{edk2_githash}
|
||||
Release: 2%{dist}
|
||||
Release: 1%{dist}
|
||||
Summary: EFI Development Kit II
|
||||
|
||||
Group: Applications/Emulators
|
||||
License: BSD
|
||||
URL: http://www.tianocore.org/edk2/
|
||||
Source0: edk2-%{edk2_date}-%{edk2_githash}.tar.gz
|
||||
Source0: edk2-%{edk2_date}-%{edk2_githash}.tar.xz
|
||||
# We have to remove certain patented algorithms from the openssl source
|
||||
# tarball with the hobble-openssl script which is included below.
|
||||
# The original openssl upstream tarball cannot be shipped in the .src.rpm.
|
||||
@ -41,6 +41,9 @@ Patch0008: 0008-MdeModulePkg-TerminalDxe-add-other-text-resolutions.patch
|
||||
# These files are meant for customization, so this is not upstream.
|
||||
Patch0009: 0009-Tweak-the-tools_def-to-support-cross-compiling.patch
|
||||
|
||||
# fix for build failure, sent upstream
|
||||
Patch0010: 0010-VfrCompile-fix-invalid-comparison-between-pointer-an.patch
|
||||
|
||||
#
|
||||
# actual firmware builds support cross-compiling. edk2-tools
|
||||
# in theory should build everywhere without much trouble, but
|
||||
@ -302,6 +305,10 @@ cp -a arm %{buildroot}/usr/share/%{name}
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 13 2017 Paolo Bonzini <pbonzini@redhat.com> - 20170209git296153c5-1
|
||||
- Rebase to git master
|
||||
- New patch 0010 fixes failure to build from source.
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 20161105git3b25ca8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
||||
SHA512 (edk2-20161105-3b25ca8.tar.gz) = dd55b84106b83c36a1c0bfc6088811f106232ee0e18da1fb7014e97f3c2aba414c57995acc2172d099281ca659c15dec3bc03910b52c215e4724044dd94a1c48
|
||||
SHA512 (openssl-1.0.2j-hobbled.tar.xz) = 87c7c4e45f83c49b36154f4c66d3799fdc63286f9841b4dd71d4bdc3b26206be6009e33462533f0c1cc0efd9ef6aa05b772728ed0ee3e88f952586cdcf513003
|
||||
SHA512 (edk2-20170209-296153c5.tar.xz) = b9b1936bde197712fe0f5dc3cf227095c08803486866967703959f4adc131c48b1b5f3bcdd8a4a40fe234eba5a7fdf887087d4d522db01a0920eb85cc7ab9454
|
||||
|
Loading…
Reference in New Issue
Block a user