Update to 4.4.0 I-build to make it cope with Java 8.
This commit is contained in:
parent
61e09fe05c
commit
e49984b18b
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
ecj-gcj.tar.bz2
|
||||
ecjsrc-4.2.1.jar
|
||||
/ecj.1
|
||||
/ecjsrc-I20140430-2000.jar
|
||||
|
28
MANIFEST.MF
Normal file
28
MANIFEST.MF
Normal file
@ -0,0 +1,28 @@
|
||||
Manifest-Version: 1.0
|
||||
Main-Class: org.eclipse.jdt.internal.compiler.batch.Main
|
||||
Bundle-ManifestVersion: 2
|
||||
Bundle-Name: Eclipse Compiler for Java(TM)
|
||||
Bundle-SymbolicName: org.eclipse.jdt.core.compiler.batch
|
||||
Bundle-Version: 3.10.0.qualifier
|
||||
Bundle-ClassPath: .
|
||||
Bundle-Vendor: Eclipse.org
|
||||
Export-Package: org.eclipse.jdt.core,
|
||||
org.eclipse.jdt.core.compiler,
|
||||
org.eclipse.jdt.internal.antadapter;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.apt.dispatch;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.apt.model;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.apt.util;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.ast;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.batch;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.classfmt;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.codegen;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.env;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.flow;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.impl;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.lookup;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.parser;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.parser.diagnose;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.problem;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.util;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.tool;x-internal:=true
|
@ -1,7 +1,7 @@
|
||||
--- a/build.xml 2012-10-09 13:56:47.695928242 -0400
|
||||
+++ b/build.xml 2012-10-09 13:57:06.822893233 -0400
|
||||
@@ -46,6 +46,7 @@
|
||||
<include name="**/*.rsc"/>
|
||||
--- build.xml 2014-05-01 09:36:51.417339328 +0300
|
||||
+++ build.xml 2014-05-01 09:38:36.330493400 +0300
|
||||
@@ -49,6 +49,7 @@
|
||||
<include name="**/readableNames.props"/>
|
||||
<include name="META-INF/**"/>
|
||||
<include name="**/*.properties"/>
|
||||
+ <include name="**/*.props"/>
|
||||
|
21
ecj.spec
21
ecj.spec
@ -1,18 +1,18 @@
|
||||
Epoch: 1
|
||||
|
||||
%global qualifier 201209141800
|
||||
%global qualifier I20140430-2000
|
||||
|
||||
%define with_gcjbootstrap %{!?_with_gcjbootstrap:0}%{?_with_gcjbootstrap:1}
|
||||
%define without_gcjbootstrap %{?_with_gcjbootstrap:0}%{!?_with_gcjbootstrap:1}
|
||||
|
||||
Summary: Eclipse Compiler for Java
|
||||
Name: ecj
|
||||
Version: 4.2.1
|
||||
Release: 10%{?dist}
|
||||
Version: 4.4.0
|
||||
Release: 0.1.git20140430%{?dist}
|
||||
URL: http://www.eclipse.org
|
||||
License: EPL
|
||||
Group: Development/Languages
|
||||
Source0: http://download.eclipse.org/eclipse/downloads/drops4/R-%{version}-%{qualifier}/%{name}src-%{version}.jar
|
||||
Source0: http://download.eclipse.org/eclipse/downloads/drops4/%{qualifier}/%{name}src-%{qualifier}.jar
|
||||
Source1: ecj.sh.in
|
||||
# Use ECJ for GCJ
|
||||
# cvs -d:pserver:anonymous@sourceware.org:/cvs/rhug \
|
||||
@ -23,6 +23,7 @@ Source2: %{name}-gcj.tar.bz2
|
||||
# No dependencies are needed for ecj, dependencies are for using of jdt.core which makes no sense outside of eclipse
|
||||
Source3: core-3.3.0-v_771.pom
|
||||
Source4: ecj.1
|
||||
Source5: http://git.eclipse.org/c/jdt/eclipse.jdt.core.git/plain/org.eclipse.jdt.core/scripts/binary/META-INF/MANIFEST.MF
|
||||
# Always generate debug info when building RPMs (Andrew Haley)
|
||||
Patch0: %{name}-rpmdebuginfo.patch
|
||||
Patch1: %{name}-defaultto1.5.patch
|
||||
@ -55,11 +56,12 @@ the JDT Core batch compiler.
|
||||
%prep
|
||||
%setup -q -c
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch4 -p1
|
||||
%patch4 -b .sav
|
||||
|
||||
cp %{SOURCE3} pom.xml
|
||||
mkdir -p scripts/binary/META-INF/
|
||||
cp %{SOURCE5} scripts/binary/META-INF/MANIFEST.MF
|
||||
# Use ECJ for GCJ's bytecode compiler
|
||||
tar jxf %{SOURCE2}
|
||||
mv eclipse-gcj/org/eclipse/jdt/internal/compiler/batch/GCCMain.java \
|
||||
@ -74,6 +76,10 @@ rm -rf eclipse-gcj
|
||||
rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java
|
||||
cp %{SOURCE4} ecj.1
|
||||
|
||||
sed -i -e "s/1.3/1.6/g" build.xml
|
||||
sed -i -e "s/1.2/1.6/g" build.xml
|
||||
sed -i -e "s/Xlint:none/Xdoclint:none -encoding cp1252/g" build.xml
|
||||
|
||||
%build
|
||||
%if %{with_gcjbootstrap}
|
||||
# Remove bits of JDT Core we don't want to build
|
||||
@ -127,6 +133,9 @@ install -pm 644 pom.xml \
|
||||
%{_mandir}/man1/ecj.1.gz
|
||||
|
||||
%changelog
|
||||
* Thu May 1 2014 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.0-0.1.git20140430
|
||||
- Update to 4.4.0 I-build to make it cope with Java 8.
|
||||
|
||||
* Mon Apr 14 2014 Mat Booth <mat.booth@redhat.com> - 1:4.2.1-10
|
||||
- Drop gcj AOT-compilation support.
|
||||
- Obsolete -native sub-package.
|
||||
|
Loading…
Reference in New Issue
Block a user