Update to 4.4.0 I-build to make it cope with Java 8.
This commit is contained in:
parent
61e09fe05c
commit
e49984b18b
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
ecj-gcj.tar.bz2
|
ecj-gcj.tar.bz2
|
||||||
ecjsrc-4.2.1.jar
|
ecjsrc-4.2.1.jar
|
||||||
/ecj.1
|
/ecj.1
|
||||||
|
/ecjsrc-I20140430-2000.jar
|
||||||
|
28
MANIFEST.MF
Normal file
28
MANIFEST.MF
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
Manifest-Version: 1.0
|
||||||
|
Main-Class: org.eclipse.jdt.internal.compiler.batch.Main
|
||||||
|
Bundle-ManifestVersion: 2
|
||||||
|
Bundle-Name: Eclipse Compiler for Java(TM)
|
||||||
|
Bundle-SymbolicName: org.eclipse.jdt.core.compiler.batch
|
||||||
|
Bundle-Version: 3.10.0.qualifier
|
||||||
|
Bundle-ClassPath: .
|
||||||
|
Bundle-Vendor: Eclipse.org
|
||||||
|
Export-Package: org.eclipse.jdt.core,
|
||||||
|
org.eclipse.jdt.core.compiler,
|
||||||
|
org.eclipse.jdt.internal.antadapter;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.apt.dispatch;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.apt.model;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.apt.util;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.ast;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.batch;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.classfmt;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.codegen;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.env;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.flow;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.impl;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.lookup;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.parser;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.parser.diagnose;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.problem;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.util;x-internal:=true,
|
||||||
|
org.eclipse.jdt.internal.compiler.tool;x-internal:=true
|
@ -1,7 +1,7 @@
|
|||||||
--- a/build.xml 2012-10-09 13:56:47.695928242 -0400
|
--- build.xml 2014-05-01 09:36:51.417339328 +0300
|
||||||
+++ b/build.xml 2012-10-09 13:57:06.822893233 -0400
|
+++ build.xml 2014-05-01 09:38:36.330493400 +0300
|
||||||
@@ -46,6 +46,7 @@
|
@@ -49,6 +49,7 @@
|
||||||
<include name="**/*.rsc"/>
|
<include name="**/readableNames.props"/>
|
||||||
<include name="META-INF/**"/>
|
<include name="META-INF/**"/>
|
||||||
<include name="**/*.properties"/>
|
<include name="**/*.properties"/>
|
||||||
+ <include name="**/*.props"/>
|
+ <include name="**/*.props"/>
|
||||||
|
23
ecj.spec
23
ecj.spec
@ -1,18 +1,18 @@
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
%global qualifier 201209141800
|
%global qualifier I20140430-2000
|
||||||
|
|
||||||
%define with_gcjbootstrap %{!?_with_gcjbootstrap:0}%{?_with_gcjbootstrap:1}
|
%define with_gcjbootstrap %{!?_with_gcjbootstrap:0}%{?_with_gcjbootstrap:1}
|
||||||
%define without_gcjbootstrap %{?_with_gcjbootstrap:0}%{!?_with_gcjbootstrap:1}
|
%define without_gcjbootstrap %{?_with_gcjbootstrap:0}%{!?_with_gcjbootstrap:1}
|
||||||
|
|
||||||
Summary: Eclipse Compiler for Java
|
Summary: Eclipse Compiler for Java
|
||||||
Name: ecj
|
Name: ecj
|
||||||
Version: 4.2.1
|
Version: 4.4.0
|
||||||
Release: 10%{?dist}
|
Release: 0.1.git20140430%{?dist}
|
||||||
URL: http://www.eclipse.org
|
URL: http://www.eclipse.org
|
||||||
License: EPL
|
License: EPL
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Source0: http://download.eclipse.org/eclipse/downloads/drops4/R-%{version}-%{qualifier}/%{name}src-%{version}.jar
|
Source0: http://download.eclipse.org/eclipse/downloads/drops4/%{qualifier}/%{name}src-%{qualifier}.jar
|
||||||
Source1: ecj.sh.in
|
Source1: ecj.sh.in
|
||||||
# Use ECJ for GCJ
|
# Use ECJ for GCJ
|
||||||
# cvs -d:pserver:anonymous@sourceware.org:/cvs/rhug \
|
# cvs -d:pserver:anonymous@sourceware.org:/cvs/rhug \
|
||||||
@ -23,6 +23,7 @@ Source2: %{name}-gcj.tar.bz2
|
|||||||
# No dependencies are needed for ecj, dependencies are for using of jdt.core which makes no sense outside of eclipse
|
# No dependencies are needed for ecj, dependencies are for using of jdt.core which makes no sense outside of eclipse
|
||||||
Source3: core-3.3.0-v_771.pom
|
Source3: core-3.3.0-v_771.pom
|
||||||
Source4: ecj.1
|
Source4: ecj.1
|
||||||
|
Source5: http://git.eclipse.org/c/jdt/eclipse.jdt.core.git/plain/org.eclipse.jdt.core/scripts/binary/META-INF/MANIFEST.MF
|
||||||
# Always generate debug info when building RPMs (Andrew Haley)
|
# Always generate debug info when building RPMs (Andrew Haley)
|
||||||
Patch0: %{name}-rpmdebuginfo.patch
|
Patch0: %{name}-rpmdebuginfo.patch
|
||||||
Patch1: %{name}-defaultto1.5.patch
|
Patch1: %{name}-defaultto1.5.patch
|
||||||
@ -55,11 +56,12 @@ the JDT Core batch compiler.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -c
|
%setup -q -c
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch4 -p1
|
%patch4 -b .sav
|
||||||
|
|
||||||
cp %{SOURCE3} pom.xml
|
cp %{SOURCE3} pom.xml
|
||||||
|
mkdir -p scripts/binary/META-INF/
|
||||||
|
cp %{SOURCE5} scripts/binary/META-INF/MANIFEST.MF
|
||||||
# Use ECJ for GCJ's bytecode compiler
|
# Use ECJ for GCJ's bytecode compiler
|
||||||
tar jxf %{SOURCE2}
|
tar jxf %{SOURCE2}
|
||||||
mv eclipse-gcj/org/eclipse/jdt/internal/compiler/batch/GCCMain.java \
|
mv eclipse-gcj/org/eclipse/jdt/internal/compiler/batch/GCCMain.java \
|
||||||
@ -74,6 +76,10 @@ rm -rf eclipse-gcj
|
|||||||
rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java
|
rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java
|
||||||
cp %{SOURCE4} ecj.1
|
cp %{SOURCE4} ecj.1
|
||||||
|
|
||||||
|
sed -i -e "s/1.3/1.6/g" build.xml
|
||||||
|
sed -i -e "s/1.2/1.6/g" build.xml
|
||||||
|
sed -i -e "s/Xlint:none/Xdoclint:none -encoding cp1252/g" build.xml
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with_gcjbootstrap}
|
%if %{with_gcjbootstrap}
|
||||||
# Remove bits of JDT Core we don't want to build
|
# Remove bits of JDT Core we don't want to build
|
||||||
@ -89,7 +95,7 @@ cp %{SOURCE4} ecj.1
|
|||||||
find -name '*.class' -or -name '*.properties' -or -name '*.rsc' |\
|
find -name '*.class' -or -name '*.properties' -or -name '*.rsc' |\
|
||||||
xargs fastjar cf %{name}-%{version}.jar
|
xargs fastjar cf %{name}-%{version}.jar
|
||||||
%else
|
%else
|
||||||
ant
|
ant
|
||||||
%endif
|
%endif
|
||||||
gzip ecj.1
|
gzip ecj.1
|
||||||
|
|
||||||
@ -127,6 +133,9 @@ install -pm 644 pom.xml \
|
|||||||
%{_mandir}/man1/ecj.1.gz
|
%{_mandir}/man1/ecj.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 1 2014 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.0-0.1.git20140430
|
||||||
|
- Update to 4.4.0 I-build to make it cope with Java 8.
|
||||||
|
|
||||||
* Mon Apr 14 2014 Mat Booth <mat.booth@redhat.com> - 1:4.2.1-10
|
* Mon Apr 14 2014 Mat Booth <mat.booth@redhat.com> - 1:4.2.1-10
|
||||||
- Drop gcj AOT-compilation support.
|
- Drop gcj AOT-compilation support.
|
||||||
- Obsolete -native sub-package.
|
- Obsolete -native sub-package.
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
f603934950639ed6ac2b2527705a69f0 ecjsrc-4.2.1.jar
|
|
||||||
0af236868ba699f2e55c654b8aca1258 ecj-gcj.tar.bz2
|
0af236868ba699f2e55c654b8aca1258 ecj-gcj.tar.bz2
|
||||||
96d507a301eeb8454299a325a9aca31d ecj.1
|
96d507a301eeb8454299a325a9aca31d ecj.1
|
||||||
|
d0ec30d76e94e0c81b85955ec4c0e853 ecjsrc-I20140430-2000.jar
|
||||||
|
Loading…
Reference in New Issue
Block a user