Fix FTBFS.
This commit is contained in:
parent
4704499fb0
commit
9b5253739e
@ -1,22 +0,0 @@
|
||||
### Eclipse Workspace Patch 1.0
|
||||
#P org.eclipse.jdt.core
|
||||
Index: compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.jdt.core/compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java,v
|
||||
retrieving revision 1.203
|
||||
diff -u -r1.203 CompilerOptions.java
|
||||
--- compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java 14 Apr 2008 19:41:33 -0000 1.203
|
||||
+++ compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java 15 Dec 2008 19:50:02 -0000
|
||||
@@ -1145,9 +1145,9 @@
|
||||
|
||||
// by default only lines and source attributes are generated.
|
||||
this.produceDebugAttributes = ClassFileConstants.ATTR_SOURCE | ClassFileConstants.ATTR_LINES;
|
||||
- this.complianceLevel = this.originalComplianceLevel = ClassFileConstants.JDK1_4; // by default be compliant with 1.4
|
||||
- this.sourceLevel = this.originalSourceLevel = ClassFileConstants.JDK1_3; //1.3 source behavior by default
|
||||
- this.targetJDK = ClassFileConstants.JDK1_2; // default generates for JVM1.2
|
||||
+ this.complianceLevel = this.originalComplianceLevel = ClassFileConstants.JDK1_5;
|
||||
+ this.sourceLevel = this.originalSourceLevel = ClassFileConstants.JDK1_5;
|
||||
+ this.targetJDK = ClassFileConstants.JDK1_5;
|
||||
|
||||
this.defaultEncoding = null; // will use the platform default encoding
|
||||
|
46
ecj.spec
46
ecj.spec
@ -2,13 +2,10 @@ Epoch: 1
|
||||
|
||||
%global qualifier I20140430-2000
|
||||
|
||||
%define with_gcjbootstrap %{!?_with_gcjbootstrap:0}%{?_with_gcjbootstrap:1}
|
||||
%define without_gcjbootstrap %{?_with_gcjbootstrap:0}%{!?_with_gcjbootstrap:1}
|
||||
|
||||
Summary: Eclipse Compiler for Java
|
||||
Name: ecj
|
||||
Version: 4.4.0
|
||||
Release: 0.2.git20140430%{?dist}
|
||||
Release: 0.3.git20140430%{?dist}
|
||||
URL: http://www.eclipse.org
|
||||
License: EPL
|
||||
Group: Development/Languages
|
||||
@ -26,23 +23,19 @@ Source4: ecj.1
|
||||
Source5: http://git.eclipse.org/c/jdt/eclipse.jdt.core.git/plain/org.eclipse.jdt.core/scripts/binary/META-INF/MANIFEST.MF
|
||||
# Always generate debug info when building RPMs (Andrew Haley)
|
||||
Patch0: %{name}-rpmdebuginfo.patch
|
||||
Patch1: %{name}-defaultto1.5.patch
|
||||
Patch2: %{name}-generatedebuginfo.patch
|
||||
Patch1: %{name}-generatedebuginfo.patch
|
||||
# Patches Source2 for compatibility with newer ecj
|
||||
Patch3: eclipse-gcj-compat4.2.1.patch
|
||||
Patch2: eclipse-gcj-compat4.2.1.patch
|
||||
# build.xml fails to include a necessary .props file in the built ecj.jar
|
||||
Patch4: %{name}-include-props.patch
|
||||
Patch5: eclipse-gcj-nodummysymbol.patch
|
||||
Patch3: %{name}-include-props.patch
|
||||
Patch4: eclipse-gcj-nodummysymbol.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: gcc-java >= 4.0.0
|
||||
BuildRequires: gzip
|
||||
|
||||
%if ! %{with_gcjbootstrap}
|
||||
BuildRequires: ant
|
||||
BuildRequires: java-devel >= 1:1.7.0
|
||||
%endif
|
||||
|
||||
Provides: eclipse-ecj = %{epoch}:%{version}-%{release}
|
||||
Obsoletes: eclipse-ecj < 1:3.4.2-4
|
||||
@ -56,8 +49,8 @@ the JDT Core batch compiler.
|
||||
%prep
|
||||
%setup -q -c
|
||||
%patch0 -p1
|
||||
%patch2 -p1
|
||||
%patch4 -b .sav
|
||||
%patch1 -p1
|
||||
%patch3 -b .sav
|
||||
|
||||
cp %{SOURCE3} pom.xml
|
||||
mkdir -p scripts/binary/META-INF/
|
||||
@ -66,8 +59,8 @@ cp %{SOURCE5} scripts/binary/META-INF/MANIFEST.MF
|
||||
tar jxf %{SOURCE2}
|
||||
mv eclipse-gcj/org/eclipse/jdt/internal/compiler/batch/GCCMain.java \
|
||||
org/eclipse/jdt/internal/compiler/batch/
|
||||
%patch3 -p1
|
||||
%patch5 -p1
|
||||
%patch2 -p1
|
||||
%patch4 -p1
|
||||
cat eclipse-gcj/gcc.properties >> \
|
||||
org/eclipse/jdt/internal/compiler/batch/messages.properties
|
||||
rm -rf eclipse-gcj
|
||||
@ -81,22 +74,7 @@ sed -i -e "s/1.2/1.6/g" build.xml
|
||||
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
|
||||
|
||||
%build
|
||||
%if %{with_gcjbootstrap}
|
||||
# Remove bits of JDT Core we don't want to build
|
||||
# These classes are required by querydsl framework and its plugins
|
||||
rm -r org/eclipse/jdt/internal/compiler/tool
|
||||
rm -r org/eclipse/jdt/internal/compiler/apt
|
||||
|
||||
rm -f org/eclipse/jdt/core/BuildJarIndex.java
|
||||
for f in `find -name '*.java' | cut -c 3- | LC_ALL=C sort`; do
|
||||
gcj -Wno-deprecated -C $f
|
||||
done
|
||||
|
||||
find -name '*.class' -or -name '*.properties' -or -name '*.rsc' |\
|
||||
xargs fastjar cf %{name}-%{version}.jar
|
||||
%else
|
||||
ant
|
||||
%endif
|
||||
gzip ecj.1
|
||||
|
||||
%install
|
||||
@ -122,10 +100,9 @@ install -pm 644 pom.xml \
|
||||
|
||||
%add_maven_depmap -a "org.eclipse.tycho:org.eclipse.jdt.core,org.eclipse.jdt.core.compiler:ecj" JPP-%{name}.pom %{name}.jar
|
||||
|
||||
%files
|
||||
%files -f .mfiles
|
||||
%doc about.html
|
||||
%{_mavenpomdir}/JPP-%{name}.pom
|
||||
%{_mavendepmapfragdir}/%{name}
|
||||
%{_bindir}/%{name}
|
||||
%{_javadir}/%{name}.jar
|
||||
%{_javadir}/eclipse-%{name}.jar
|
||||
@ -133,6 +110,9 @@ install -pm 644 pom.xml \
|
||||
%{_mandir}/man1/ecj.1.gz
|
||||
|
||||
%changelog
|
||||
* Mon Jun 9 2014 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.0-0.3.git20140430
|
||||
- Fix FTBFS.
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.4.0-0.2.git20140430
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user