Update to Oxygen.3
This commit is contained in:
parent
f8d6b5774f
commit
84a88bfa92
15
ecj.spec
15
ecj.spec
@ -1,11 +1,11 @@
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
%global qualifier R-4.7.1-201709061700
|
%global qualifier M-4.7.3-201803010715
|
||||||
|
|
||||||
Summary: Eclipse Compiler for Java
|
Summary: Eclipse Compiler for Java
|
||||||
Name: ecj
|
Name: ecj
|
||||||
Version: 4.7.1
|
Version: 4.7.3
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.eclipse.org
|
URL: http://www.eclipse.org
|
||||||
License: EPL
|
License: EPL
|
||||||
|
|
||||||
@ -21,6 +21,9 @@ Patch0: %{name}-rpmdebuginfo.patch
|
|||||||
# Fix build with lambda syntax, ebz#520940
|
# Fix build with lambda syntax, ebz#520940
|
||||||
Patch1: java8.patch
|
Patch1: java8.patch
|
||||||
|
|
||||||
|
# Include java9api stubs in build
|
||||||
|
Patch2: java9api.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: ant
|
BuildRequires: ant
|
||||||
@ -34,6 +37,7 @@ the JDT Core batch compiler.
|
|||||||
%setup -q -c
|
%setup -q -c
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p3
|
%patch1 -p3
|
||||||
|
%patch2 -b.orig
|
||||||
|
|
||||||
sed -i -e 's|debuglevel=\"lines,source\"|debug=\"yes\"|g' build.xml
|
sed -i -e 's|debuglevel=\"lines,source\"|debug=\"yes\"|g' build.xml
|
||||||
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
|
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
|
||||||
@ -55,7 +59,7 @@ rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java
|
|||||||
org.eclipse.jdt:core org.eclipse.jdt:ecj
|
org.eclipse.jdt:core org.eclipse.jdt:ecj
|
||||||
|
|
||||||
%build
|
%build
|
||||||
ant
|
ant -Djava9api=$(build-classpath eclipse/java9api)
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%mvn_artifact pom.xml ecj.jar
|
%mvn_artifact pom.xml ecj.jar
|
||||||
@ -74,6 +78,9 @@ install -m 644 -p ecj.1 $RPM_BUILD_ROOT%{_mandir}/man1/ecj.1
|
|||||||
%{_mandir}/man1/ecj*
|
%{_mandir}/man1/ecj*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 20 2018 Mat Booth <mat.booth@redhat.com> - 1:4.7.3-1
|
||||||
|
- Update to Oxygen.3
|
||||||
|
|
||||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.7.1-2
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.7.1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
48
java9api.patch
Normal file
48
java9api.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
--- build.xml.orig 2018-03-20 15:15:57.063810672 +0000
|
||||||
|
+++ build.xml 2018-03-20 15:16:26.018700633 +0000
|
||||||
|
@@ -15,16 +15,20 @@
|
||||||
|
<property name="output" value="bin" />
|
||||||
|
<property name="jar_file" value="ecj.jar" />
|
||||||
|
|
||||||
|
+ <path id="build.path">
|
||||||
|
+ <pathelement path="${java9api}"/>
|
||||||
|
+ <pathelement path="/usr/lib/jvm/java-1.8.0/jre/lib/rt.jar"/>
|
||||||
|
+ </path>
|
||||||
|
<target name="build">
|
||||||
|
<delete file="${basedir}/${jar_file}" failonerror="no" />
|
||||||
|
<delete dir="${output}" failonerror="no" />
|
||||||
|
<mkdir dir="${output}" />
|
||||||
|
|
||||||
|
- <javac srcdir="${basedir}" destdir="${output}"
|
||||||
|
- debuglevel="lines,source"
|
||||||
|
+ <javac srcdir="${basedir}" destdir="${output}" bootclasspathref="build.path"
|
||||||
|
+ debug="yes"
|
||||||
|
source="1.8"
|
||||||
|
target="1.8">
|
||||||
|
- <compilerarg line="-Xlint:none"/>
|
||||||
|
+ <compilerarg line="-Xlint:none -encoding cp1252 -encoding cp1252"/>
|
||||||
|
</javac>
|
||||||
|
|
||||||
|
<delete file="${basedir}/META-INF/MANIFEST.MF" failonerror="false"/>
|
||||||
|
--- org/eclipse/jdt/internal/compiler/env/IModulePathEntry.java.orig 2018-03-20 15:38:22.373710813 +0000
|
||||||
|
+++ org/eclipse/jdt/internal/compiler/env/IModulePathEntry.java 2018-03-20 15:39:46.541393267 +0000
|
||||||
|
@@ -10,7 +10,6 @@
|
||||||
|
*******************************************************************************/
|
||||||
|
package org.eclipse.jdt.internal.compiler.env;
|
||||||
|
|
||||||
|
-import org.eclipse.jdt.core.IJavaProject;
|
||||||
|
import org.eclipse.jdt.core.compiler.CharOperation;
|
||||||
|
|
||||||
|
/**
|
||||||
|
@@ -80,9 +79,4 @@
|
||||||
|
public default boolean isAutomaticModule() {
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
-
|
||||||
|
- /** Tests whether the current entry represents the given java project. */
|
||||||
|
- public default boolean equalsProject(IJavaProject project) {
|
||||||
|
- return false;
|
||||||
|
- }
|
||||||
|
-}
|
||||||
|
\ No newline at end of file
|
||||||
|
+}
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (ecj-4.7.1.pom) = 2f670ac1b1fefa73ae73a56b99b374bc1c3c31944e667f39c0a16cae2580e754f2ba3f6b2ec5234cf1ab03d63743f71a0912a4919772b37fe7b4f37fbd9593d8
|
SHA512 (ecjsrc-4.7.3.jar) = 31a86941360fca6a9e93216acf3f66ea27d66b955ffefed7f2b160685ac0d26111e8eaf0fecfd4972f48112970d1501cf60aed121c67c55f007b313706490688
|
||||||
SHA512 (ecjsrc-4.7.1.jar) = d4ec9be4c7e3f6b5072dad58219b98475def366d45953a92e7fedfa7b316522a377a19a2733e81411e1bb072db7fdf27fd420d2db4229b225349adc27dcaacd9
|
SHA512 (ecj-4.7.3.pom) = 79e59064806c2c4a2ed62da3a584448bbd3603bc1e7fab73f0d5b34dffec8ff8305604e1786e8e5fbf41204a4e336e3268d862158986fea0d4cbd81bb1158d32
|
||||||
|
Loading…
Reference in New Issue
Block a user