diff --git a/.project b/.project
new file mode 100644
index 0000000..f7c15c2
--- /dev/null
+++ b/.project
@@ -0,0 +1,11 @@
+
+
+ ecj
+
+
+
+
+
+
+
+
diff --git a/ecj.spec b/ecj.spec
index e5b836e..6f35fb0 100644
--- a/ecj.spec
+++ b/ecj.spec
@@ -8,7 +8,7 @@ Epoch: 1
Summary: Eclipse Compiler for Java
Name: ecj
Version: 4.2.1
-Release: 9%{?dist}
+Release: 10%{?dist}
URL: http://www.eclipse.org
License: EPL
Group: Development/Languages
@@ -33,9 +33,9 @@ Patch3: eclipse-gcj-compat4.2.1.patch
Patch4: %{name}-include-props.patch
Patch5: eclipse-gcj-nodummysymbol.patch
+BuildArch: noarch
+
BuildRequires: gcc-java >= 4.0.0
-BuildRequires: /usr/bin/aot-compile-rpm
-BuildRequires: java-gcj-compat
BuildRequires: gzip
%if ! %{with_gcjbootstrap}
@@ -46,22 +46,12 @@ BuildRequires: java-devel >= 1:1.7.0
Provides: eclipse-ecj = %{epoch}:%{version}-%{release}
Obsoletes: eclipse-ecj < 1:3.4.2-4
+Obsoletes: %{name}-native < 1:4.2.1-10
+
%description
ECJ is the Java bytecode compiler of the Eclipse Platform. It is also known as
the JDT Core batch compiler.
-%package native
-Summary: Native(gcj) bits for %{name}
-Group: Development/Libraries
-Requires: %{name} = %{epoch}:%{version}-%{release}
-Requires: libgcj >= 4.0.0
-Requires(post): java-gcj-compat
-Requires(postun): java-gcj-compat
-
-%description native
-AOT compiled ecj to speed up when running under GCJ.
-
-
%prep
%setup -q -c
%patch0 -p1
@@ -119,8 +109,6 @@ sed --in-place "s:@JAVADIR@:%{_javadir}:" $RPM_BUILD_ROOT%{_bindir}/ecj
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
install -m 644 -p ecj.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/ecj.1.gz
-aot-compile-rpm
-
# poms
install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
install -pm 644 pom.xml \
@@ -128,18 +116,6 @@ install -pm 644 pom.xml \
%add_maven_depmap -a "org.eclipse.tycho:org.eclipse.jdt.core,org.eclipse.jdt.core.compiler:ecj" JPP-%{name}.pom %{name}.jar
-%post native
-if [ -x %{_bindir}/rebuild-gcj-db ]
-then
- %{_bindir}/rebuild-gcj-db
-fi
-
-%postun native
-if [ -x %{_bindir}/rebuild-gcj-db ]
-then
- %{_bindir}/rebuild-gcj-db
-fi
-
%files
%doc about.html
%{_mavenpomdir}/JPP-%{name}.pom
@@ -150,10 +126,11 @@ fi
%{_javadir}/jdtcore.jar
%{_mandir}/man1/ecj.1.gz
-%files native
-%{_libdir}/gcj/%{name}
-
%changelog
+* Mon Apr 14 2014 Mat Booth - 1:4.2.1-10
+- Drop gcj AOT-compilation support.
+- Obsolete -native sub-package.
+
* Wed Oct 09 2013 gil cattaneo 1:4.2.1-9
- enable build of org/eclipse/jdt/internal/compiler/[apt,tool]
(ant build mode only), required by querydsl