Update to Mars.1 release
This commit is contained in:
parent
d3211075f5
commit
2f46010af2
48
MANIFEST.MF
48
MANIFEST.MF
@ -1,28 +1,28 @@
|
||||
Manifest-Version: 1.0
|
||||
Main-Class: org.eclipse.jdt.internal.compiler.batch.Main
|
||||
Bundle-ManifestVersion: 2
|
||||
Bundle-Name: Eclipse Compiler for Java(TM)
|
||||
Archiver-Version: Plexus Archiver
|
||||
Created-By: Apache Maven
|
||||
Built-By: e4Build
|
||||
Build-Jdk: 1.8.0_51
|
||||
Bundle-SymbolicName: org.eclipse.jdt.core.compiler.batch
|
||||
Bundle-Version: 3.11.0.qualifier
|
||||
Export-Package: org.eclipse.jdt.core,org.eclipse.jdt.core.compiler,org
|
||||
.eclipse.jdt.internal.antadapter;x-internal:=true,org.eclipse.jdt.int
|
||||
ernal.compiler;x-internal:=true,org.eclipse.jdt.internal.compiler.apt
|
||||
.dispatch;x-internal:=true,org.eclipse.jdt.internal.compiler.apt.mode
|
||||
l;x-internal:=true,org.eclipse.jdt.internal.compiler.apt.util;x-inter
|
||||
nal:=true,org.eclipse.jdt.internal.compiler.ast;x-internal:=true,org.
|
||||
eclipse.jdt.internal.compiler.batch;x-internal:=true,org.eclipse.jdt.
|
||||
internal.compiler.classfmt;x-internal:=true,org.eclipse.jdt.internal.
|
||||
compiler.codegen;x-internal:=true,org.eclipse.jdt.internal.compiler.e
|
||||
nv;x-internal:=true,org.eclipse.jdt.internal.compiler.flow;x-internal
|
||||
:=true,org.eclipse.jdt.internal.compiler.impl;x-internal:=true,org.ec
|
||||
lipse.jdt.internal.compiler.lookup;x-internal:=true,org.eclipse.jdt.i
|
||||
nternal.compiler.parser;x-internal:=true,org.eclipse.jdt.internal.com
|
||||
piler.parser.diagnose;x-internal:=true,org.eclipse.jdt.internal.compi
|
||||
ler.problem;x-internal:=true,org.eclipse.jdt.internal.compiler.util;x
|
||||
-internal:=true,org.eclipse.jdt.internal.compiler.tool;x-internal:=true
|
||||
Bundle-Name: Eclipse Compiler for Java(TM)
|
||||
Bundle-Version: 3.11.1.v20150902-1521
|
||||
Bundle-ClassPath: .
|
||||
Bundle-ManifestVersion: 2
|
||||
Bundle-Vendor: Eclipse.org
|
||||
Export-Package: org.eclipse.jdt.core,
|
||||
org.eclipse.jdt.core.compiler,
|
||||
org.eclipse.jdt.internal.antadapter;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.apt.dispatch;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.apt.model;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.apt.util;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.ast;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.batch;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.classfmt;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.codegen;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.env;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.flow;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.impl;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.lookup;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.parser;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.parser.diagnose;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.problem;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.util;x-internal:=true,
|
||||
org.eclipse.jdt.internal.compiler.tool;x-internal:=true
|
||||
Main-Class: org.eclipse.jdt.internal.compiler.batch.Main
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- build.xml 2014-05-01 09:36:51.417339328 +0300
|
||||
+++ build.xml 2014-05-01 09:38:36.330493400 +0300
|
||||
@@ -49,6 +49,7 @@
|
||||
<include name="**/readableNames.props"/>
|
||||
<include name="META-INF/**"/>
|
||||
<include name="**/*.properties"/>
|
||||
+ <include name="**/*.props"/>
|
||||
<exclude name="META-INF/eclipse.inf"/>
|
||||
</fileset>
|
||||
</zip>
|
@ -1,4 +1,4 @@
|
||||
#!/bin/sh
|
||||
|
||||
CLASSPATH=@JAVADIR@/ecj.jar:${CLASSPATH=.} \
|
||||
CLASSPATH=$(build-classpath ecj):${CLASSPATH=.} \
|
||||
java org.eclipse.jdt.internal.compiler.batch.Main "$@"
|
||||
|
16
ecj.spec
16
ecj.spec
@ -1,10 +1,10 @@
|
||||
Epoch: 1
|
||||
|
||||
%global qualifier R-4.5-201506032000
|
||||
%global qualifier R-4.5.1-201509040015
|
||||
|
||||
Summary: Eclipse Compiler for Java
|
||||
Name: ecj
|
||||
Version: 4.5
|
||||
Version: 4.5.1
|
||||
Release: 1%{?dist}
|
||||
URL: http://www.eclipse.org
|
||||
License: EPL
|
||||
@ -12,12 +12,11 @@ License: EPL
|
||||
Source0: http://download.eclipse.org/eclipse/downloads/drops4/%{qualifier}/ecjsrc-%{version}.jar
|
||||
Source1: ecj.sh.in
|
||||
Source3: https://repo1.maven.org/maven2/org/eclipse/jdt/core/compiler/ecj/%{version}/ecj-%{version}.pom
|
||||
Source4: http://git.eclipse.org/c/jdt/eclipse.jdt.core.git/plain/org.eclipse.jdt.core/scripts/binary/META-INF/MANIFEST.MF
|
||||
# Extracted from https://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/%{qualifier}/ecj-%{version}.jar
|
||||
Source4: MANIFEST.MF
|
||||
|
||||
# Always generate debug info when building RPMs (Andrew Haley)
|
||||
Patch0: %{name}-rpmdebuginfo.patch
|
||||
# build.xml fails to include a necessary .props file in the built ecj.jar
|
||||
Patch1: %{name}-include-props.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -34,7 +33,6 @@ the JDT Core batch compiler.
|
||||
%prep
|
||||
%setup -q -c
|
||||
%patch0 -p1
|
||||
%patch1 -b .sav
|
||||
|
||||
sed -i -e 's|debuglevel=\"lines,source\"|debug=\"yes\"|g' build.xml
|
||||
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
|
||||
@ -57,7 +55,7 @@ rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java
|
||||
%mvn_alias org.eclipse.jdt.core.compiler:ecj \
|
||||
org.eclipse.jdt:org.eclipse.jdt.core org.eclipse.jdt:org.eclipse.jdt.compiler.apt \
|
||||
org.eclipse.tycho:org.eclipse.jdt.core org.eclipse.tycho:org.eclipse.jdt.compiler.apt \
|
||||
org.eclipse.jetty.orbit:org.eclipse.jdt.core \
|
||||
org.eclipse.jetty.orbit:org.eclipse.jdt.core org.eclipse.jetty.orbit:org.eclipse.jdt.compiler.apt \
|
||||
org.eclipse.jdt:core
|
||||
|
||||
%build
|
||||
@ -70,7 +68,6 @@ gzip ecj.1
|
||||
|
||||
# Install the ecj wrapper script
|
||||
install -p -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/ecj
|
||||
sed --in-place "s:@JAVADIR@:%{_javadir}:" $RPM_BUILD_ROOT%{_bindir}/ecj
|
||||
|
||||
# Install manpage
|
||||
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
@ -82,6 +79,9 @@ install -m 644 -p ecj.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/ecj.1.gz
|
||||
%{_mandir}/man1/ecj.1.gz
|
||||
|
||||
%changelog
|
||||
* Tue Oct 06 2015 Mat Booth <mat.booth@redhat.com> - 1:4.5.1-1
|
||||
- Update to Mars.1 release
|
||||
|
||||
* Thu Jul 2 2015 Alexander Kurtakov <akurtako@redhat.com> 1:4.5-1
|
||||
- Update to upstream 4.5 release.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user