Update to latest release
Amend license tag
This commit is contained in:
parent
bbdc5dcc32
commit
1b8266442b
22
ecj.spec
22
ecj.spec
@ -1,13 +1,13 @@
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
%global qualifier M-4.7.3aRC2-201803300640
|
%global qualifier S-4.9RC2-201809060745
|
||||||
|
|
||||||
Summary: Eclipse Compiler for Java
|
Summary: Eclipse Compiler for Java
|
||||||
Name: ecj
|
Name: ecj
|
||||||
Version: 4.7.3a
|
Version: 4.9
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.eclipse.org
|
URL: http://www.eclipse.org
|
||||||
License: EPL
|
License: EPL-2.0
|
||||||
|
|
||||||
Source0: http://download.eclipse.org/eclipse/downloads/drops4/%{qualifier}/ecjsrc-%{version}RC2.jar
|
Source0: http://download.eclipse.org/eclipse/downloads/drops4/%{qualifier}/ecjsrc-%{version}RC2.jar
|
||||||
Source1: ecj.sh.in
|
Source1: ecj.sh.in
|
||||||
@ -20,11 +20,8 @@ Source5: java10api.jar
|
|||||||
# Always generate debug info when building RPMs (Andrew Haley)
|
# Always generate debug info when building RPMs (Andrew Haley)
|
||||||
Patch0: %{name}-rpmdebuginfo.patch
|
Patch0: %{name}-rpmdebuginfo.patch
|
||||||
|
|
||||||
# Fix build with lambda syntax, ebz#520940
|
|
||||||
Patch1: java8.patch
|
|
||||||
|
|
||||||
# Include java API stubs in build
|
# Include java API stubs in build
|
||||||
Patch2: javaAPI.patch
|
Patch1: javaAPI.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -38,8 +35,7 @@ the JDT Core batch compiler.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -c
|
%setup -q -c
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p3
|
%patch1
|
||||||
%patch2 -b.orig
|
|
||||||
|
|
||||||
sed -i -e 's|debuglevel=\"lines,source\"|debug=\"yes\"|g' build.xml
|
sed -i -e 's|debuglevel=\"lines,source\"|debug=\"yes\"|g' build.xml
|
||||||
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
|
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
|
||||||
@ -79,11 +75,15 @@ mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
|
|||||||
install -m 644 -p ecj.1 $RPM_BUILD_ROOT%{_mandir}/man1/ecj.1
|
install -m 644 -p ecj.1 $RPM_BUILD_ROOT%{_mandir}/man1/ecj.1
|
||||||
|
|
||||||
%files -f .mfiles
|
%files -f .mfiles
|
||||||
%doc about.html
|
%license about.html
|
||||||
%{_bindir}/ecj
|
%{_bindir}/ecj
|
||||||
%{_mandir}/man1/ecj*
|
%{_mandir}/man1/ecj*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 12 2018 Mat Booth <mat.booth@redhat.com> - 1:4.9-1
|
||||||
|
- Update to latest release
|
||||||
|
- Amend license tag
|
||||||
|
|
||||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.7.3a-2
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.7.3a-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
38
java8.patch
38
java8.patch
@ -1,38 +0,0 @@
|
|||||||
From 40575084a51619788a032ee4ee3698c47358575b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mat Booth
|
|
||||||
Date: Mon, 14 Aug 2017 14:19:48 +0100
|
|
||||||
Subject: Bug 520940 - ecj cannot be built since introduction of java 1.8
|
|
||||||
lambda syntax
|
|
||||||
|
|
||||||
Change-Id: Ib65c17e614d96de44416b0ede1f059c63df47130
|
|
||||||
Signed-off-by: Mat Booth <mat.booth@redhat.com>
|
|
||||||
---
|
|
||||||
org.eclipse.jdt.core/scripts/build.xml | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/org.eclipse.jdt.core/scripts/build.xml b/org.eclipse.jdt.core/scripts/build.xml
|
|
||||||
index 3fbdb3e..f7e951d 100644
|
|
||||||
--- a/org.eclipse.jdt.core/scripts/build.xml
|
|
||||||
+++ b/org.eclipse.jdt.core/scripts/build.xml
|
|
||||||
@@ -22,8 +22,8 @@
|
|
||||||
|
|
||||||
<javac srcdir="${basedir}" destdir="${output}"
|
|
||||||
debuglevel="lines,source"
|
|
||||||
- source="1.7"
|
|
||||||
- target="1.7">
|
|
||||||
+ source="1.8"
|
|
||||||
+ target="1.8">
|
|
||||||
<compilerarg line="-Xlint:none"/>
|
|
||||||
</javac>
|
|
||||||
|
|
||||||
@@ -43,4 +43,4 @@
|
|
||||||
</zip>
|
|
||||||
<delete dir="${output}" />
|
|
||||||
</target>
|
|
||||||
-</project>
|
|
||||||
\ No newline at end of file
|
|
||||||
+</project>
|
|
||||||
--
|
|
||||||
cgit v1.1
|
|
||||||
|
|
||||||
|
|
@ -24,25 +24,3 @@
|
|||||||
</javac>
|
</javac>
|
||||||
|
|
||||||
<delete file="${basedir}/META-INF/MANIFEST.MF" failonerror="false"/>
|
<delete file="${basedir}/META-INF/MANIFEST.MF" failonerror="false"/>
|
||||||
--- org/eclipse/jdt/internal/compiler/env/IModulePathEntry.java.orig 2018-03-20 15:38:22.373710813 +0000
|
|
||||||
+++ org/eclipse/jdt/internal/compiler/env/IModulePathEntry.java 2018-03-20 15:39:46.541393267 +0000
|
|
||||||
@@ -10,7 +10,6 @@
|
|
||||||
*******************************************************************************/
|
|
||||||
package org.eclipse.jdt.internal.compiler.env;
|
|
||||||
|
|
||||||
-import org.eclipse.jdt.core.IJavaProject;
|
|
||||||
import org.eclipse.jdt.core.compiler.CharOperation;
|
|
||||||
|
|
||||||
/**
|
|
||||||
@@ -80,9 +79,4 @@
|
|
||||||
public default boolean isAutomaticModule() {
|
|
||||||
return false;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
- /** Tests whether the current entry represents the given java project. */
|
|
||||||
- public default boolean equalsProject(IJavaProject project) {
|
|
||||||
- return false;
|
|
||||||
- }
|
|
||||||
-}
|
|
||||||
\ No newline at end of file
|
|
||||||
+}
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (ecjsrc-4.7.3aRC2.jar) = c6886bf1b21f47ba68f55fff40b2c02f6032e2b491a79d374c2596418a04c994d243623a3efef747f36edefdb5f2731a475e972a1191d7e002beaecc2ef9d5e5
|
SHA512 (ecjsrc-4.9RC2.jar) = 7171fdc50aa7e8e32becae2f2b9c285982c36defa9e6413d4d13e2654e73e4b06ac20075e1ac22937a2147dc8d57e2a8587a57d4349118b2f11dd51749cec799
|
||||||
SHA512 (ecj-4.7.3a.pom) = a4eb5656867b88817dfe2776320c5a91f2d2402372a993e7698bc5846d5dd05f0bfb9808ed2e514e442438595cf05db0df7014c1c957e4c134bb82f236975759
|
SHA512 (ecj-4.9.pom) = 7c573dacfe9dea8066e6f3d3a5407f46f1e874ba8d41127df8d7df94b15559b7ce50701a2fa0ec471897e6d3a1fe0b2b71c4f260b92dbab1b8330e58937cc21f
|
||||||
SHA512 (java10api.jar) = b92faee6a4f7ab3d631e93ed99fffb101035bf7c0dd632dd5322c9e0d2848eeda496d6cf4d28122c88173fb7fcacc77ce40f2822e923903cec47114c9a25c242
|
SHA512 (java10api.jar) = b92faee6a4f7ab3d631e93ed99fffb101035bf7c0dd632dd5322c9e0d2848eeda496d6cf4d28122c88173fb7fcacc77ce40f2822e923903cec47114c9a25c242
|
||||||
|
Loading…
Reference in New Issue
Block a user