Add patch to generate full debuginfo for ecj itself
This commit is contained in:
parent
9a2c272e9e
commit
1a0c361ec1
21
ecj-generatedebuginfo.patch
Normal file
21
ecj-generatedebuginfo.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up ./build.xml.sav ./build.xml
|
||||
--- ./build.xml.sav 2009-03-11 13:30:38.000000000 -0400
|
||||
+++ ./build.xml 2009-03-11 13:30:34.000000000 -0400
|
||||
@@ -10,7 +10,7 @@
|
||||
<mkdir dir="${output}" />
|
||||
|
||||
<javac srcdir="${basedir}" destdir="${output}"
|
||||
- debuglevel="lines,source"
|
||||
+ debug="yes"
|
||||
source="1.3"
|
||||
target="1.2"
|
||||
excludes="org/eclipse/jdt/internal/compiler/tool/*,**/apt/**">
|
||||
@@ -18,7 +18,7 @@
|
||||
</javac>
|
||||
|
||||
<javac destdir="${output}"
|
||||
- debuglevel="lines,source"
|
||||
+ debug="yes"
|
||||
source="1.6"
|
||||
target="1.6"
|
||||
includes="org/eclipse/jdt/internal/compiler/tool/*">
|
7
ecj.spec
7
ecj.spec
@ -8,7 +8,7 @@ Epoch: 1
|
||||
Summary: Eclipse Compiler for Java
|
||||
Name: ecj
|
||||
Version: 3.4.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
URL: http://www.eclipse.org
|
||||
License: EPL
|
||||
Group: Development/Languages
|
||||
@ -24,6 +24,7 @@ Source2: %{name}-gcj.tar.bz2
|
||||
# Always generate debug info when building RPMs (Andrew Haley)
|
||||
Patch0: %{name}-rpmdebuginfo.patch
|
||||
Patch1: %{name}-defaultto1.5.patch
|
||||
Patch2: %{name}-generatedebuginfo.patch
|
||||
|
||||
BuildRequires: gcc-java >= 4.0.0
|
||||
BuildRequires: /usr/bin/aot-compile-rpm
|
||||
@ -48,6 +49,7 @@ the JDT Core batch compiler.
|
||||
%setup -q -c
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Use ECJ for GCJ's bytecode compiler
|
||||
tar jxf %{SOURCE2}
|
||||
@ -119,6 +121,9 @@ fi
|
||||
%{_libdir}/gcj/%{name}
|
||||
|
||||
%changelog
|
||||
* Wed Mar 11 2009 Deepak Bhole <dbhole@redhat.com> 1:3.4.2-4
|
||||
- Add patch to generate full debuginfo for ecj itself
|
||||
|
||||
* Tue Mar 10 2009 Deepak Bhole <dbhole@redhat.com> 1:3.4.2-3
|
||||
- Add BR for aot-compile-rpm
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user