diff --git a/.cvsignore b/.cvsignore
index e69de29..b4c3b6c 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -0,0 +1 @@
+easymock-1.2-src.tar.gz
diff --git a/easymock-1.2-build_xml.patch b/easymock-1.2-build_xml.patch
new file mode 100644
index 0000000..bfbeb89
--- /dev/null
+++ b/easymock-1.2-build_xml.patch
@@ -0,0 +1,30 @@
+--- build.xml.sav 2005-08-07 17:53:29.000000000 +0200
++++ build.xml 2006-02-24 16:25:45.000000000 +0100
+@@ -17,7 +17,7 @@
+
+
+
+-
++
+
+
+
+@@ -99,14 +99,16 @@
+
+
+
+-
++
+
+
+-
++
+
+
+
++
+
+
+
diff --git a/easymock-1.2_Java1.5.pom b/easymock-1.2_Java1.5.pom
new file mode 100644
index 0000000..82fbac3
--- /dev/null
+++ b/easymock-1.2_Java1.5.pom
@@ -0,0 +1,7 @@
+
+ 4.0.0
+ easymock
+ easymock
+ EasyMock 1.2_Java1.5
+ 1.2_Java1.5
+
diff --git a/easymock-component-info.xml b/easymock-component-info.xml
new file mode 100644
index 0000000..95ec60d
--- /dev/null
+++ b/easymock-component-info.xml
@@ -0,0 +1,21 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/easymock.spec b/easymock.spec
new file mode 100644
index 0000000..103b98d
--- /dev/null
+++ b/easymock.spec
@@ -0,0 +1,172 @@
+# Copyright (c) 2000-2009, JPackage Project
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the
+# distribution.
+# 3. Neither the name of the JPackage Project nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+Name: easymock
+Version: 1.2
+Release: 9%{?dist}
+Epoch: 0
+Summary: Easy mock objects
+Group: Development/Libraries
+License: MIT
+URL: http://www.easymock.org/
+# cvs -d:pserver:anonymous@easymock.cvs.sourceforge.net:/cvsroot/easymock login
+# cvs -z3 -d:pserver:anonymous@easymock.cvs.sourceforge.net:/cvsroot/easymock export -r EasyMock1_2_Java1_3 easymock
+# tar czf easymock-1.2-src.tar.gz easymock
+Source0: easymock-1.2-src.tar.gz
+Source1: http://repo1.maven.org/maven2/easymock/easymock/1.2_Java1.5/easymock-1.2_Java1.5.pom
+Source2: easymock-component-info.xml
+Patch0: easymock-1.2-build_xml.patch
+Requires(post): jpackage-utils >= 1.7.2
+Requires(postun): jpackage-utils >= 1.7.2
+BuildRequires: jpackage-utils >= 0:1.6
+BuildRequires: ant >= 0:1.6
+BuildRequires: ant-junit >= 0:1.6
+BuildRequires: junit >= 0:3.8.1
+BuildRequires: java-devel >= 0:1.5.0
+BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+
+%description
+EasyMock provides Mock Objects for interfaces in JUnit tests by generating
+them on the fly using Java's proxy mechanism. Due to EasyMock's unique style
+of recording expectations, most refactorings will not affect the Mock Objects.
+So EasyMock is a perfect fit for Test-Driven Development.
+
+%package javadoc
+Summary: Javadoc for %{name}
+Group: Documentation
+
+%description javadoc
+Javadoc for %{name}.
+
+%prep
+%setup -q -n %{name}
+%patch0 -p0
+mkdir lib
+pushd lib
+ln -sf $(build-classpath junit) .
+popd
+
+# We no longer ship a 1.3/1.4 VM, Set it to generic javahome
+rm easymockbuild.properties
+echo "java\ 1.3=%{java}" >> easymockbuild.properties
+echo "java\ 1.4=%{java}" >> easymockbuild.properties
+echo "java\ 1.5=%{java}" >> easymockbuild.properties
+echo "java\ compiler=%{javac}" >> easymockbuild.properties
+
+%build
+export OPT_JAR_LIST="ant/ant-junit junit"
+export CLASSPATH=
+%{ant} -Dbuild.sysclasspath=first
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+unzip -qq %{name}%{version}_Java1.3.zip
+install -dm 755 $RPM_BUILD_ROOT%{_javadir}
+
+install -pm 644 %{name}%{version}_Java1.3/%{name}.jar \
+ $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
+ln -s %{name}-%{version}.jar \
+ $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
+
+# javadoc
+install -dm 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
+cp -pr %{name}%{version}_Java1.3/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
+ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
+
+# pom
+install -dm 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/
+%add_to_maven_depmap easymock easymock %{version}_Java1.5 JPP easymock
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%update_maven_depmap
+
+%postun
+%update_maven_depmap
+
+%files
+%defattr(0644,root,root,0755)
+%doc %{name}%{version}_Java1.3/{Documentation,License}.html
+%{_datadir}/maven2/*
+%{_mavendepmapfragdir}/*
+%{_javadir}/%{name}-%{version}.jar
+%{_javadir}/%{name}.jar
+
+%files javadoc
+%defattr(0644,root,root,0755)
+%{_javadocdir}/%{name}-%{version}
+%{_javadocdir}/%{name}
+
+%changelog
+* Mon May 18 2009 Fernando Nasser 0:1.2-9
+- Update instructions for obtaining source tar ball
+
+* Mon May 04 2009 Yong Yang 0:1.2-8
+- Rebuild with maven2-2.0.8 built in non-bootstrap mode
+
+* Wed Mar 18 2009 Yong Yang 0:1.2-7
+- merge from JPP-6
+- rebuild with new maven2 2.0.8 built in bootstrap mode
+
+* Mon Feb 02 2009 David Walluck 0:1.2-6
+- fix component-info.xml
+
+* Mon Feb 02 2009 David Walluck 0:1.2-5
+- remove unneeded maven flag
+
+* Mon Feb 02 2009 David Walluck 0:1.2-4
+- add repolib
+
+* Fri Jan 30 2009 Will Tatam 1.2-3.jpp5
+- Inital JPP-5 Build
+
+* Fri Jan 09 2009 Yong Yang 1.2-2jpp.1
+- Imported from dbhole's maven 2.0.8 packages, initial building on jpp6
+
+* Fri Apr 11 2008 Deepak Bhole 1.2-1jpp.1
+- Import from JPackage
+- Add pom file
+
+* Fri Feb 24 2006 Ralph Apel - 0:1.2-1jpp
+- Update to 1.2 keeping only java 1.4 requirement
+
+* Fri Feb 24 2006 Ralph Apel - 0:1.1-3jpp
+- drop java-1.3.1 requirement
+
+* Mon Oct 04 2004 Ralph Apel - 0:1.1-2jpp
+- Fixed Url, Summary, Description and License
+
+* Mon Oct 04 2004 Ralph Apel - 0:1.1-1jpp
+- First JPackage release
diff --git a/sources b/sources
index e69de29..d820270 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+f6a02c912ad98d485141d240faf68440 easymock-1.2-src.tar.gz