* Tue Jun 18 2008 Eric Sandeen <sandeen@redhat.com> 1.41-0.WIP.0617
- New upstream snapshot release for ext4 capability
This commit is contained in:
parent
4e751fe1f3
commit
ca67f32f40
@ -1 +1 @@
|
||||
e2fsprogs-1.40.10.tar.gz
|
||||
e2fsprogs-1.41-WIP-0617.tar.gz
|
||||
|
@ -1,59 +0,0 @@
|
||||
[PATCH] blkid: more sanity checks for swap v1
|
||||
|
||||
mkswap followed by pvcreate on a block device
|
||||
will still turn up as "swap" in blkid, because
|
||||
pvcreate isn't particularly careful about zeroing
|
||||
old signatures. (neither is mkswap, for that matter).
|
||||
|
||||
Testing for appropriate version and page counts
|
||||
gives us a bit more confidence that we have a
|
||||
real swap (v1) partition.
|
||||
|
||||
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
|
||||
---
|
||||
lib/blkid/probe.c | 7 ++++++-
|
||||
1 files changed, 6 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/lib/blkid/probe.c b/lib/blkid/probe.c
|
||||
index 45885c3..a070201 100644
|
||||
--- a/lib/blkid/probe.c
|
||||
+++ b/lib/blkid/probe.c
|
||||
@@ -827,7 +827,7 @@ static int probe_swap0(struct blkid_probe *probe,
|
||||
}
|
||||
|
||||
static int probe_swap1(struct blkid_probe *probe,
|
||||
- struct blkid_magic *id __BLKID_ATTR((unused)),
|
||||
+ struct blkid_magic *id,
|
||||
unsigned char *buf __BLKID_ATTR((unused)))
|
||||
{
|
||||
struct swap_id_block *sws;
|
||||
@@ -843,6 +843,11 @@ static int probe_swap1(struct blkid_probe *probe,
|
||||
if (!sws)
|
||||
return 1;
|
||||
|
||||
+ /* check for wrong version or zeroed pagecount, for sanity */
|
||||
+ if (!memcmp(id->bim_magic, "SWAPSPACE2", id->bim_len) &&
|
||||
+ (sws->sws_version != 1 || sws->sws_lastpage == 0))
|
||||
+ return 1;
|
||||
+
|
||||
/* arbitrary sanity check.. is there any garbage down there? */
|
||||
if (sws->sws_pad[32] == 0 && sws->sws_pad[33] == 0) {
|
||||
if (sws->sws_volume[0])
|
||||
--- a/lib/blkid/test_probe.in 2008-05-12 11:50:41.580983841 -0500
|
||||
+++ b/lib/blkid/test_probe.in 2008-05-12 11:51:21.323436536 -0500
|
||||
@@ -20,6 +20,15 @@ do
|
||||
continue
|
||||
fi
|
||||
bunzip2 < $SRCDIR/tests/$i.img.bz2 > /tmp/test.img.$$
|
||||
+ # swap is native-endian, so regenerate before testing
|
||||
+ if [ "$i" == "swap0" ]; then
|
||||
+ dd if=/dev/zero of=/tmp/test.img.$$ bs=1024 count=1 seek=1024
|
||||
+ mkswap -v0 /tmp/test.img.$$ > /dev/null
|
||||
+ elif [ "$i" == "swap1" ]; then
|
||||
+ dd if=/dev/zero of=/tmp/test.img.$$ bs=1024 count=1 seek=1024
|
||||
+ mkswap -v1 -L SWAP-TEST -U 8ff8e77f-8553-485e-8656-58be67a81666 /tmp/test.img.$$ >/dev/null
|
||||
+ fi
|
||||
+
|
||||
./tst_probe /tmp/test.img.$$ > tests/$i.out
|
||||
/bin/rm -f /tmp/test.img.$$ tests/$i.ok tests/$i.failed
|
||||
cmp -s tests/$i.out $SRCDIR/tests/$i.results
|
28
e2fsprogs-1.41-buildfix
Normal file
28
e2fsprogs-1.41-buildfix
Normal file
@ -0,0 +1,28 @@
|
||||
Commit: 51d12cebb61ca00f5455fe6e25938cd79fea15ab in pu fails to build
|
||||
"make check".
|
||||
|
||||
Signed-off-by: Jose R. Santos <jrs@us.ibm.com>
|
||||
---
|
||||
|
||||
e2fsck/Makefile.in | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/e2fsck/Makefile.in b/e2fsck/Makefile.in
|
||||
index 32743bc..0186112 100644
|
||||
--- a/e2fsck/Makefile.in
|
||||
+++ b/e2fsck/Makefile.in
|
||||
@@ -143,12 +143,12 @@ tst_crc32: $(srcdir)/crc32.c $(LIBEXT2FS)
|
||||
tst_refcount: ea_refcount.c
|
||||
@echo " LD $@"
|
||||
@$(CC) -o tst_refcount $(srcdir)/ea_refcount.c \
|
||||
- $(ALL_CFLAGS) -DTEST_PROGRAM -lcom_err
|
||||
+ $(ALL_CFLAGS) -DTEST_PROGRAM -L$(LIB) -lcom_err
|
||||
|
||||
tst_region: region.c
|
||||
@echo " LD $@"
|
||||
@$(CC) -o tst_region $(srcdir)/region.c \
|
||||
- $(ALL_CFLAGS) -DTEST_PROGRAM -lcom_err
|
||||
+ $(ALL_CFLAGS) -DTEST_PROGRAM -L$(LIB) -lcom_err
|
||||
|
||||
check:: tst_refcount tst_region tst_crc32
|
||||
./tst_refcount
|
19
e2fsprogs-1.41-fix-mkswap-tests
Normal file
19
e2fsprogs-1.41-fix-mkswap-tests
Normal file
@ -0,0 +1,19 @@
|
||||
Index: devel/e2fsprogs-1.41-WIP/lib/blkid/test_probe.in
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41-WIP.orig/lib/blkid/test_probe.in 2008-06-16 12:08:45.000000000 -0500
|
||||
+++ e2fsprogs-1.41-WIP/lib/blkid/test_probe.in 2008-06-16 14:56:33.437233901 -0500
|
||||
@@ -20,10 +20,13 @@ do
|
||||
continue
|
||||
fi
|
||||
bunzip2 < $SRCDIR/tests/$i.img.bz2 > tests/tmp/test.img.$$
|
||||
- # swap is native-endian, so regenerate before testing
|
||||
if [ "$i" = "swap0" ]; then
|
||||
+ # swap is native-endian, so regenerate before testing
|
||||
+ dd if=/dev/zero of=tests/tmp/test.img.$$ bs=16k count=64
|
||||
mkswap -v0 tests/tmp/test.img.$$ > /dev/null
|
||||
elif [ "$i" = "swap1" ]; then
|
||||
+ # swap is native-endian, so regenerate before testing
|
||||
+ dd if=/dev/zero of=tests/tmp/test.img.$$ bs=16k count=64
|
||||
mkswap -v1 -L SWAP-TEST -U 8ff8e77f-8553-485e-8656-58be67a81666 tests/tmp/test.img.$$ >/dev/null
|
||||
fi
|
||||
./tst_probe tests/tmp/test.img.$$ > tests/$i.out
|
@ -3,19 +3,20 @@
|
||||
|
||||
Summary: Utilities for managing the second and third extended (ext2/ext3) filesystems
|
||||
Name: e2fsprogs
|
||||
Version: 1.40.10
|
||||
Release: 3%{?dist}
|
||||
Version: 1.41
|
||||
Release: 0.WIP.0617%{?dist}
|
||||
# License based on upstream-modified COPYING file,
|
||||
# which clearly states "V2" intent.
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}-WIP-0617.tar.gz
|
||||
Source1: ext2_types-wrapper.h
|
||||
Source2: blkid_types-wrapper.h
|
||||
Source3: uuidd.init
|
||||
Patch1: e2fsprogs-1.38-etcblkid.patch
|
||||
Patch2: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
|
||||
Patch3: e2fsprogs-1.40.8-blkid-swap-tests.patch
|
||||
Patch3: e2fsprogs-1.41-buildfix
|
||||
Patch4: e2fsprogs-1.41-fix-mkswap-tests
|
||||
|
||||
Url: http://e2fsprogs.sourceforge.net/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -92,8 +93,8 @@ SMP systems.
|
||||
# mildly unsafe but 'til I get something better, avoid full fsck
|
||||
# after an selinux install...
|
||||
%patch2 -p1 -b .featurecheck
|
||||
# check a bit more in swapv1 headers before recognizing as swap
|
||||
%patch3 -p1 -b .swapchecks
|
||||
%patch3 -p1 -b .buildfix
|
||||
%patch4 -p1 -b .mkswap
|
||||
|
||||
%build
|
||||
%configure --enable-elf-shlibs --enable-nls --disable-e2initrd-helper --enable-blkid-devmapper --enable-blkid-selinux
|
||||
@ -178,14 +179,19 @@ fi
|
||||
%{_root_sbindir}/e2fsck
|
||||
%{_root_sbindir}/e2image
|
||||
%{_root_sbindir}/e2label
|
||||
%{_root_sbindir}/e2undo
|
||||
%{_root_sbindir}/findfs
|
||||
%{_root_sbindir}/fsck
|
||||
%{_root_sbindir}/fsck.ext2
|
||||
%{_root_sbindir}/fsck.ext3
|
||||
%{_root_sbindir}/fsck.ext4
|
||||
%{_root_sbindir}/fsck.ext4dev
|
||||
%{_root_sbindir}/logsave
|
||||
%{_root_sbindir}/mke2fs
|
||||
%{_root_sbindir}/mkfs.ext2
|
||||
%{_root_sbindir}/mkfs.ext3
|
||||
%{_root_sbindir}/mkfs.ext4
|
||||
%{_root_sbindir}/mkfs.ext4dev
|
||||
%{_root_sbindir}/resize2fs
|
||||
%{_root_sbindir}/tune2fs
|
||||
%{_sbindir}/filefrag
|
||||
@ -210,13 +216,18 @@ fi
|
||||
%{_mandir}/man8/filefrag.8*
|
||||
%{_mandir}/man8/fsck.ext2.8*
|
||||
%{_mandir}/man8/fsck.ext3.8*
|
||||
%{_mandir}/man8/fsck.ext4.8*
|
||||
%{_mandir}/man8/fsck.ext4dev.8*
|
||||
%{_mandir}/man8/e2image.8*
|
||||
%{_mandir}/man8/e2label.8*
|
||||
%{_mandir}/man8/e2undo.8*
|
||||
%{_mandir}/man8/fsck.8*
|
||||
%{_mandir}/man8/logsave.8*
|
||||
%{_mandir}/man8/mke2fs.8*
|
||||
%{_mandir}/man8/mkfs.ext2.8*
|
||||
%{_mandir}/man8/mkfs.ext3.8*
|
||||
%{_mandir}/man8/mkfs.ext4.8*
|
||||
%{_mandir}/man8/mkfs.ext4dev.8*
|
||||
%{_mandir}/man8/mklost+found.8*
|
||||
%{_mandir}/man8/resize2fs.8*
|
||||
%{_mandir}/man8/tune2fs.8*
|
||||
@ -282,6 +293,9 @@ fi
|
||||
%dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
|
||||
|
||||
%changelog
|
||||
* Tue Jun 18 2008 Eric Sandeen <sandeen@redhat.com> 1.41-0.WIP.0617
|
||||
- New upstream snapshot release for ext4 capability
|
||||
|
||||
* Wed Jun 04 2008 Eric Sandeen <sandeen@redhat.com> 1.40.10-3
|
||||
- Tidy up multilib hack for non-multilib arches (#446016)
|
||||
- Fix up %postun script (#449868)
|
||||
|
Loading…
Reference in New Issue
Block a user