- Fix up UTF-8 formatting in e2fsck output (#655227)
This commit is contained in:
parent
7698e77296
commit
9801d97ede
574
e2fsprogs-1.41.12-UTF8-chars.patch
Normal file
574
e2fsprogs-1.41.12-UTF8-chars.patch
Normal file
@ -0,0 +1,574 @@
|
||||
commit 61ef2474c24c80a5bf0e24ba85a7506fd7651a5c
|
||||
Author: Theodore Ts'o <tytso@mit.edu>
|
||||
Date: Sun Aug 1 22:30:33 2010 -0400
|
||||
|
||||
badblocks: Deal with UTF-8 characters in progress message
|
||||
|
||||
Addresses-Gentoo-Bug: #309909
|
||||
Addresses-Debian-Bug: #583782
|
||||
Addresses-Debian-Bug: #587834
|
||||
|
||||
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index d563a8d..aaeb177 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -1,10 +1,12 @@
|
||||
#! /bin/sh
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
-# Generated by GNU Autoconf 2.64.
|
||||
+# Generated by GNU Autoconf 2.65.
|
||||
+#
|
||||
#
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
|
||||
-# 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software
|
||||
-# Foundation, Inc.
|
||||
+# 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
|
||||
+# Inc.
|
||||
+#
|
||||
#
|
||||
# This configure script is free software; the Free Software Foundation
|
||||
# gives unlimited permission to copy, distribute and modify it.
|
||||
@@ -524,7 +526,8 @@ as_tr_cpp="eval sed 'y%*$as_cr_letters%P$as_cr_LETTERS%;s%[^_$as_cr_alnum]%_%g'"
|
||||
as_tr_sh="eval sed 'y%*+%pp%;s%[^_$as_cr_alnum]%_%g'"
|
||||
|
||||
|
||||
-exec 7<&0 </dev/null 6>&1
|
||||
+test -n "$DJDIR" || exec 7<&0 </dev/null
|
||||
+exec 6>&1
|
||||
|
||||
# Name of the host.
|
||||
# hostname on some systems (SVR3.2, Linux) returns a bogus exit status,
|
||||
@@ -588,6 +591,7 @@ ac_includes_default="\
|
||||
# include <unistd.h>
|
||||
#endif"
|
||||
|
||||
+ac_header_list=
|
||||
ac_subst_vars='LTLIBOBJS
|
||||
LIBOBJS
|
||||
BUILD_LDFLAGS
|
||||
@@ -1478,7 +1482,7 @@ Some influential environment variables:
|
||||
LDFLAGS linker flags, e.g. -L<lib dir> if you have libraries in a
|
||||
nonstandard directory <lib dir>
|
||||
LIBS libraries to pass to the linker, e.g. -l<library>
|
||||
- CPPFLAGS C/C++/Objective C preprocessor flags, e.g. -I<include dir> if
|
||||
+ CPPFLAGS (Objective) C/C++ preprocessor flags, e.g. -I<include dir> if
|
||||
you have headers in a nonstandard directory <include dir>
|
||||
CPP C preprocessor
|
||||
PKG_CONFIG path to pkg-config utility
|
||||
@@ -1550,7 +1554,7 @@ test -n "$ac_init_help" && exit $ac_status
|
||||
if $ac_init_version; then
|
||||
cat <<\_ACEOF
|
||||
configure
|
||||
-generated by GNU Autoconf 2.64
|
||||
+generated by GNU Autoconf 2.65
|
||||
|
||||
Copyright (C) 2009 Free Software Foundation, Inc.
|
||||
This configure script is free software; the Free Software Foundation
|
||||
@@ -1597,7 +1601,7 @@ sed 's/^/| /' conftest.$ac_ext >&5
|
||||
ac_retval=1
|
||||
fi
|
||||
eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
||||
- return $ac_retval
|
||||
+ as_fn_set_status $ac_retval
|
||||
|
||||
} # ac_fn_c_try_compile
|
||||
|
||||
@@ -1643,7 +1647,7 @@ fi
|
||||
# left behind by Apple's compiler. We do this before executing the actions.
|
||||
rm -rf conftest.dSYM conftest_ipa8_conftest.oo
|
||||
eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
||||
- return $ac_retval
|
||||
+ as_fn_set_status $ac_retval
|
||||
|
||||
} # ac_fn_c_try_link
|
||||
|
||||
@@ -1680,7 +1684,7 @@ sed 's/^/| /' conftest.$ac_ext >&5
|
||||
ac_retval=1
|
||||
fi
|
||||
eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
||||
- return $ac_retval
|
||||
+ as_fn_set_status $ac_retval
|
||||
|
||||
} # ac_fn_c_try_cpp
|
||||
|
||||
@@ -1809,7 +1813,7 @@ sed 's/^/| /' conftest.$ac_ext >&5
|
||||
fi
|
||||
rm -rf conftest.dSYM conftest_ipa8_conftest.oo
|
||||
eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
||||
- return $ac_retval
|
||||
+ as_fn_set_status $ac_retval
|
||||
|
||||
} # ac_fn_c_try_run
|
||||
|
||||
@@ -2139,7 +2143,7 @@ rm -f conftest.val
|
||||
|
||||
fi
|
||||
eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
||||
- return $ac_retval
|
||||
+ as_fn_set_status $ac_retval
|
||||
|
||||
} # ac_fn_c_compute_int
|
||||
|
||||
@@ -2243,7 +2247,7 @@ This file contains any messages produced by compilers while
|
||||
running configure, to aid debugging if configure makes a mistake.
|
||||
|
||||
It was created by $as_me, which was
|
||||
-generated by GNU Autoconf 2.64. Invocation command line was
|
||||
+generated by GNU Autoconf 2.65. Invocation command line was
|
||||
|
||||
$ $0 $@
|
||||
|
||||
@@ -2496,7 +2500,7 @@ fi
|
||||
for ac_site_file in "$ac_site_file1" "$ac_site_file2"
|
||||
do
|
||||
test "x$ac_site_file" = xNONE && continue
|
||||
- if test -r "$ac_site_file"; then
|
||||
+ if test /dev/null != "$ac_site_file" && test -r "$ac_site_file"; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: loading site script $ac_site_file" >&5
|
||||
$as_echo "$as_me: loading site script $ac_site_file" >&6;}
|
||||
sed 's/^/| /' "$ac_site_file" >&5
|
||||
@@ -2505,9 +2509,9 @@ $as_echo "$as_me: loading site script $ac_site_file" >&6;}
|
||||
done
|
||||
|
||||
if test -r "$cache_file"; then
|
||||
- # Some versions of bash will fail to source /dev/null (special
|
||||
- # files actually), so we avoid doing that.
|
||||
- if test -f "$cache_file"; then
|
||||
+ # Some versions of bash will fail to source /dev/null (special files
|
||||
+ # actually), so we avoid doing that. DJGPP emulates it as a regular file.
|
||||
+ if test /dev/null != "$cache_file" && test -f "$cache_file"; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: loading cache $cache_file" >&5
|
||||
$as_echo "$as_me: loading cache $cache_file" >&6;}
|
||||
case $cache_file in
|
||||
@@ -2521,6 +2525,9 @@ $as_echo "$as_me: creating cache $cache_file" >&6;}
|
||||
>$cache_file
|
||||
fi
|
||||
|
||||
+as_fn_append ac_header_list " stdlib.h"
|
||||
+as_fn_append ac_header_list " unistd.h"
|
||||
+as_fn_append ac_header_list " sys/param.h"
|
||||
# Check that the precious variables saved in the cache have kept the same
|
||||
# value.
|
||||
ac_cache_corrupted=false
|
||||
@@ -3067,32 +3074,30 @@ $as_echo "$ac_try_echo"; } >&5
|
||||
... rest of stderr output deleted ...
|
||||
10q' conftest.err >conftest.er1
|
||||
cat conftest.er1 >&5
|
||||
- rm -f conftest.er1 conftest.err
|
||||
fi
|
||||
+ rm -f conftest.er1 conftest.err
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }
|
||||
done
|
||||
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
-#include <stdio.h>
|
||||
+
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-FILE *f = fopen ("conftest.out", "w");
|
||||
- return ferror (f) || fclose (f) != 0;
|
||||
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
_ACEOF
|
||||
ac_clean_files_save=$ac_clean_files
|
||||
-ac_clean_files="$ac_clean_files a.out a.out.dSYM a.exe b.out conftest.out"
|
||||
+ac_clean_files="$ac_clean_files a.out a.out.dSYM a.exe b.out"
|
||||
# Try to create an executable without -o first, disregard a.out.
|
||||
# It will help us diagnose broken compilers, and finding out an intuition
|
||||
# of exeext.
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for C compiler default output file name" >&5
|
||||
-$as_echo_n "checking for C compiler default output file name... " >&6; }
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the C compiler works" >&5
|
||||
+$as_echo_n "checking whether the C compiler works... " >&6; }
|
||||
ac_link_default=`$as_echo "$ac_link" | sed 's/ -o *conftest[^ ]*//'`
|
||||
|
||||
# The possible output files:
|
||||
@@ -3154,10 +3159,10 @@ test "$ac_cv_exeext" = no && ac_cv_exeext=
|
||||
else
|
||||
ac_file=''
|
||||
fi
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_file" >&5
|
||||
-$as_echo "$ac_file" >&6; }
|
||||
if test -z "$ac_file"; then :
|
||||
- $as_echo "$as_me: failed program was:" >&5
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
+$as_echo "no" >&6; }
|
||||
+$as_echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
|
||||
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
@@ -3165,51 +3170,18 @@ $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
{ as_fn_set_status 77
|
||||
as_fn_error "C compiler cannot create executables
|
||||
See \`config.log' for more details." "$LINENO" 5; }; }
|
||||
+else
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
+$as_echo "yes" >&6; }
|
||||
fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for C compiler default output file name" >&5
|
||||
+$as_echo_n "checking for C compiler default output file name... " >&6; }
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_file" >&5
|
||||
+$as_echo "$ac_file" >&6; }
|
||||
ac_exeext=$ac_cv_exeext
|
||||
|
||||
-# Check that the compiler produces executables we can run. If not, either
|
||||
-# the compiler is broken, or we cross compile.
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the C compiler works" >&5
|
||||
-$as_echo_n "checking whether the C compiler works... " >&6; }
|
||||
-# If not cross compiling, check that we can run a simple program.
|
||||
-if test "$cross_compiling" != yes; then
|
||||
- if { ac_try='./$ac_file'
|
||||
- { { case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo"; } >&5
|
||||
- (eval "$ac_try") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; }; then
|
||||
- cross_compiling=no
|
||||
- else
|
||||
- if test "$cross_compiling" = maybe; then
|
||||
- cross_compiling=yes
|
||||
- else
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error "cannot run C compiled programs.
|
||||
-If you meant to cross compile, use \`--host'.
|
||||
-See \`config.log' for more details." "$LINENO" 5; }
|
||||
- fi
|
||||
- fi
|
||||
-fi
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
-
|
||||
-rm -f -r a.out a.out.dSYM a.exe conftest$ac_cv_exeext b.out conftest.out
|
||||
+rm -f -r a.out a.out.dSYM a.exe conftest$ac_cv_exeext b.out
|
||||
ac_clean_files=$ac_clean_files_save
|
||||
-# Check that the compiler produces executables we can run. If not, either
|
||||
-# the compiler is broken, or we cross compile.
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether we are cross compiling" >&5
|
||||
-$as_echo_n "checking whether we are cross compiling... " >&6; }
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $cross_compiling" >&5
|
||||
-$as_echo "$cross_compiling" >&6; }
|
||||
-
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for suffix of executables" >&5
|
||||
$as_echo_n "checking for suffix of executables... " >&6; }
|
||||
if { { ac_try="$ac_link"
|
||||
@@ -3242,13 +3214,72 @@ $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
as_fn_error "cannot compute suffix of executables: cannot compile and link
|
||||
See \`config.log' for more details." "$LINENO" 5; }
|
||||
fi
|
||||
-rm -f conftest$ac_cv_exeext
|
||||
+rm -f conftest conftest$ac_cv_exeext
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_exeext" >&5
|
||||
$as_echo "$ac_cv_exeext" >&6; }
|
||||
|
||||
rm -f conftest.$ac_ext
|
||||
EXEEXT=$ac_cv_exeext
|
||||
ac_exeext=$EXEEXT
|
||||
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#include <stdio.h>
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+FILE *f = fopen ("conftest.out", "w");
|
||||
+ return ferror (f) || fclose (f) != 0;
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+ac_clean_files="$ac_clean_files conftest.out"
|
||||
+# Check that the compiler produces executables we can run. If not, either
|
||||
+# the compiler is broken, or we cross compile.
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether we are cross compiling" >&5
|
||||
+$as_echo_n "checking whether we are cross compiling... " >&6; }
|
||||
+if test "$cross_compiling" != yes; then
|
||||
+ { { ac_try="$ac_link"
|
||||
+case "(($ac_try" in
|
||||
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
+ *) ac_try_echo=$ac_try;;
|
||||
+esac
|
||||
+eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
|
||||
+$as_echo "$ac_try_echo"; } >&5
|
||||
+ (eval "$ac_link") 2>&5
|
||||
+ ac_status=$?
|
||||
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
+ test $ac_status = 0; }
|
||||
+ if { ac_try='./conftest$ac_cv_exeext'
|
||||
+ { { case "(($ac_try" in
|
||||
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
+ *) ac_try_echo=$ac_try;;
|
||||
+esac
|
||||
+eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
|
||||
+$as_echo "$ac_try_echo"; } >&5
|
||||
+ (eval "$ac_try") 2>&5
|
||||
+ ac_status=$?
|
||||
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
+ test $ac_status = 0; }; }; then
|
||||
+ cross_compiling=no
|
||||
+ else
|
||||
+ if test "$cross_compiling" = maybe; then
|
||||
+ cross_compiling=yes
|
||||
+ else
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
+$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
+as_fn_error "cannot run C compiled programs.
|
||||
+If you meant to cross compile, use \`--host'.
|
||||
+See \`config.log' for more details." "$LINENO" 5; }
|
||||
+ fi
|
||||
+ fi
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $cross_compiling" >&5
|
||||
+$as_echo "$cross_compiling" >&6; }
|
||||
+
|
||||
+rm -f conftest.$ac_ext conftest$ac_cv_exeext conftest.out
|
||||
+ac_clean_files=$ac_clean_files_save
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for suffix of object files" >&5
|
||||
$as_echo_n "checking for suffix of object files... " >&6; }
|
||||
if test "${ac_cv_objext+set}" = set; then :
|
||||
@@ -3905,8 +3936,8 @@ $as_echo "$ac_try_echo"; } >&5
|
||||
... rest of stderr output deleted ...
|
||||
10q' conftest.err >conftest.er1
|
||||
cat conftest.er1 >&5
|
||||
- rm -f conftest.er1 conftest.err
|
||||
fi
|
||||
+ rm -f conftest.er1 conftest.err
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }
|
||||
done
|
||||
@@ -6792,10 +6823,14 @@ _ACEOF
|
||||
|
||||
fi
|
||||
|
||||
-for ac_header in stdlib.h unistd.h
|
||||
+
|
||||
+
|
||||
+
|
||||
+ for ac_header in $ac_header_list
|
||||
do :
|
||||
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
||||
-ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
|
||||
+ac_fn_c_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default
|
||||
+"
|
||||
eval as_val=\$$as_ac_Header
|
||||
if test "x$as_val" = x""yes; then :
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
@@ -6806,6 +6841,13 @@ fi
|
||||
|
||||
done
|
||||
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
for ac_func in getpagesize
|
||||
do :
|
||||
ac_fn_c_check_func "$LINENO" "getpagesize" "ac_cv_func_getpagesize"
|
||||
@@ -6862,11 +6904,6 @@ char *malloc ();
|
||||
|
||||
/* This mess was copied from the GNU getpagesize.h. */
|
||||
#ifndef HAVE_GETPAGESIZE
|
||||
-/* Assume that all systems that can run configure have sys/param.h. */
|
||||
-# ifndef HAVE_SYS_PARAM_H
|
||||
-# define HAVE_SYS_PARAM_H 1
|
||||
-# endif
|
||||
-
|
||||
# ifdef _SC_PAGESIZE
|
||||
# define getpagesize() sysconf(_SC_PAGESIZE)
|
||||
# else /* no _SC_PAGESIZE */
|
||||
@@ -6901,8 +6938,9 @@ int
|
||||
main ()
|
||||
{
|
||||
char *data, *data2, *data3;
|
||||
+ const char *cdata2;
|
||||
int i, pagesize;
|
||||
- int fd;
|
||||
+ int fd, fd2;
|
||||
|
||||
pagesize = getpagesize ();
|
||||
|
||||
@@ -6915,27 +6953,41 @@ main ()
|
||||
umask (0);
|
||||
fd = creat ("conftest.mmap", 0600);
|
||||
if (fd < 0)
|
||||
- return 1;
|
||||
+ return 2;
|
||||
if (write (fd, data, pagesize) != pagesize)
|
||||
- return 1;
|
||||
+ return 3;
|
||||
close (fd);
|
||||
|
||||
+ /* Next, check that the tail of a page is zero-filled. File must have
|
||||
+ non-zero length, otherwise we risk SIGBUS for entire page. */
|
||||
+ fd2 = open ("conftest.txt", O_RDWR | O_CREAT | O_TRUNC, 0600);
|
||||
+ if (fd2 < 0)
|
||||
+ return 4;
|
||||
+ cdata2 = "";
|
||||
+ if (write (fd2, cdata2, 1) != 1)
|
||||
+ return 5;
|
||||
+ data2 = (char *) mmap (0, pagesize, PROT_READ | PROT_WRITE, MAP_SHARED, fd2, 0L);
|
||||
+ if (data2 == MAP_FAILED)
|
||||
+ return 6;
|
||||
+ for (i = 0; i < pagesize; ++i)
|
||||
+ if (*(data2 + i))
|
||||
+ return 7;
|
||||
+ close (fd2);
|
||||
+ if (munmap (data2, pagesize))
|
||||
+ return 8;
|
||||
+
|
||||
/* Next, try to mmap the file at a fixed address which already has
|
||||
something else allocated at it. If we can, also make sure that
|
||||
we see the same garbage. */
|
||||
fd = open ("conftest.mmap", O_RDWR);
|
||||
if (fd < 0)
|
||||
- return 1;
|
||||
- data2 = (char *) malloc (2 * pagesize);
|
||||
- if (!data2)
|
||||
- return 1;
|
||||
- data2 += (pagesize - ((long int) data2 & (pagesize - 1))) & (pagesize - 1);
|
||||
+ return 9;
|
||||
if (data2 != mmap (data2, pagesize, PROT_READ | PROT_WRITE,
|
||||
MAP_PRIVATE | MAP_FIXED, fd, 0L))
|
||||
- return 1;
|
||||
+ return 10;
|
||||
for (i = 0; i < pagesize; ++i)
|
||||
if (*(data + i) != *(data2 + i))
|
||||
- return 1;
|
||||
+ return 11;
|
||||
|
||||
/* Finally, make sure that changes to the mapped area do not
|
||||
percolate back to the file as seen by read(). (This is a bug on
|
||||
@@ -6944,12 +6996,12 @@ main ()
|
||||
*(data2 + i) = *(data2 + i) + 1;
|
||||
data3 = (char *) malloc (pagesize);
|
||||
if (!data3)
|
||||
- return 1;
|
||||
+ return 12;
|
||||
if (read (fd, data3, pagesize) != pagesize)
|
||||
- return 1;
|
||||
+ return 13;
|
||||
for (i = 0; i < pagesize; ++i)
|
||||
if (*(data + i) != *(data3 + i))
|
||||
- return 1;
|
||||
+ return 14;
|
||||
close (fd);
|
||||
return 0;
|
||||
}
|
||||
@@ -6971,7 +7023,7 @@ if test $ac_cv_func_mmap_fixed_mapped = yes; then
|
||||
$as_echo "#define HAVE_MMAP 1" >>confdefs.h
|
||||
|
||||
fi
|
||||
-rm -f conftest.mmap
|
||||
+rm -f conftest.mmap conftest.txt
|
||||
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether we are using the GNU C Library 2.1 or newer" >&5
|
||||
@@ -10647,7 +10699,7 @@ if test "$ac_res" != no; then :
|
||||
fi
|
||||
|
||||
fi
|
||||
-for ac_func in chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit blkid_probe_get_topology
|
||||
+for ac_func in chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit blkid_probe_get_topology mbstowcs
|
||||
do :
|
||||
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
|
||||
@@ -11593,7 +11645,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
|
||||
# values after options handling.
|
||||
ac_log="
|
||||
This file was extended by $as_me, which was
|
||||
-generated by GNU Autoconf 2.64. Invocation command line was
|
||||
+generated by GNU Autoconf 2.65. Invocation command line was
|
||||
|
||||
CONFIG_FILES = $CONFIG_FILES
|
||||
CONFIG_HEADERS = $CONFIG_HEADERS
|
||||
@@ -11629,6 +11681,7 @@ Usage: $0 [OPTION]... [TAG]...
|
||||
|
||||
-h, --help print this help, then exit
|
||||
-V, --version print version number and configuration settings, then exit
|
||||
+ --config print configuration, then exit
|
||||
-q, --quiet, --silent
|
||||
do not print progress messages
|
||||
-d, --debug don't remove temporary files
|
||||
@@ -11646,10 +11699,11 @@ Report bugs to the package provider."
|
||||
|
||||
_ACEOF
|
||||
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
|
||||
+ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
|
||||
ac_cs_version="\\
|
||||
config.status
|
||||
-configured by $0, generated by GNU Autoconf 2.64,
|
||||
- with options \\"`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
|
||||
+configured by $0, generated by GNU Autoconf 2.65,
|
||||
+ with options \\"\$ac_cs_config\\"
|
||||
|
||||
Copyright (C) 2009 Free Software Foundation, Inc.
|
||||
This config.status script is free software; the Free Software Foundation
|
||||
@@ -11686,6 +11740,8 @@ do
|
||||
ac_cs_recheck=: ;;
|
||||
--version | --versio | --versi | --vers | --ver | --ve | --v | -V )
|
||||
$as_echo "$ac_cs_version"; exit ;;
|
||||
+ --config | --confi | --conf | --con | --co | --c )
|
||||
+ $as_echo "$ac_cs_config"; exit ;;
|
||||
--debug | --debu | --deb | --de | --d | -d )
|
||||
debug=: ;;
|
||||
--file | --fil | --fi | --f )
|
||||
@@ -11894,7 +11950,7 @@ s/'"$ac_delim"'$//
|
||||
t delim
|
||||
:nl
|
||||
h
|
||||
-s/\(.\{148\}\).*/\1/
|
||||
+s/\(.\{148\}\)..*/\1/
|
||||
t more1
|
||||
s/["\\]/\\&/g; s/^/"/; s/$/\\n"\\/
|
||||
p
|
||||
@@ -11908,7 +11964,7 @@ s/.\{148\}//
|
||||
t nl
|
||||
:delim
|
||||
h
|
||||
-s/\(.\{148\}\).*/\1/
|
||||
+s/\(.\{148\}\)..*/\1/
|
||||
t more2
|
||||
s/["\\]/\\&/g; s/^/"/; s/$/"/
|
||||
p
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 3441bee..5c6b801 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -853,7 +853,7 @@ if test -n "$BLKID_CMT"; then
|
||||
AC_SEARCH_LIBS([blkid_probe_all], [blkid])
|
||||
fi
|
||||
dnl
|
||||
-AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit blkid_probe_get_topology)
|
||||
+AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit blkid_probe_get_topology mbstowcs)
|
||||
dnl
|
||||
dnl Check to see if -lsocket is required (solaris) to make something
|
||||
dnl that uses socket() to compile; this is needed for the UUID library
|
||||
diff --git a/misc/badblocks.c b/misc/badblocks.c
|
||||
index bcf89f7..5d5ca89 100644
|
||||
--- a/misc/badblocks.c
|
||||
+++ b/misc/badblocks.c
|
||||
@@ -203,6 +203,9 @@ static void print_status(void)
|
||||
calc_percent((unsigned long) currently_testing,
|
||||
(unsigned long) num_blocks),
|
||||
time_diff_format(&time_end, &time_start, diff_buf));
|
||||
+#ifdef HAVE_MBSTOWCS
|
||||
+ len = mbstowcs(NULL, line_buf, sizeof(line_buf));
|
||||
+#endif
|
||||
fputs(line_buf, stderr);
|
||||
memset(line_buf, '\b', len);
|
||||
line_buf[len] = 0;
|
@ -4,7 +4,7 @@
|
||||
Summary: Utilities for managing ext2, ext3, and ext4 filesystems
|
||||
Name: e2fsprogs
|
||||
Version: 1.41.12
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
# License tags based on COPYING file distinctions for various components
|
||||
License: GPLv2
|
||||
@ -16,6 +16,7 @@ Patch1: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
|
||||
Patch2: e2fpsrogs-1.41.12-EOFBLOCKS-test.patch
|
||||
Patch3: e2fsprogs-1.41.12-relax-resize2fs-P.patch
|
||||
Patch4: e2fsprogs-1.41.12-e4defrag.patch
|
||||
Patch5: e2fsprogs-1.41.12-UTF8-chars.patch
|
||||
|
||||
Url: http://e2fsprogs.sourceforge.net/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -157,6 +158,8 @@ It was originally inspired by the Multics SubSystem library.
|
||||
%patch3 -p1 -b .resize2fs
|
||||
# e4defrag for testing
|
||||
%patch4 -p1
|
||||
# Fix up UTF8 formatting
|
||||
%patch5 -p1 -b .utf8
|
||||
|
||||
%build
|
||||
%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
|
||||
@ -323,6 +326,9 @@ exit 0
|
||||
%{_libdir}/pkgconfig/ss.pc
|
||||
|
||||
%changelog
|
||||
* Tue Dec 07 2010 Eric Sandeen <sandeen@redhat.com> 1.41.12-7
|
||||
- Fix up UTF-8 formatting in e2fsck output (#655227)
|
||||
|
||||
* Wed Oct 06 2010 Eric Sandeen <sandeen@redhat.com> 1.41.12-6
|
||||
- Install e4defrag for testing
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user