- Add missing dependency info for quota.c - fixes build on s390(x)

This commit is contained in:
Dan Horák 2014-06-30 10:58:39 +02:00
parent b8e8b249ac
commit 6423b6d7cb
2 changed files with 34 additions and 1 deletions

View File

@ -0,0 +1,28 @@
From 5c15bf5f978bae01f1ca3cbe6414ab1d355a6adf Mon Sep 17 00:00:00 2001
From: Theodore Ts'o <tytso@mit.edu>
Date: Thu, 22 May 2014 18:52:27 -0400
Subject: e2fsck: fix Makefile dependency for quota.o
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
diff --git a/e2fsck/Makefile.in b/e2fsck/Makefile.in
index 4b10f6f..f773fea 100644
--- a/e2fsck/Makefile.in
+++ b/e2fsck/Makefile.in
@@ -552,3 +552,13 @@ logfile.o: $(srcdir)/logfile.c $(top_builddir)/lib/config.h \
$(top_srcdir)/lib/quota/dqblk_v2.h $(top_srcdir)/lib/quota/quotaio_tree.h \
$(top_srcdir)/lib/../e2fsck/dict.h
prof_err.o: prof_err.c
+quota.o: $(srcdir)/quota.c $(top_builddir)/lib/config.h \
+ $(top_builddir)/lib/dirpaths.h $(srcdir)/e2fsck.h \
+ $(top_srcdir)/lib/ext2fs/ext2_fs.h $(top_builddir)/lib/ext2fs/ext2_types.h \
+ $(top_srcdir)/lib/ext2fs/ext2fs.h $(top_srcdir)/lib/ext2fs/ext3_extents.h \
+ $(top_srcdir)/lib/et/com_err.h $(top_srcdir)/lib/ext2fs/ext2_io.h \
+ $(top_builddir)/lib/ext2fs/ext2_err.h \
+ $(top_srcdir)/lib/ext2fs/ext2_ext_attr.h $(top_srcdir)/lib/ext2fs/bitops.h \
+ $(srcdir)/profile.h prof_err.h $(top_srcdir)/lib/quota/quotaio.h \
+ $(top_srcdir)/lib/quota/dqblk_v2.h $(top_srcdir)/lib/quota/quotaio_tree.h \
+ $(top_srcdir)/lib/../e2fsck/dict.h $(srcdir)/problem.h
--
cgit v0.10.1

View File

@ -1,7 +1,7 @@
Summary: Utilities for managing ext2, ext3, and ext4 filesystems
Name: e2fsprogs
Version: 1.42.10
Release: 3%{?dist}
Release: 4%{?dist}
# License tags based on COPYING file distinctions for various components
License: GPLv2
@ -12,6 +12,7 @@ Source2: e2fsck.conf
Patch1: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
Patch2: e2fsprogs-1.42.10-largefile.patch
Patch3: e2fsprogs-1.42.10-quota-deps.patch
Url: http://e2fsprogs.sourceforge.net/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -152,6 +153,7 @@ It was originally inspired by the Multics SubSystem library.
# after an selinux install...
%patch1 -p1 -b .featurecheck
%patch2 -p1
%patch3 -p1
%build
%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
@ -327,6 +329,9 @@ exit 0
%{_libdir}/pkgconfig/ss.pc
%changelog
* Mon Jun 30 2014 Dan Horák <dan[at]danny.cz> - 1.42.10-4
- Add missing dependency info for quota.c - fixes build on s390(x)
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.42.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild