* Tue Jan 01 2008 Eric Sandeen <esandeen@redhat.com> 1.40.2-15

- Drop resize_inode removal patch from tune2fs; ostensibly was
  for old kernels which could not mount, but seems to be fine.
- Drop pottcdate removal patch, and don't rebuild .po files,
  causes multilib problems and we generally shouldn't rebuild.
- Drop multilib patch; wrapper header should take care of this now.
- Drop ->open rename, Fedora seems ok with this now.
This commit is contained in:
Eric Sandeen 2008-01-01 19:22:37 +00:00
parent e7a9631152
commit 6260bb65df
5 changed files with 9 additions and 220 deletions

View File

@ -1,17 +0,0 @@
--- e2fsprogs-1.38/po/Makefile.in.in.pottcdate 2005-06-29 19:42:20.000000000 +0200
+++ e2fsprogs-1.38/po/Makefile.in.in 2005-11-10 17:35:39.000000000 +0100
@@ -117,10 +117,12 @@
rm -f $(DOMAIN).1po $(DOMAIN).2po $(DOMAIN).po; \
else \
rm -f $(DOMAIN).1po $(DOMAIN).2po $(srcdir)/$(DOMAIN).pot && \
- mv $(DOMAIN).po $(srcdir)/$(DOMAIN).pot; \
+ sed -f remove-potcdate.sed < $(DOMAIN).po > $(srcdir)/$(DOMAIN).pot && \
+ rm -f $(DOMAIN).po; \
fi; \
else \
- mv $(DOMAIN).po $(srcdir)/$(DOMAIN).pot; \
+ sed -f remove-potcdate.sed < $(DOMAIN).po > $(srcdir)/$(DOMAIN).pot && \
+ rm -f $(DOMAIN).po; \
fi; \
}

View File

@ -1,10 +0,0 @@
--- e2fsprogs-1.38/misc/tune2fs.c.resize_inode 2005-06-20 14:35:27.000000000 +0200
+++ e2fsprogs-1.38/misc/tune2fs.c 2005-09-08 15:51:38.000000000 +0200
@@ -95,6 +95,7 @@
static __u32 ok_features[3] = {
EXT3_FEATURE_COMPAT_HAS_JOURNAL |
+ EXT2_FEATURE_COMPAT_RESIZE_INODE |
EXT2_FEATURE_COMPAT_DIR_INDEX, /* Compat */
EXT2_FEATURE_INCOMPAT_FILETYPE, /* Incompat */
EXT2_FEATURE_RO_COMPAT_SPARSE_SUPER /* R/O compat */

View File

@ -1,88 +0,0 @@
--- e2fsprogs-1.39/lib/ext2fs/ext2_types.h.in.multilib 2006-04-09 03:39:39.000000000 +0200
+++ e2fsprogs-1.39/lib/ext2fs/ext2_types.h.in 2006-07-24 16:14:11.000000000 +0200
@@ -9,6 +9,18 @@
@ASM_TYPES_HEADER@
+#include <bits/wordsize.h>
+# define SIZEOF_SHORT 2
+# define SIZEOF_INT 4
+#if __WORDSIZE == 64
+# define SIZEOF_LONG 8
+#elif __WORDSIZE == 32
+# define SIZEOF_LONG 4
+#else
+# error unknown __WORDSIZE
+#endif
+# define SIZEOF_LONG_LONG 8
+
#ifdef __U8_TYPEDEF
typedef __U8_TYPEDEF __u8;
#else
--- e2fsprogs-1.39/lib/blkid/blkid_types.h.in.multilib 2006-04-09 03:43:44.000000000 +0200
+++ e2fsprogs-1.39/lib/blkid/blkid_types.h.in 2006-07-24 16:14:56.000000000 +0200
@@ -9,6 +9,18 @@
@ASM_TYPES_HEADER@
+#include <bits/wordsize.h>
+# define SIZEOF_SHORT 2
+# define SIZEOF_INT 4
+#if __WORDSIZE == 64
+# define SIZEOF_LONG 8
+#elif __WORDSIZE == 32
+# define SIZEOF_LONG 4
+#else
+# error unknown __WORDSIZE
+#endif
+# define SIZEOF_LONG_LONG 8
+
#ifdef __U8_TYPEDEF
typedef __U8_TYPEDEF __u8;
#else
--- e2fsprogs-1.39/lib/uuid/uuid_types.h.in.multilib 2006-07-24 16:08:53.000000000 +0200
+++ e2fsprogs-1.39/lib/uuid/uuid_types.h.in 2006-07-24 16:10:46.000000000 +0200
@@ -9,6 +9,18 @@
typedef unsigned char uint8_t;
typedef signed char int8_t;
+#include <bits/wordsize.h>
+# define SIZEOF_SHORT 2
+# define SIZEOF_INT 4
+#if __WORDSIZE == 64
+# define SIZEOF_LONG 8
+#elif __WORDSIZE == 32
+# define SIZEOF_LONG 4
+#else
+# error unknown __WORDSIZE
+#endif
+# define SIZEOF_LONG_LONG 8
+
#if (@SIZEOF_INT@ == 8)
typedef int int64_t;
typedef unsigned int uint64_t;
--- e2fsprogs-1.39/configure.in.multilib 2006-07-24 16:06:33.000000000 +0200
+++ e2fsprogs-1.39/configure.in 2006-07-24 16:07:46.000000000 +0200
@@ -611,14 +611,14 @@
ac_cv_sizeof_long_long=8
AC_MSG_WARN([Cross-compiling, so cannot check type sizes; assuming short=2, int=4, long=4, long long=8])
fi
-AC_CHECK_SIZEOF(short)
-AC_CHECK_SIZEOF(int)
-AC_CHECK_SIZEOF(long)
-AC_CHECK_SIZEOF(long long)
-SIZEOF_SHORT=$ac_cv_sizeof_short
-SIZEOF_INT=$ac_cv_sizeof_int
-SIZEOF_LONG=$ac_cv_sizeof_long
-SIZEOF_LONG_LONG=$ac_cv_sizeof_long_long
+dnl AC_CHECK_SIZEOF(short)
+dnl AC_CHECK_SIZEOF(int)
+dnl AC_CHECK_SIZEOF(long)
+dnl AC_CHECK_SIZEOF(long long)
+SIZEOF_SHORT="SIZEOF_SHORT"
+SIZEOF_INT="SIZEOF_INT"
+SIZEOF_LONG="SIZEOF_LONG"
+SIZEOF_LONG_LONG="SIZEOF_LONG_LONG"
AC_SUBST(SIZEOF_SHORT)
AC_SUBST(SIZEOF_INT)
AC_SUBST(SIZEOF_LONG)

View File

@ -1,91 +0,0 @@
Index: e2fsprogs-1.40.2/debugfs/debugfs.c
===================================================================
--- e2fsprogs-1.40.2.orig/debugfs/debugfs.c
+++ e2fsprogs-1.40.2/debugfs/debugfs.c
@@ -62,7 +62,7 @@ static void open_filesystem(char *device
current_fs = NULL;
return;
}
- retval = unix_io_manager->open(data_filename, 0, &data_io);
+ retval = (unix_io_manager->open)(data_filename, 0, &data_io);
if (retval) {
com_err(data_filename, 0, "while opening data source");
current_fs = NULL;
Index: e2fsprogs-1.40.2/e2fsck/journal.c
===================================================================
--- e2fsprogs-1.40.2.orig/e2fsck/journal.c
+++ e2fsprogs-1.40.2/e2fsck/journal.c
@@ -362,7 +362,7 @@ static errcode_t e2fsck_get_journal(e2fs
#ifndef USE_INODE_IO
if (ext_journal)
#endif
- retval = io_ptr->open(journal_name, IO_FLAG_RW,
+ retval = (io_ptr->open)(journal_name, IO_FLAG_RW,
&ctx->journal_io);
if (retval)
goto errout;
Index: e2fsprogs-1.40.2/e2fsck/util.c
===================================================================
--- e2fsprogs-1.40.2.orig/e2fsck/util.c
+++ e2fsprogs-1.40.2/e2fsck/util.c
@@ -435,7 +435,7 @@ blk_t get_backup_sb(e2fsck_t ctx, ext2_f
if (!name || !manager)
goto cleanup;
- if (manager->open(name, 0, &io) != 0)
+ if ((manager->open)(name, 0, &io) != 0)
goto cleanup;
if (ext2fs_get_mem(SUPERBLOCK_SIZE, &buf))
Index: e2fsprogs-1.40.2/lib/ext2fs/initialize.c
===================================================================
--- e2fsprogs-1.40.2.orig/lib/ext2fs/initialize.c
+++ e2fsprogs-1.40.2/lib/ext2fs/initialize.c
@@ -124,7 +124,7 @@ errcode_t ext2fs_initialize(const char *
io_flags = IO_FLAG_RW;
if (flags & EXT2_FLAG_EXCLUSIVE)
io_flags |= IO_FLAG_EXCLUSIVE;
- retval = manager->open(name, io_flags, &fs->io);
+ retval = (manager->open)(name, io_flags, &fs->io);
if (retval)
goto cleanup;
fs->image_io = fs->io;
Index: e2fsprogs-1.40.2/lib/ext2fs/openfs.c
===================================================================
--- e2fsprogs-1.40.2.orig/lib/ext2fs/openfs.c
+++ e2fsprogs-1.40.2/lib/ext2fs/openfs.c
@@ -119,7 +119,7 @@ errcode_t ext2fs_open2(const char *name,
io_flags |= IO_FLAG_RW;
if (flags & EXT2_FLAG_EXCLUSIVE)
io_flags |= IO_FLAG_EXCLUSIVE;
- retval = manager->open(fs->device_name, io_flags, &fs->io);
+ retval = (manager->open)(fs->device_name, io_flags, &fs->io);
if (retval)
goto cleanup;
if (io_options &&
Index: e2fsprogs-1.40.2/lib/ext2fs/test_io.c
===================================================================
--- e2fsprogs-1.40.2.orig/lib/ext2fs/test_io.c
+++ e2fsprogs-1.40.2/lib/ext2fs/test_io.c
@@ -195,7 +195,7 @@ static errcode_t test_open(const char *n
memset(data, 0, sizeof(struct test_private_data));
data->magic = EXT2_ET_MAGIC_TEST_IO_CHANNEL;
if (test_io_backing_manager) {
- retval = test_io_backing_manager->open(name, flags,
+ retval = (test_io_backing_manager->open)(name, flags,
&data->real);
if (retval)
goto cleanup;
Index: e2fsprogs-1.40.2/misc/e2image.c
===================================================================
--- e2fsprogs-1.40.2.orig/misc/e2image.c
+++ e2fsprogs-1.40.2/misc/e2image.c
@@ -584,7 +584,7 @@ static void install_image(char *device,
exit(1);
}
- retval = io_ptr->open(device, IO_FLAG_RW, &io);
+ retval = (io_ptr->open)(device, IO_FLAG_RW, &io);
if (retval) {
com_err(device, 0, "while opening device file");
exit(1);

View File

@ -4,7 +4,7 @@
Summary: Utilities for managing the second and third extended (ext2/ext3) filesystems
Name: e2fsprogs
Version: 1.40.2
Release: 14%{?dist}
Release: 15%{?dist}
# License based on upstream-modified COPYING file,
# which clearly states "V2" intent.
License: GPLv2
@ -12,16 +12,12 @@ Group: System Environment/Base
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Source1: ext2_types-wrapper.h
Source2: blkid_types-wrapper.h
Patch30: e2fsprogs-1.38-resize-inode.patch
Patch32: e2fsprogs-1.38-no_pottcdate.patch
Patch34: e2fsprogs-1.39-blkid-devmapper.patch
Patch36: e2fsprogs-1.38-etcblkid.patch
Patch39: e2fsprogs-1.39-multilib.patch
Patch62: e2fsprogs-1.39-mkinstalldirs.patch
Patch63: e2fsprogs-1.40.2-warning-fixes.patch
Patch64: e2fsprogs-1.40.2-swapfs.patch
Patch65: e2fsprogs-1.40.2-fix-open-create-modes.patch
Patch66: e2fsprogs-1.40.2-protect-open-ops.patch
Patch67: e2fsprogs-1.40.2-blkid-FAT-magic-not-on-strict-position.patch
Patch68: e2fsprogs-1.40.2-blkid-squashfs.patch
Patch69: e2fsprogs-1.40.2-integer-overflows.patch
@ -84,16 +80,10 @@ also want to install e2fsprogs.
%prep
%setup -q -n e2fsprogs-%{version}
# enable tune2fs to set and clear the resize inode (#167816)
%patch30 -p1 -b .resize-inode
# drop timestamp from mo files (#168815/168814/245653)
%patch32 -p1 -b .pottcdate
# look at device mapper devices
%patch34 -p1 -b .dm
# put blkid.tab in /etc/blkid/
%patch36 -p1 -b .etcblkid
# Fix multilib conflicts (#192665)
%patch39 -p1 -b .multilib
# Fix for newer autoconf (#220715)
%patch62 -p1 -b .mkinstalldirs
# Fix type warning in badblocks
@ -102,8 +92,6 @@ also want to install e2fsprogs.
%patch64 -p1 -b .swapfs
# fix one open("foo", O_CREAT) caller with no mode
%patch65 -p1 -b .creatmode
# protect ->open ops from glibc open-create-mode-checker
%patch66 -p1 -b .open
# fix fat probe when there is a real MBR
%patch67 -p1 -b .blkid-fat
# detect squashfs in libblkid (#305151)
@ -115,7 +103,6 @@ also want to install e2fsprogs.
aclocal
autoconf
%configure --enable-elf-shlibs --enable-nls --disable-e2initrd-helper --enable-blkid-devmapper --enable-blkid-selinux
make -C po update-po
make %{?_smp_mflags}
%install
@ -271,6 +258,14 @@ exit 0
%{_mandir}/man3/uuid_unparse.3*
%changelog
* Tue Jan 01 2008 Eric Sandeen <esandeen@redhat.com> 1.40.2-15
- Drop resize_inode removal patch from tune2fs; ostensibly was
for old kernels which could not mount, but seems to be fine.
- Drop pottcdate removal patch, and don't rebuild .po files,
causes multilib problems and we generally shouldn't rebuild.
- Drop multilib patch; wrapper header should take care of this now.
- Drop ->open rename, Fedora seems ok with this now.
* Tue Dec 11 2007 Eric Sandeen <esandeen@redhat.com> 1.40.2-14
- Fix integer overflows (#414591 / CVE-2007-5497)