* Thu Oct 02 2008 Eric Sandeen <sandeen@redhat.com> 1.41.2-1
- New upstream version - Updated default dir hash (half_md4) for better perf & fewer collisions - Fixed ext4 online resizing with flex_bg - ext4 journal now in extents format and in middle of filesystem - fix unreadable e2image files - fix file descriptor leak in libcom_err (#464689)
This commit is contained in:
parent
0fd402e7b1
commit
39baca9f1c
@ -1 +1 @@
|
||||
e2fsprogs-1.41.0.tar.gz
|
||||
e2fsprogs-1.41.2.tar.gz
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- e2fsprogs-1.38/doc/libblkid.txt.etcblkid 2006-03-08 15:02:33.000000000 -0500
|
||||
+++ e2fsprogs-1.38/doc/libblkid.txt 2006-03-08 15:04:08.000000000 -0500
|
||||
@@ -58,7 +58,7 @@
|
||||
Index: e2fsprogs-1.41.1/doc/libblkid.txt
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/doc/libblkid.txt 2007-06-30 07:58:34.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/doc/libblkid.txt 2008-10-01 13:20:34.303063944 -0500
|
||||
@@ -58,7 +58,7 @@ type, or label, or uuid for a particular
|
||||
}
|
||||
|
||||
If a program needs to call multiple blkid functions, then passing in a
|
||||
@ -9,7 +11,7 @@
|
||||
will be repeatedly parsed over and over again, with memory allocated
|
||||
and deallocated. To initialize the blkid cache, blkid_get_cache()
|
||||
function is used:
|
||||
@@ -68,7 +68,7 @@
|
||||
@@ -68,7 +68,7 @@ function is used:
|
||||
|
||||
The second parameter of blkid_get_cache (if non-zero) is the alternate
|
||||
filename of the blkid cache file (where the default is
|
||||
@ -18,9 +20,11 @@
|
||||
|
||||
If you have called blkid_get_cache(), you should call blkid_put_cache()
|
||||
when you are done using the blkid library functions. This will save the
|
||||
--- e2fsprogs-1.38/misc/blkid.8.in.etcblkid 2006-03-08 15:02:46.000000000 -0500
|
||||
+++ e2fsprogs-1.38/misc/blkid.8.in 2006-03-08 15:04:17.000000000 -0500
|
||||
@@ -55,7 +55,7 @@
|
||||
Index: e2fsprogs-1.41.1/misc/blkid.8.in
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/misc/blkid.8.in 2008-08-24 23:19:56.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/misc/blkid.8.in 2008-10-01 13:20:34.303063944 -0500
|
||||
@@ -55,7 +55,7 @@ more devices.
|
||||
Read from
|
||||
.I cachefile
|
||||
instead of reading from the default cache file
|
||||
@ -28,8 +32,8 @@
|
||||
+.IR /etc/blkid/blkid.tab .
|
||||
If you want to start with a clean cache (i.e. don't report devices previously
|
||||
scanned but not necessarily available at this time), specify
|
||||
.IR /dev/null.
|
||||
@@ -139,7 +139,7 @@
|
||||
.IR /dev/null .
|
||||
@@ -133,7 +133,7 @@ Display version number and exit.
|
||||
Write the device cache to
|
||||
.I writecachefile
|
||||
instead of writing it to the default cache file
|
||||
@ -38,20 +42,24 @@
|
||||
If you don't want to save the cache to the default file, specify
|
||||
.IR /dev/null.
|
||||
If not specified it will be the same file as that given by the
|
||||
--- e2fsprogs-1.38/misc/blkid.c.etcblkid 2006-03-08 15:02:39.000000000 -0500
|
||||
+++ e2fsprogs-1.38/misc/blkid.c 2006-03-08 15:04:19.000000000 -0500
|
||||
@@ -40,7 +40,7 @@ static void usage(int error)
|
||||
Index: e2fsprogs-1.41.1/misc/blkid.c
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/misc/blkid.c 2008-08-28 09:26:31.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/misc/blkid.c 2008-10-01 13:20:54.787002093 -0500
|
||||
@@ -52,7 +52,7 @@ static void usage(int error)
|
||||
fprintf(out,
|
||||
"usage:\t%s [-c <file>] [-ghl] [-o format] "
|
||||
"[-s <tag>] [-t <token>]\n [-v] [-w <file>] [dev ...]\n"
|
||||
"usage:\t%s [-c <file>] [-ghlLv] [-o format] "
|
||||
"[-s <tag>] [-t <token>]\n [-w <file>] [dev ...]\n"
|
||||
- "\t-c\tcache file (default: /etc/blkid.tab, /dev/null = none)\n"
|
||||
+ "\t-c\tcache file (default: /etc/blkid/blkid.tab, /dev/null = none)\n"
|
||||
"\t-h\tprint this usage message and exit\n"
|
||||
"\t-g\tgarbage collect the blkid cache\n"
|
||||
"\t-s\tshow specified tag(s) (default show all tags)\n"
|
||||
--- e2fsprogs-1.38/lib/blkid/Makefile.in.etcblkid 2006-03-08 15:04:56.000000000 -0500
|
||||
+++ e2fsprogs-1.38/lib/blkid/Makefile.in 2006-03-08 15:05:59.000000000 -0500
|
||||
@@ -129,9 +129,10 @@
|
||||
Index: e2fsprogs-1.41.1/lib/blkid/Makefile.in
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/lib/blkid/Makefile.in 2008-08-28 09:26:31.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/lib/blkid/Makefile.in 2008-10-01 13:20:34.338002746 -0500
|
||||
@@ -142,9 +142,10 @@ blkid.pc: $(srcdir)/blkid.pc.in $(top_bu
|
||||
@cd $(top_builddir); CONFIG_FILES=lib/blkid/blkid.pc ./config.status
|
||||
|
||||
installdirs::
|
||||
@ -64,7 +72,7 @@
|
||||
|
||||
install:: all installdirs
|
||||
@echo " INSTALL_DATA $(libdir)/libblkid.a"
|
||||
@@ -157,6 +158,7 @@
|
||||
@@ -170,6 +171,7 @@ uninstall::
|
||||
$(RM) -f $(DESTDIR)$(libdir)/libblkid.a \
|
||||
$(DESTDIR)$(libdir)/pkgconfig/blkid.pc
|
||||
$(RM) -rf $(DESTDIR)$(includedir)/blkid
|
||||
@ -72,9 +80,11 @@
|
||||
for i in $(SMANPAGES); do \
|
||||
$(RM) -f $(DESTDIR)$(man3dir)/$$i; \
|
||||
done
|
||||
--- e2fsprogs-1.38/lib/blkid/libblkid.3.in.etcblkid 2006-03-08 15:02:58.000000000 -0500
|
||||
+++ e2fsprogs-1.38/lib/blkid/libblkid.3.in 2006-03-08 15:04:22.000000000 -0500
|
||||
@@ -24,7 +24,7 @@
|
||||
Index: e2fsprogs-1.41.1/lib/blkid/libblkid.3.in
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/lib/blkid/libblkid.3.in 2008-08-24 23:19:56.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/lib/blkid/libblkid.3.in 2008-10-01 13:21:23.992001339 -0500
|
||||
@@ -24,7 +24,7 @@ A common use is to allow use of LABEL= a
|
||||
specific block device names into configuration files.
|
||||
.P
|
||||
Block device information is normally kept in a cache file
|
||||
@ -83,29 +93,33 @@
|
||||
and is verified to still be valid before being returned to the user
|
||||
(if the user has read permission on the raw block device, otherwise not).
|
||||
The cache file also allows unprivileged users (normally anyone other
|
||||
@@ -49,7 +49,7 @@
|
||||
@@ -51,7 +51,7 @@ was written by Andreas Dilger for the ex
|
||||
from Ted Ts'o. The library was subsequently heavily modified by Ted Ts'o.
|
||||
.SH FILES
|
||||
.TP
|
||||
-.I /etc/blkid.tab
|
||||
+.I /etc/blkid/blkid.tab
|
||||
-.I /etc/blkid.tab
|
||||
+.I /etc/blkid/blkid.tab
|
||||
Caches data extracted from each recognized block device.
|
||||
.SH AVAILABILITY
|
||||
.B libblkid
|
||||
--- e2fsprogs-1.38/lib/blkid/blkidP.h.etcblkid 2006-03-08 15:03:04.000000000 -0500
|
||||
+++ e2fsprogs-1.38/lib/blkid/blkidP.h 2006-03-08 15:04:25.000000000 -0500
|
||||
@@ -104,7 +104,7 @@
|
||||
Index: e2fsprogs-1.41.1/lib/blkid/blkidP.h
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/lib/blkid/blkidP.h 2008-08-28 09:26:31.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/lib/blkid/blkidP.h 2008-10-01 13:21:39.192001091 -0500
|
||||
@@ -104,7 +104,7 @@ struct blkid_struct_cache
|
||||
extern char *blkid_strdup(const char *s);
|
||||
extern char *blkid_strndup(const char *s, const int length);
|
||||
|
||||
-#define BLKID_CACHE_FILE "/etc/blkid.tab"
|
||||
+#define BLKID_CACHE_FILE "/etc/blkid/blkid.tab"
|
||||
extern const char *blkid_devdirs[];
|
||||
|
||||
#define BLKID_ERR_IO 5
|
||||
--- e2fsprogs-1.38/RELEASE-NOTES.etcblkid 2006-03-08 15:02:53.000000000 -0500
|
||||
+++ e2fsprogs-1.38/RELEASE-NOTES 2006-03-08 15:04:30.000000000 -0500
|
||||
@@ -718,7 +718,7 @@
|
||||
#define BLKID_ERR_PROC 9
|
||||
Index: e2fsprogs-1.41.1/RELEASE-NOTES
|
||||
===================================================================
|
||||
--- e2fsprogs-1.41.1.orig/RELEASE-NOTES 2008-09-01 15:01:14.000000000 -0500
|
||||
+++ e2fsprogs-1.41.1/RELEASE-NOTES 2008-10-01 13:20:34.383001892 -0500
|
||||
@@ -2460,7 +2460,7 @@ label.
|
||||
|
||||
Fixed a bug in the blkid library wihch could avoid an infinite loop
|
||||
in blkid_find_dev_with_tag() if /proc is not mounted and there the
|
||||
|
@ -1,35 +0,0 @@
|
||||
From: Theodore Ts'o <tytso@mit.edu>
|
||||
Date: Sun, 13 Jul 2008 23:03:59 +0000 (-0400)
|
||||
Subject: libext2fs: Don't check the group checksum when !GDT_CSUM
|
||||
X-Git-Url: http://git.kernel.org/?p=fs%2Fext2%2Fe2fsprogs.git;a=commitdiff_plain;h=4729455f0a68f2fa0a83ec8460d1d4bccba9dcfa
|
||||
|
||||
libext2fs: Don't check the group checksum when !GDT_CSUM
|
||||
|
||||
ext2fs_group_desc_csum_verify() is always checking the bg_checksum (to
|
||||
make sure it is zero) even when the GDT_CSUM feature is not present.
|
||||
This is normally OK, but apparently there are filesystems in the wild
|
||||
where this field has not be initialized to zero.
|
||||
|
||||
Addresses-Debian-Bug: #490637
|
||||
|
||||
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
|
||||
---
|
||||
|
||||
diff --git a/lib/ext2fs/csum.c b/lib/ext2fs/csum.c
|
||||
index ce1508e..6a49d8f 100644
|
||||
--- a/lib/ext2fs/csum.c
|
||||
+++ b/lib/ext2fs/csum.c
|
||||
@@ -60,8 +60,10 @@ STATIC __u16 ext2fs_group_desc_csum(ext2_filsys fs, dgrp_t group)
|
||||
|
||||
int ext2fs_group_desc_csum_verify(ext2_filsys fs, dgrp_t group)
|
||||
{
|
||||
- if (fs->group_desc[group].bg_checksum !=
|
||||
- ext2fs_group_desc_csum(fs, group))
|
||||
+ if (EXT2_HAS_RO_COMPAT_FEATURE(fs->super,
|
||||
+ EXT4_FEATURE_RO_COMPAT_GDT_CSUM) &&
|
||||
+ (fs->group_desc[group].bg_checksum !=
|
||||
+ ext2fs_group_desc_csum(fs, group)))
|
||||
return 0;
|
||||
|
||||
return 1;
|
||||
|
19
e2fsprogs-journal-move.patch
Normal file
19
e2fsprogs-journal-move.patch
Normal file
@ -0,0 +1,19 @@
|
||||
Only move ext4's journal for now; I don't want to change this behavior
|
||||
for ext3 late in the release process.
|
||||
|
||||
Index: e2fsprogs/lib/ext2fs/mkjournal.c
|
||||
===================================================================
|
||||
--- e2fsprogs.orig/lib/ext2fs/mkjournal.c
|
||||
+++ e2fsprogs/lib/ext2fs/mkjournal.c
|
||||
@@ -332,6 +332,10 @@ static errcode_t write_journal_inode(ext
|
||||
es.goal = (fs->super->s_blocks_per_group * group) +
|
||||
fs->super->s_first_data_block;
|
||||
|
||||
+ /* quick conservative hack: if not ext4, just keep the goal at 0 */
|
||||
+ if (!(fs->super->s_feature_incompat & EXT3_FEATURE_INCOMPAT_EXTENTS))
|
||||
+ es.goal = 0;
|
||||
+
|
||||
retval = ext2fs_block_iterate2(fs, journal_ino, BLOCK_FLAG_APPEND,
|
||||
0, mkjournal_proc, &es);
|
||||
if (es.err) {
|
||||
|
@ -3,8 +3,8 @@
|
||||
|
||||
Summary: Utilities for managing the second and third extended (ext2/ext3) filesystems
|
||||
Name: e2fsprogs
|
||||
Version: 1.41.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.41.2
|
||||
Release: 1%{?dist}
|
||||
# License based on upstream-modified COPYING file,
|
||||
# which clearly states "V2" intent.
|
||||
License: GPLv2
|
||||
@ -15,7 +15,7 @@ Source2: blkid_types-wrapper.h
|
||||
Source3: uuidd.init
|
||||
Patch1: e2fsprogs-1.38-etcblkid.patch
|
||||
Patch2: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
|
||||
Patch3: e2fsprogs-1.41-group-checksum-tests
|
||||
Patch3: e2fsprogs-journal-move.patch
|
||||
|
||||
Url: http://e2fsprogs.sourceforge.net/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -92,7 +92,8 @@ SMP systems.
|
||||
# mildly unsafe but 'til I get something better, avoid full fsck
|
||||
# after an selinux install...
|
||||
%patch2 -p1 -b .featurecheck
|
||||
%patch3 -p1 -b .csum
|
||||
# Only change the journal placement for ext4, for now.
|
||||
%patch3 -p1 -b .journalmove
|
||||
|
||||
%build
|
||||
%configure --enable-elf-shlibs --enable-nls --disable-e2initrd-helper --enable-blkid-devmapper --enable-blkid-selinux
|
||||
@ -291,7 +292,15 @@ fi
|
||||
%dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
|
||||
|
||||
%changelog
|
||||
* Thu Jul 10 2008 Eric Sandeen <sandeen@redhat.com> 1.41.0-1
|
||||
* Thu Oct 02 2008 Eric Sandeen <sandeen@redhat.com> 1.41.2-1
|
||||
- New upstream version
|
||||
- Updated default dir hash (half_md4) for better perf & fewer collisions
|
||||
- Fixed ext4 online resizing with flex_bg
|
||||
- ext4 journal now in extents format and in middle of filesystem
|
||||
- fix unreadable e2image files
|
||||
- fix file descriptor leak in libcom_err (#464689)
|
||||
|
||||
* Sat Aug 23 2008 Eric Sandeen <sandeen@redhat.com> 1.41.0-2
|
||||
- Don't check the group checksum when !GDT_CSUM (#459875)
|
||||
|
||||
* Thu Jul 10 2008 Eric Sandeen <sandeen@redhat.com> 1.41.0-1
|
||||
|
Loading…
Reference in New Issue
Block a user