* Thu Jun 4 2009 Karel Zak <kzak@redhat.com> 1.41.6-2
- disable libblkid (replaced by libblkid from util-linux-ng)
This commit is contained in:
parent
95301b8c84
commit
1d6697713b
@ -1,130 +0,0 @@
|
|||||||
Index: e2fsprogs-1.41.5/doc/libblkid.txt
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/doc/libblkid.txt
|
|
||||||
+++ e2fsprogs-1.41.5/doc/libblkid.txt
|
|
||||||
@@ -58,7 +58,7 @@ type, or label, or uuid for a particular
|
|
||||||
}
|
|
||||||
|
|
||||||
If a program needs to call multiple blkid functions, then passing in a
|
|
||||||
-cache value of NULL is not recommended, since the /etc/blkid.tab file
|
|
||||||
+cache value of NULL is not recommended, since the /etc/blkid/blkid.tab file
|
|
||||||
will be repeatedly parsed over and over again, with memory allocated
|
|
||||||
and deallocated. To initialize the blkid cache, blkid_get_cache()
|
|
||||||
function is used:
|
|
||||||
@@ -68,7 +68,7 @@ function is used:
|
|
||||||
|
|
||||||
The second parameter of blkid_get_cache (if non-zero) is the alternate
|
|
||||||
filename of the blkid cache file (where the default is
|
|
||||||
-/etc/blkid.tab). Normally, programs should just pass in NULL.
|
|
||||||
+/etc/blkid/blkid.tab). Normally, programs should just pass in NULL.
|
|
||||||
|
|
||||||
If you have called blkid_get_cache(), you should call blkid_put_cache()
|
|
||||||
when you are done using the blkid library functions. This will save the
|
|
||||||
Index: e2fsprogs-1.41.5/misc/blkid.8.in
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/misc/blkid.8.in
|
|
||||||
+++ e2fsprogs-1.41.5/misc/blkid.8.in
|
|
||||||
@@ -55,7 +55,7 @@ more devices.
|
|
||||||
Read from
|
|
||||||
.I cachefile
|
|
||||||
instead of reading from the default cache file
|
|
||||||
-.IR /etc/blkid.tab .
|
|
||||||
+.IR /etc/blkid/blkid.tab .
|
|
||||||
If you want to start with a clean cache (i.e. don't report devices previously
|
|
||||||
scanned but not necessarily available at this time), specify
|
|
||||||
.IR /dev/null .
|
|
||||||
@@ -133,7 +133,7 @@ Display version number and exit.
|
|
||||||
Write the device cache to
|
|
||||||
.I writecachefile
|
|
||||||
instead of writing it to the default cache file
|
|
||||||
-.IR /etc/blkid.tab .
|
|
||||||
+.IR /etc/blkid/blkid.tab .
|
|
||||||
If you don't want to save the cache to the default file, specify
|
|
||||||
.IR /dev/null.
|
|
||||||
If not specified it will be the same file as that given by the
|
|
||||||
Index: e2fsprogs-1.41.5/misc/blkid.c
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/misc/blkid.c
|
|
||||||
+++ e2fsprogs-1.41.5/misc/blkid.c
|
|
||||||
@@ -52,7 +52,7 @@ static void usage(int error)
|
|
||||||
fprintf(out,
|
|
||||||
"usage:\t%s [-c <file>] [-ghlLv] [-o format] "
|
|
||||||
"[-s <tag>] [-t <token>]\n [-w <file>] [dev ...]\n"
|
|
||||||
- "\t-c\tcache file (default: /etc/blkid.tab, /dev/null = none)\n"
|
|
||||||
+ "\t-c\tcache file (default: /etc/blkid/blkid.tab, /dev/null = none)\n"
|
|
||||||
"\t-h\tprint this usage message and exit\n"
|
|
||||||
"\t-g\tgarbage collect the blkid cache\n"
|
|
||||||
"\t-s\tshow specified tag(s) (default show all tags)\n"
|
|
||||||
Index: e2fsprogs-1.41.5/lib/blkid/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/lib/blkid/Makefile.in
|
|
||||||
+++ e2fsprogs-1.41.5/lib/blkid/Makefile.in
|
|
||||||
@@ -142,9 +142,10 @@ blkid.pc: $(srcdir)/blkid.pc.in $(top_bu
|
|
||||||
@cd $(top_builddir); CONFIG_FILES=lib/blkid/blkid.pc ./config.status
|
|
||||||
|
|
||||||
installdirs::
|
|
||||||
- @echo " MKINSTALLDIRS $(libdir) $(includedir)/blkid"
|
|
||||||
+ @echo " MKINSTALLDIRS $(libdir) $(includedir)/blkid /etc/blkid"
|
|
||||||
@$(MKINSTALLDIRS) $(DESTDIR)$(libdir) \
|
|
||||||
- $(DESTDIR)$(includedir)/blkid $(DESTDIR)$(libdir)/pkgconfig
|
|
||||||
+ $(DESTDIR)$(includedir)/blkid $(DESTDIR)$(libdir)/pkgconfig \
|
|
||||||
+ $(DESTDIR)/etc/blkid
|
|
||||||
|
|
||||||
install:: all installdirs
|
|
||||||
@echo " INSTALL_DATA $(libdir)/libblkid.a"
|
|
||||||
@@ -170,6 +171,7 @@ uninstall::
|
|
||||||
$(RM) -f $(DESTDIR)$(libdir)/libblkid.a \
|
|
||||||
$(DESTDIR)$(libdir)/pkgconfig/blkid.pc
|
|
||||||
$(RM) -rf $(DESTDIR)$(includedir)/blkid
|
|
||||||
+ $(RM) -rf $(DESTDIR)/etc/blkid
|
|
||||||
for i in $(SMANPAGES); do \
|
|
||||||
$(RM) -f $(DESTDIR)$(man3dir)/$$i; \
|
|
||||||
done
|
|
||||||
Index: e2fsprogs-1.41.5/lib/blkid/libblkid.3.in
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/lib/blkid/libblkid.3.in
|
|
||||||
+++ e2fsprogs-1.41.5/lib/blkid/libblkid.3.in
|
|
||||||
@@ -24,7 +24,7 @@ A common use is to allow use of LABEL= a
|
|
||||||
specific block device names into configuration files.
|
|
||||||
.P
|
|
||||||
Block device information is normally kept in a cache file
|
|
||||||
-.I /etc/blkid.tab
|
|
||||||
+.I /etc/blkid/blkid.tab
|
|
||||||
and is verified to still be valid before being returned to the user
|
|
||||||
(if the user has read permission on the raw block device, otherwise not).
|
|
||||||
The cache file also allows unprivileged users (normally anyone other
|
|
||||||
@@ -51,7 +51,7 @@ was written by Andreas Dilger for the ex
|
|
||||||
from Ted Ts'o. The library was subsequently heavily modified by Ted Ts'o.
|
|
||||||
.SH FILES
|
|
||||||
.TP
|
|
||||||
-.I /etc/blkid.tab
|
|
||||||
+.I /etc/blkid/blkid.tab
|
|
||||||
Caches data extracted from each recognized block device.
|
|
||||||
.SH AVAILABILITY
|
|
||||||
.B libblkid
|
|
||||||
Index: e2fsprogs-1.41.5/lib/blkid/blkidP.h
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/lib/blkid/blkidP.h
|
|
||||||
+++ e2fsprogs-1.41.5/lib/blkid/blkidP.h
|
|
||||||
@@ -104,7 +104,7 @@ struct blkid_struct_cache
|
|
||||||
extern char *blkid_strdup(const char *s);
|
|
||||||
extern char *blkid_strndup(const char *s, const int length);
|
|
||||||
|
|
||||||
-#define BLKID_CACHE_FILE "/etc/blkid.tab"
|
|
||||||
+#define BLKID_CACHE_FILE "/etc/blkid/blkid.tab"
|
|
||||||
|
|
||||||
#define BLKID_ERR_IO 5
|
|
||||||
#define BLKID_ERR_PROC 9
|
|
||||||
Index: e2fsprogs-1.41.5/RELEASE-NOTES
|
|
||||||
===================================================================
|
|
||||||
--- e2fsprogs-1.41.5.orig/RELEASE-NOTES
|
|
||||||
+++ e2fsprogs-1.41.5/RELEASE-NOTES
|
|
||||||
@@ -2829,7 +2829,7 @@ label.
|
|
||||||
|
|
||||||
Fixed a bug in the blkid library wihch could avoid an infinite loop
|
|
||||||
in blkid_find_dev_with_tag() if /proc is not mounted and there the
|
|
||||||
-/etc/blkid.tab file has not yet been created.
|
|
||||||
+/etc/blkid/blkid.tab file has not yet been created.
|
|
||||||
|
|
||||||
Fixed the badblocks program so that the destructive read/write test
|
|
||||||
honors the -c option, and to use O_DIRECT when possible to avoid
|
|
@ -4,16 +4,14 @@
|
|||||||
Summary: Utilities for managing ext2, ext3, and ext4 filesystems
|
Summary: Utilities for managing ext2, ext3, and ext4 filesystems
|
||||||
Name: e2fsprogs
|
Name: e2fsprogs
|
||||||
Version: 1.41.6
|
Version: 1.41.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
# License based on upstream-modified COPYING file,
|
# License based on upstream-modified COPYING file,
|
||||||
# which clearly states "V2" intent.
|
# which clearly states "V2" intent.
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
Source1: ext2_types-wrapper.h
|
Source1: ext2_types-wrapper.h
|
||||||
Source2: blkid_types-wrapper.h
|
|
||||||
Source3: uuidd.init
|
Source3: uuidd.init
|
||||||
Patch1: e2fsprogs-1.38-etcblkid.patch
|
|
||||||
Patch2: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
|
Patch2: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
|
||||||
|
|
||||||
Url: http://e2fsprogs.sourceforge.net/
|
Url: http://e2fsprogs.sourceforge.net/
|
||||||
@ -21,7 +19,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|||||||
Requires: e2fsprogs-libs = %{version}-%{release}, device-mapper
|
Requires: e2fsprogs-libs = %{version}-%{release}, device-mapper
|
||||||
Obsoletes: e4fsprogs
|
Obsoletes: e4fsprogs
|
||||||
BuildRequires: pkgconfig, texinfo, libselinux-devel
|
BuildRequires: pkgconfig, texinfo, libselinux-devel
|
||||||
BuildRequires: libsepol-devel, device-mapper-devel, util-linux
|
BuildRequires: libsepol-devel
|
||||||
|
BuildRequires: libblkid-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The e2fsprogs package contains a number of utilities for creating,
|
The e2fsprogs package contains a number of utilities for creating,
|
||||||
@ -86,15 +85,14 @@ SMP systems.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n e2fsprogs-%{version}
|
%setup -q -n e2fsprogs-%{version}
|
||||||
# put blkid.tab in /etc/blkid/
|
|
||||||
%patch1 -p1 -b .etcblkid
|
|
||||||
# ignore some flag differences on primary/backup sb feature checks
|
# ignore some flag differences on primary/backup sb feature checks
|
||||||
# mildly unsafe but 'til I get something better, avoid full fsck
|
# mildly unsafe but 'til I get something better, avoid full fsck
|
||||||
# after an selinux install...
|
# after an selinux install...
|
||||||
%patch2 -p1 -b .featurecheck
|
%patch2 -p1 -b .featurecheck
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-elf-shlibs --enable-nls --disable-e2initrd-helper --enable-blkid-devmapper --enable-blkid-selinux
|
%configure --enable-elf-shlibs --enable-nls \
|
||||||
|
--disable-e2initrd-helper --disable-libblkid
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -110,10 +108,6 @@ make install install-libs DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" \
|
|||||||
mv -f $RPM_BUILD_ROOT%{_includedir}/ext2fs/ext2_types.h \
|
mv -f $RPM_BUILD_ROOT%{_includedir}/ext2fs/ext2_types.h \
|
||||||
$RPM_BUILD_ROOT%{_includedir}/ext2fs/ext2_types-%{_arch}.h
|
$RPM_BUILD_ROOT%{_includedir}/ext2fs/ext2_types-%{_arch}.h
|
||||||
install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/ext2fs/ext2_types.h
|
install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/ext2fs/ext2_types.h
|
||||||
|
|
||||||
mv -f $RPM_BUILD_ROOT%{_includedir}/blkid/blkid_types.h \
|
|
||||||
$RPM_BUILD_ROOT%{_includedir}/blkid/blkid_types-%{_arch}.h
|
|
||||||
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_includedir}/blkid/blkid_types.h
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Our own initscript for uuidd
|
# Our own initscript for uuidd
|
||||||
@ -129,10 +123,6 @@ make check
|
|||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
%post
|
|
||||||
[ -e /etc/blkid.tab ] && mv /etc/blkid.tab /etc/blkid/blkid.tab || :
|
|
||||||
[ -e /etc/blkid.tab.old ] && mv /etc/blkid.tab.old /etc/blkid/blkid.tab.old || :
|
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
@ -167,17 +157,14 @@ fi
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc README RELEASE-NOTES
|
%doc README RELEASE-NOTES
|
||||||
|
|
||||||
%dir /etc/blkid
|
|
||||||
%config(noreplace) /etc/mke2fs.conf
|
%config(noreplace) /etc/mke2fs.conf
|
||||||
%{_root_sbindir}/badblocks
|
%{_root_sbindir}/badblocks
|
||||||
%{_root_sbindir}/blkid
|
|
||||||
%{_root_sbindir}/debugfs
|
%{_root_sbindir}/debugfs
|
||||||
%{_root_sbindir}/dumpe2fs
|
%{_root_sbindir}/dumpe2fs
|
||||||
%{_root_sbindir}/e2fsck
|
%{_root_sbindir}/e2fsck
|
||||||
%{_root_sbindir}/e2image
|
%{_root_sbindir}/e2image
|
||||||
%{_root_sbindir}/e2label
|
%{_root_sbindir}/e2label
|
||||||
%{_root_sbindir}/e2undo
|
%{_root_sbindir}/e2undo
|
||||||
%{_root_sbindir}/findfs
|
|
||||||
%{_root_sbindir}/fsck
|
%{_root_sbindir}/fsck
|
||||||
%{_root_sbindir}/fsck.ext2
|
%{_root_sbindir}/fsck.ext2
|
||||||
%{_root_sbindir}/fsck.ext3
|
%{_root_sbindir}/fsck.ext3
|
||||||
@ -205,11 +192,9 @@ fi
|
|||||||
%{_mandir}/man5/mke2fs.conf.5*
|
%{_mandir}/man5/mke2fs.conf.5*
|
||||||
|
|
||||||
%{_mandir}/man8/badblocks.8*
|
%{_mandir}/man8/badblocks.8*
|
||||||
%{_mandir}/man8/blkid.8*
|
|
||||||
%{_mandir}/man8/debugfs.8*
|
%{_mandir}/man8/debugfs.8*
|
||||||
%{_mandir}/man8/dumpe2fs.8*
|
%{_mandir}/man8/dumpe2fs.8*
|
||||||
%{_mandir}/man8/e2fsck.8*
|
%{_mandir}/man8/e2fsck.8*
|
||||||
%{_mandir}/man8/findfs.8*
|
|
||||||
%{_mandir}/man8/filefrag.8*
|
%{_mandir}/man8/filefrag.8*
|
||||||
%{_mandir}/man8/fsck.ext2.8*
|
%{_mandir}/man8/fsck.ext2.8*
|
||||||
%{_mandir}/man8/fsck.ext3.8*
|
%{_mandir}/man8/fsck.ext3.8*
|
||||||
@ -231,7 +216,6 @@ fi
|
|||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_root_libdir}/libblkid.so.*
|
|
||||||
%{_root_libdir}/libcom_err.so.*
|
%{_root_libdir}/libcom_err.so.*
|
||||||
%{_root_libdir}/libe2p.so.*
|
%{_root_libdir}/libe2p.so.*
|
||||||
%{_root_libdir}/libext2fs.so.*
|
%{_root_libdir}/libext2fs.so.*
|
||||||
@ -244,8 +228,6 @@ fi
|
|||||||
%{_bindir}/compile_et
|
%{_bindir}/compile_et
|
||||||
%{_bindir}/mk_cmds
|
%{_bindir}/mk_cmds
|
||||||
|
|
||||||
%{_libdir}/libblkid.a
|
|
||||||
%{_libdir}/libblkid.so
|
|
||||||
%{_libdir}/libcom_err.a
|
%{_libdir}/libcom_err.a
|
||||||
%{_libdir}/libcom_err.so
|
%{_libdir}/libcom_err.so
|
||||||
%{_libdir}/libe2p.a
|
%{_libdir}/libe2p.a
|
||||||
@ -260,7 +242,6 @@ fi
|
|||||||
|
|
||||||
%{_datadir}/et
|
%{_datadir}/et
|
||||||
%{_datadir}/ss
|
%{_datadir}/ss
|
||||||
%{_includedir}/blkid
|
|
||||||
%{_includedir}/e2p
|
%{_includedir}/e2p
|
||||||
%{_includedir}/et
|
%{_includedir}/et
|
||||||
%{_includedir}/ext2fs
|
%{_includedir}/ext2fs
|
||||||
@ -269,7 +250,6 @@ fi
|
|||||||
%{_mandir}/man1/compile_et.1*
|
%{_mandir}/man1/compile_et.1*
|
||||||
%{_mandir}/man1/mk_cmds.1*
|
%{_mandir}/man1/mk_cmds.1*
|
||||||
%{_mandir}/man3/com_err.3*
|
%{_mandir}/man3/com_err.3*
|
||||||
%{_mandir}/man3/libblkid.3*
|
|
||||||
%{_mandir}/man3/uuid.3*
|
%{_mandir}/man3/uuid.3*
|
||||||
%{_mandir}/man3/uuid_clear.3*
|
%{_mandir}/man3/uuid_clear.3*
|
||||||
%{_mandir}/man3/uuid_compare.3*
|
%{_mandir}/man3/uuid_compare.3*
|
||||||
@ -290,6 +270,9 @@ fi
|
|||||||
%dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
|
%dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 4 2009 Karel Zak <kzak@redhat.com> 1.41.6-2
|
||||||
|
- disable libblkid (replaced by libblkid from util-linux-ng)
|
||||||
|
|
||||||
* Sat May 30 2009 Eric Sandeen <sandeen@redhat.com> 1.41.6-1
|
* Sat May 30 2009 Eric Sandeen <sandeen@redhat.com> 1.41.6-1
|
||||||
- New upstream version
|
- New upstream version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user